Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


OpenCL Grayed Out

New Here ,
Sep 29, 2018 Sep 29, 2018

Copy link to clipboard

Copied

Hi, I do not know why this is happening but it's frustrating me.

The problem is that the OpenCL box is grayed out. Previously, if the box was ok, but when reinstalling the program, it did not let me check the box.

I have a GTX 1050ti graphics card and it's drivers are updated, so I do not know why the box can not be marked. My photoshop is in Spanish but you can easily deduce what is what, I hope you can help me.

Regards!

Views

9.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Advocate , Sep 30, 2018 Sep 30, 2018
Hi, See this video. It will help you to fix the OpenCL Grayed out.How to Fix OpenCL grayed out in Photoshop | Enable Oil Paint Filter Option - YouTube

Likes

Translate

Translate
Advocate ,
Sep 30, 2018 Sep 30, 2018

Copy link to clipboard

Copied

Hi, See this video. It will help you to fix the OpenCL Grayed out.

How to Fix OpenCL grayed out in Photoshop | Enable Oil Paint Filter Option - YouTube

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 30, 2018 Sep 30, 2018

Copy link to clipboard

Copied

  • What operating system are you using?  If Windows 10, do you have the 1803 build installed?
  • Check Device Manager to see the date on the Display Adaptor driver, and see if there was an update that correlates to the Opne CL issue?
  • Try uninstalling and reinstalling the GPU driver.
  • Try rolling back the GPU driver.  With my old system I used to install each NVIDIA driver update as they came out, which seemed like once a month or more.  I was constantly running into issues like not being able to set Drawing Mode to Advanced.  At that time, Perspective Warp would only work with Advanced mode set, so it was a pain.  I don't play games, so I now don't update for the sake of it.  What I am saying is that an earlier driver might fix your issue.
  • Try installing CC 2017 or earlier from the Previous Versions list, and see if they allow Open CL.  Not a fix, but more information to work with.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 10, 2020 Aug 10, 2020

Copy link to clipboard

Copied

I'm having the same problem on an iMac (2011) 27 with a AMD Radeon HD 6770M 512 MB

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

Same problem with MacBook (it supports OpenCL, I checked), everything is up to date.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 20, 2021 Apr 20, 2021

Copy link to clipboard

Copied

multimediafabrig88565216_0-1618910725392.png

Hi,
I kind of have the same problem here but I'm also not able to select the advanced settings
does anybody know what I have to do?
Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

LATEST

Had the same problem. and was getting really anoyed.

checked youtube and google but still nothing worked.

 

then i tryed DDU driver uninstaller

https://www.wagnardsoft.com/content/display-driver-uninstaller-ddu-v18039-released

 

Uninstalled my Nvidia drivers & because i have to GPU's my intel drivers.

Restarted my pc and let Windows reinstall the drivers by itself with Windows update.

 

After the last install of video drivers from Nvidia i restarted my pc 

and I could use OpenCL again. 

 

It worked for me and i hope this will work for other people. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines