Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: Extensions missing after updating to Photoshop 22.3

Community Beginner ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

After installing the latest update of PS all my 3rd party plugins are gone. I was trying to reinstall them, but still, they're not appearing in the program. The only thing that's still working is Raya Pro, but it's installed with the Creative Cloud plugins section. 

 

Does anyone have any idea how to recover the "old" plugins that suppose to be visible under the "window" menu? I was trying to reinstall the plugins, both with a script and manually ad it doesn't help. Maybe there's some different folder now where I should put the extensions that I'm not aware of?

TOPICS
Actions and scripting, macOS, Windows

Views

9.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Beginner , Mar 11, 2021 Mar 11, 2021
-> Filters work when working on an image until you load an image they are gray. I think the problem is the one discovered by Piotrek, old extensions cannot be enabled in preferences and plugins. We hope for future updates. Maybe Adobe could warn

Likes

Translate

Translate
Mar 11, 2021 Mar 11, 2021
 Hi All, We're sorry that some old Extensions are missing for you after updating to Photoshop v22.3 Please note that Extensions are not supported for Mac computer using the M1 processor. Please try and find plugins with the same functionality or contact the extension owner to get your extensions ported to UXP to run as native on M1 devices. You can still use the older extensions in emulation mode if needed. However, you would need to install the extension while running in Rosetta emulatio...

Likes

Translate

Translate
Community Beginner ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

I think I've found the reason why the extensions aren't working.

In the preferences -> plug-ins the whole section "old extensions" is greyed out with unchecked box "load extensions panel".

 

But the question is if there's any workaround to use the extensions bought outside Creative Cloud marketplace?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

hello, I have another problem , may be you have the same . After the upgade to version 22.3, all the filters are ligth grey , can't be opened. No chance. In afddition , tried to use the pen and the program crashed. I also lost all the plug-in.

Walter

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

Luckily, filters works fine in my case. The only thing I noticed that's missing are the extensions

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

-> Filters work when working on an image until you load an image they are gray. I think the problem is the one discovered by Piotrek, old extensions cannot be enabled in preferences and plugins. We hope for future updates. Maybe Adobe could warn

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

Thank you, this saved me from another hour of troubleshooting!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

Same here. I've tried to re-install all the plugins i use. But without success. 

And as Piotrek Deska mentioned the legacy plugin section in preferences is greyed out.

Hopefully Adobe fixes this quickly. I use my plugins on a daily basis.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

For the moment the only solution for me was to downgrade back to 22.2. I'm also wondering if it's on the Adobe's side, or maybe the plugins authors have to recode the extensions since the update is mostly for the M1 Macs, so PS can work natively. Or is it something that Adobe have to fix and the processor type doesn't matter?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

For me too there is no other solution, I work a lot with a panel that creates masks of shades that I cannot give up.

Where I come from it is customary to say "one is always missing to make 100"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

What you can do is to run the new version (22.3) under Rosetta. This is the only way I found to get the extension working. Of course we lose the advantages of runnning on M1 but I hope this is only temporary.

 

If you want to do that you can got to the application folder, select adobe photoshop and with the right click ask the "Get Info". On this new tab you can select to run Photoshop with Rosetta.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

Thanks for the info. I'll definitely try this workaround.

Luckily, even that natively PS was super fast, under Rosetta it also works very well. At least for my needs at the moment. 

 

Hope Adobe will release another update soon and fix the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

thank you for your suggestion

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 01, 2021 Apr 01, 2021

Copy link to clipboard

Copied

I don't even get the option to check the Rosetta mode option. It's just not there. Any suggestions??

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

Hi,

I just upgraded to the new native photoshop for mac M1 chips, however my external extensions are now gone (tk panel, tm panel, orion...). I tried intalling them again with no luck. Does photoshop not support them for the time being?

Thanks,

Andrea

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

I know there's some features like Preset Syncing and video that aren't supported yet.  Not sure about the external extensions

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

Having the same problem. The only extension that is still working is Raya Pro but it was installed from Adobe Marketplace.

I've noticed that the whole section of "old extensions" is greyed in app preferences.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

All old plugins must be made again for native apps. If these are plugins you may have lost them  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

The only way to use again the Extension with the new Phtotoshop version (22.3) on a mac with M1 seems to be running Photoshop under Rosetta.

 

If you want to do this then right click the app Photoshop, go into "Get info" and click on the option open with Rosetta.

Once you do this you start seeing again your old fireds (The plugins ;-))

 

Hopefully it is just a temporary measure that allows Adobe to fix the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

"Hopefully it is just a temporary measure that allows Adobe to fix the issue."

Absolutely not. There is nothing for Adobe to fix. It's a new architecture, and plug-in authors must ALL make new plug-ins. May will not do this and many plug-ins will be lost forever if you run native on M1. Within a few years, there will be no choice.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

Was this at all mentioned by Adobe ??? It comes as a surprise for everybody, apparently.

And what is the difference between Extensions and Plugin ? Will both of need to be rewritten for the M1 version ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

"Was this at all mentioned by Adobe ??? It comes as a surprise for everybody, apparently."

Well, no surprise at all to people who are Mac developers. But I do not say at all that Photoshop users should somehow have know this. The people at Adobe who are really technical (developers) will have known from the moment M1 was announced, but it is not their job to communicate with customers. There is another layer of people for that who (a) may not have this developer knowledge and (b) aren't necessarily immersed in the world of the end user, so as to realise that plug-ins are not just interesting, but vital. Anyway, yes, I think Adobe could certainly have communicated this more, certainly could have qualified every talk of "M1 native" with this info. But that might be seen as negative, and big companies have people in charge of removing everything negative from every presentation and manual.  Apple will have known too, but it's their job to sell new hardware.

"And what is the difference between Extensions and Plugin ? Will both of need to be rewritten for the M1 version ?" That I don't know. Because, while I make plug-ins for Adobe products, I don't make them for Photoshop. It's about whether they are written in C, which is not something a customer can even know. Can anyone clarify? I observe an Adobe reply saying " Please note that Extensions are not supported for Mac computer using the M1 processor. Please try and find plugins with the same functionality " 

The message seems to be - get everything new. The unwritten message is - and lots of things will never be available, but who really cares about that stuff anyway?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

I always thought plugins comparing to extensions are limited tools that can be added to filters menu, so something simple for certain task, while extensions are panels for more complex stuff.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

Are you answering to yourself having other account: @Andrea5C8D

And who's that other @andrea5C1E, posting in the linked thread? 😕

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

ahahah...no, if I had the answer, I would have asked the question...I think is just a coincidence (some other Andrea somewhere in the world) 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines