Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Photoshop cc 2019 Brush Lag and Bugs

Community Beginner ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Hey guys, after updating to PS CC2019 I'm having a ton of issues with the brush tool.

1. After I make multiple consecutive brush strokes photoshop cant seem to quite keep up, if I make 5 brush strokes in rapid succession the first one may appear in real time but they rapidly begin to fall behind where my cursor actually is. This does not happen in cc2018 where i'm using the exact same brush on the same document size. These are simple round brushes on small documents, I'm really not pushing it. (This may have improved with a preference reset its hard to tell)

2. It seems to occasionally (every 3rd to 5th input) skip a brushstroke, making only a single low opacity circle or no mark at all without drawing the rest of the line. I can scrub the cursor across the document at full pressure and it makes no mark till I lift the pen off the tablet to make a new mark.

3. If I hold a brushstroke for any more than a second or two I get a busy cursor (a ring of rotating dots) this happens no matter if Im using my mouse or the wacom. It no longer allows me to see the brush tip shape but will continue to make the brush stroke just fine. This happens no matter how small the document or how simple the brush.

To clarify I have reset my photoshop preferences repeatedly, made sure I have updated wacom drivers. These seem explicitly connected to 2019s brush engine because I can compare them side by side and not have any of these problems in 2018. Also their performance preferences are set up identically but I have tried increasing them in 2019 and it seems to make no impact. Thanks for the help!

-Ben

iMac (Retina 5K, 27-inch, Late 2014)
macOS Mojave 10.14

4 GHz Intel Core i7

32 GB 1600 MHz DDR3

AMD Radeon R9 M295X 4096 MB

Wacom Cintiq 27QHD

TOPICS
Performance

Views

35.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
replies 112 Replies 112
New Here ,
Oct 19, 2018 Oct 19, 2018

Copy link to clipboard

Copied

I‘ve got exactly the same problem as you do, and I tested it with my Magic Mouse which doesn’t lag compare to Wacom tablet. Then problem might be PS 2019 with Wacom

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 19, 2018 Oct 19, 2018

Copy link to clipboard

Copied

Interesting, when I use my mouse I can definitely recreate it but it's a little more inconsistent. But both the brush lag and busy cursor will eventually appear and the skipped brush strokes tend to happen after a long complex stroke.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 28, 2018 Nov 28, 2018

Copy link to clipboard

Copied

wacom had an update around the same time as photoshop and ive been wondering, bc before ps update, my more paint like brushes...looked more paint like and now they seem more dulled.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 19, 2018 Oct 19, 2018

Copy link to clipboard

Copied

I have the same problem. It shows up both when I use the magic trackpad and when I use my Wacom Bamboo tablet. Longtime user of Photoshop--since Photoshop 2.0--and I've never seen this problem before.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 19, 2018 Oct 19, 2018

Copy link to clipboard

Copied

UPDATE: Ok so interestingly enough I can no longer recreate the issue it seems to have disappeared on it's own which is weird since I didn't do any updates or change the conditions I was operating in and I did quite a few restarts. However I did have an adobe employee on twitter suggest turning on "legacy compositing" in the performance menu. So that might help you guys who have this as a persistent issue. Let me know if it helps!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 21, 2018 Oct 21, 2018

Copy link to clipboard

Copied

I was so hopeful when I read that suggestion (turning on legacy composting), but there has been no change for me! Huge lag on the brush, and can't generate anything except short stumpy strokes! Painting with the brush is a huge part of my job and this is crippling my work, seriously regretting this update! The transform tool changes are also pushing me to madness ha!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

UPDATE #2: Ok so it's actually still happening (with legacy compositing on) just more inconsistent than I thought. I'm starting to get skipped brush strokes again where I have to make the same mark multiple times to even get one to appear. The busy cursor is also back, as soon as I hold a brushstroke for more than about a second.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

UPDATE #3: Alright I saw somewhere else that I should try hiding rulers, and it made a HUGE difference. I can't speak to the more inconsistent bugs but the busy cursor is definitely influenced by ruler visibility. Hide those and it goes away and doesn't lag anymore! It would also explain the inconsistency of the bug if I sometimes had the ruler on or off.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

Thanks for the updating for this spinning wheel issue! However, my ruler weren't on, and even after I switched the ruler on & off, it still doesn't help, . Many people have this problem, and it seems to do only with the Mac OS Mojave. The problem is really inconsistent, it's just annoying while retouching photos. Anyway, thanks a lot benzweifel 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 22, 2018 Oct 22, 2018

Copy link to clipboard

Copied

Hi Ben! Thanks for that hint - save the day! You are absolutely right - i switched off the ruler and it works with the brush again! Many Many Thanks. Hope Adobe will fix that issue in a short time.

Regards, Roger

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 02, 2018 Nov 02, 2018

Copy link to clipboard

Copied

hey! thanks a lot for the suggestion! that worked for me!

Macbook Pro Retina 15

Late 2015

MacOS Mojave

Photoshop CC 2019

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 02, 2019 Dec 02, 2019

Copy link to clipboard

Copied

thanks so very very much....turning off the rulers.....brilliant. An 80 % improvement on the lag

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 28, 2020 Nov 28, 2020

Copy link to clipboard

Copied

LATEST

I have tried everything and nothing worked (legacy, openCL and GL, smoothing, reset, etc etc).

Turning off rulers worked though! Thank you so much! This explains why this happens from time to time. I never made the connection but it makes sense now (sometimes I accidentally hit CTRL R when my fingers are flying across the hotkeys)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 23, 2018 Oct 23, 2018

Copy link to clipboard

Copied

Same Problem!

my set up:
Macbook Pro 2018
Mojave OS
Wacom intuos Pro 2017

I didn't experience this issue with PS CC 2018 and Mojave. But now I definitely am. And my set up is too new to have this kind of problem so it's definitely stuff to be fixed.
Illustrator 2019 and Premiere 2019 work smoothly though. Photoshop is always a pain in the ass when updating.
Cheers.

Steve

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 23, 2018 Oct 23, 2018

Copy link to clipboard

Copied

Have you also reinstalled MacOS software?

If so, you may have confused your preferences or if you've not updated PS in a while you may have a new (old) feature. Brush smoothing.

I like the smoothing feature and use it between 5-25% for regular use, however if you change it to 0% does the issue still occur? If so, can you share a screenshot of your photoshop set up and then it may highlight some settings.

Screen Shot 2018-10-23 at 09.15.55.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 24, 2018 Oct 24, 2018

Copy link to clipboard

Copied

For those suggesting brush smoothing, I know what my smoothing is set to and these problems persist whether it's on or off. This isn't a performance issue, it's a set of bugs that strictly occur when rulers are visible. Have a look: Photoshop CC 2019 Busy Cursor - YouTube

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 25, 2018 Oct 25, 2018

Copy link to clipboard

Copied

Damn the switching off of the rulers helped! That's a strange thing. I didn't uncheck the graphic card box though, it didn't matter once the rulers were hidden it "seemed" to not show busy cursor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 13, 2019 Mar 13, 2019

Copy link to clipboard

Copied

Switching off the rulers also worked for me. I do not understand why, but it does.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 08, 2019 Mar 08, 2019

Copy link to clipboard

Copied

Thanks! Turning the rulers off worked for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 13, 2019 Mar 13, 2019

Copy link to clipboard

Copied

So it did for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 27, 2018 Nov 27, 2018

Copy link to clipboard

Copied

Thx varDale=undefined I have lowered the smoothing from 100% to 10% and it helped smoothing.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 18, 2019 Mar 18, 2019

Copy link to clipboard

Copied

Thank you for the smoothing hint.. I tried so many other hints.. this one fixed.. I am sooooo glad.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 23, 2018 Oct 23, 2018

Copy link to clipboard

Copied

im on windows 10. edit>purge>all

worked for me

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 23, 2018 Oct 23, 2018

Copy link to clipboard

Copied

Nevermind, purge doesnt work

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines