Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Why does Photoshop CS6 blink on Windows 8?

Community Beginner ,
Dec 21, 2012 Dec 21, 2012

Copy link to clipboard

Copied

When using Photoshop CS6, my screen blinks and flashes, especially when using editing tools or adjusting the image (increasing/decreasing size.)  I am an Adobe Cloud member and using a new machine that has Windows 8 which I am still getting used to.  I had been using my CS apps on my laptop/W7 with no problem whatsoever.  Not sure if the OS makes a difference.  Suggestions?  Thank you.

Views

121.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Dec 21, 2012 Dec 21, 2012
Known problem with Windows 8 GPU drivers.We're working with the GPU vendors and Microsoft to come up with a solution.For the time being, set the GPU drawing mode to "Basic" in preferences.

Likes

Translate

Translate
Dec 21, 2012 Dec 21, 2012

Copy link to clipboard

Copied

Known problem with Windows 8 GPU drivers.

We're working with the GPU vendors and Microsoft to come up with a solution.

For the time being, set the GPU drawing mode to "Basic" in preferences.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 07, 2013 Jan 07, 2013

Copy link to clipboard

Copied

I am having the same exact problem.  Brand new computer and also using the free trial of adobe cloud until my funds arrive to purchase the full service. (However, now I'm very leery of purchasing the cloud ).   Not cool seeing as I need to use these programs all day and every day for both of my businesses...

I tried setting the GPU mode to "Basic", even tried "Normal" but still getting the same exact results with frequent flashing and it is the only program I have open on my PC.  For example, when I try to use the lasso tool, it constantly flashes black as I'm selecting until I let go.

I cant work like this and it's hurting business and it is making me fall behind with clients.

Is there any estimate as to when this will be fixed?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Jan 07, 2013 Jan 07, 2013

Copy link to clipboard

Copied

Setting the GPU mode to "Basic" should avoid the known GPU issues in Win8.

(don't forget to restart Photoshop after changing the mode)

We're still working with Microsoft and the GPU vendors to get this fixed, but we cannot speak as to their schedules.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 07, 2013 Jan 07, 2013

Copy link to clipboard

Copied

Haha Derp!  Yup, that seemed to help.

Hopefully you guys can get everything sorted out soon. Thanks for the help

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 19, 2013 Jun 19, 2013

Copy link to clipboard

Copied

I wonder how this turned out. Same problem here except that PS6 works fine, and CC has the flickering problem with the lasso tool. It seems rather a long time since this problem was identified. How's the working it out going, gentlemen?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 19, 2013 Jun 19, 2013

Copy link to clipboard

Copied

Kate,

You no doubt see the "Set the GPU to BASIC" suggestion followed by the "We are working with Microsoft to fix it, ball is in their court" line.  I love all the tools Adobe CS has to offer which is why being among the first to hop on the Cloud was an easy choice. But, the blinking seems to be getting worse in Photshop and I do have my GPU set on BASIC.  Please, Adobe, treat this as a front burner issue and seek an immediate resolution.  At the very least, provice your Cloud members an update on where your efforts.  As it is, it just seems like this is not a pressing concern for you.  However, it is for you paying clients.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Jun 19, 2013 Jun 19, 2013

Copy link to clipboard

Copied

THe GPU vendors have improved the situation in recent driver versions - but we cannot set Microsoft's release schedule.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 19, 2013 Jun 19, 2013

Copy link to clipboard

Copied

Thank you, Chris. I appreciate knowing that the issue is being dealt with. I have set the performance to basic and it worked so far, but it's too bad to not be able to run this machine at it's optimum settings. ASUS, i7, 2 graphics cards - one onboard Intel 4000 or something like that and nvidea with 2G RAM, 8 G RAM, 2 LaCie T drives and a 7500 rpm primary drive. If those specs don't run PSCC, I don't know what will. The cards have the latest drivers. WIn8.

There was no problem with PS6.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Jun 19, 2013 Jun 19, 2013

Copy link to clipboard

Copied

The problem exists in Photoshop CS6, and we've tried to work around some of it in Photoshop CC.

But some OS level things we can't completely work around...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 19, 2013 Jun 19, 2013

Copy link to clipboard

Copied

I can understand that to a point, Chris. But this should have been disclosed at the outset. To find out it was a known issue AFTER the membership was paid for is poor CSM. Especially given the number of makers preloading machines with Windows 8. But thanks for the reply.

Sent from my Galaxy S®III

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 19, 2013 Jun 19, 2013

Copy link to clipboard

Copied

This may help some people. On another site: http://www.tomshardware.com/forum/342967-33-switching-onboard-graphics-nvidia-graphics-card

A gentleman replied to the question of how one switches from the onboard (not so powerful) graphics processor to the video card (very powerful) using software in the case of nVidea cards. It is easy, and might work out some of the kinks. I have switched and will now try to see if I can mess up PSCC using the higher setting. bbiab

"

Yes, this is called 'Optimus Technology' developed by nVidia, where your main graphics card is the integrated one and it works together with nVidia dedicated/discrete graphics card to deliver great performance but still save battery live. It's basic, the nVidia one is powerful and the Integrated one is not. But the nVidia one is power hungry and quickly put down battery very quick, where the integrated one does not. So what nVidia do is, when you are gaming, they automatically switch to use the nVidia so the performance is high. When not gaming, you turn of the nVidia one and switch back to the integrated graphics. But this does not work when you don't set it up yet. Don't worry, it's not hard and does not require change on hardware, only software. The first thing to do is, go to your nVidia driver by right clicking on your desktop and choose 'nVidia control panel'. If you can't find it go and download the driver. After you are at the control panel of nVidia, in the left side of that window there is 'Manage 3D settings' Under the 'Select a Task'. Click on that and you see in the other part there is a 'global settings' tab and 'program settings'. Go to the global one and in the 'preferred graphics processor' choose 'High Performance nVidia Processor'. You should then have the optimus technology when you choose apply. The 'program settings' in the other hand is to choose what graphics card you want to use for each program of your preference. So you choose on your program and select your preferred graphic card there.

P.S. Some programs are sadly not supported by the Optimus graphic card, so which means that the program will still run in the main graphics (which is the integrated graphics) and you still have the integrated performance. To get rid of this issue you must to contact your nearest ASUS service to disable the optimus technology.

Sorry for grammar mistakes............."

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 19, 2013 Jun 19, 2013

Copy link to clipboard

Copied

So, I followed the instructions above booted PS, changed the performance setting to the highest setting, rebooted. Then I grabbed the lasso tool, and presto it seems to be working. No flickering. In short, it's the performance that I am used to having. Mind you, this is a Raw file with one layer so far.

I hope this might help out somebody else.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 20, 2013 Jun 20, 2013

Copy link to clipboard

Copied

Thanks for all the info folks.  I too have WIndows 8 and am having the flickering in Photoshop CC I just downloaded yesterday.  I had CS6 and had no issues.  I will check out these fixes!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Aug 22, 2016 Aug 22, 2016

Copy link to clipboard

Copied

I'm using Photoshop CS2 on Windows 7. I followed your instructions and found the nVidia control panel, and I found the Global Settings, but I can't find any "preferred graphics processor" or any way to select "High Performance nVidia Processor". What am I doing wrong? Is it different in Windows 7?

"The first thing to do is, go to your nVidia driver by right clicking on your desktop and choose 'nVidia control panel'. If you can't find it go and download the driver. After you are at the control panel of nVidia, in the left side of that window there is 'Manage 3D settings' Under the 'Select a Task'. Click on that and you see in the other part there is a 'global settings' tab and 'program settings'. Go to the global one and in the 'preferred graphics processor' choose 'High Performance nVidia Processor'. You should then have the optimus technology when you choose apply. The 'program settings' in the other hand is to choose what graphics card you want to use for each program of your preference. So you choose on your program and select your preferred graphic card there."

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 19, 2013 Jun 19, 2013

Copy link to clipboard

Copied

I would disable the onboard Intel.  PS does not like 2 dissimilar cards and you may have it swithing back and forth.  nVidia should be able to handle everything.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 09, 2014 Sep 09, 2014

Copy link to clipboard

Copied

whats GPU mode?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 28, 2014 Oct 28, 2014

Copy link to clipboard

Copied

It is now Oct 2014 and Photoshop CC still has the flicker issue. When are Microsoft and Adobe going to get their act together?

Thank God for PS 30 day trial because I could not work with a flickering screen, and will be reverting to Photoshop CS6 once my trial has ended.

I should think Adobe will lose a lot of business over this. Because it is all very well saying select Basic Mode, BUT I found that after I did that,  Photoshop will not play nice when using the 3D panel.  I am running this on a Samsung i5 core processor with 8GB of RAM and of course the lovely Windows 8 (not!!).

I thought when I bought my new laptop, this was more than adequate to run all the new features of Photoshop. I am very disappointed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Oct 28, 2014 Oct 28, 2014

Copy link to clipboard

Copied

The GPU vendors fixed this shortly after Win 8 was released.  We have informed Microsoft of the issue, but they update drivers on their own schedule.

All you need to do is update your video card driver from the GPU maker's website (part of normal system maintenance) to pick up the driver with the bug fixes.

Why are you reverting Photoshop versions over a well know, long solved, OS driver problem that affects many applications that use the GPU?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 29, 2014 Oct 29, 2014

Copy link to clipboard

Copied

Thank you for the prompt reply.  I have already tried the solutions offered (reading all the other posts here). I have an Intel HD 3000 Graphics Card. My driver is up to date.

I have to keep it in basic mode because it is terrible on my eyes to have constant flickering every time I click anything on the screen,  sometimes the screen blackens for as much a second.

What are the differences between Basic Mode, Normal Mode and Advanced Mode? I guess I can live with working always in basic mode, but I am trying out all new features and finding the 3D panel does not work very well in Basic Mode.

I now have only 9 days left (on my 30 day trial) to resolve flickers and 3D issues.

On the last update of Photoshop, I saw a screen saying they were extending the trial. I am not sure what they meant but my countdown stayed exactly the same. That would have been ideal for me, because it would give me more time to find out why Intel driver update did not work.

You asked why would I revert to an earlier version but that version works fine and no issues.

I am reluctant to pay the monthly fee to upgrade unless I resolve this.

Any suggestions or help would be most appreciated.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2013 Sep 17, 2013

Copy link to clipboard

Copied

I noticed your response mentioned that Adobe and Microsoft are working together to fix this blinking problem in 2012.  Have they come up with anything yet?  It is impossible for me to select or transform images, which makes photoshop pretty useless for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Sep 17, 2013 Sep 17, 2013

Copy link to clipboard

Copied

We can only say that Microsoft knows about this and is working on it.

In the meantime, updating the drivers almost always solves it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2013 Sep 17, 2013

Copy link to clipboard

Copied

Reinstalled the graphics card driver to ensure I have the most recent version. I do. For the record, all of the flickering problems continue. I will just have to wait it out, I guess. I just hope it doesn't take too long...other software is beckoning.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 17, 2013 Sep 17, 2013

Copy link to clipboard

Copied

A lot of you folks upgraded to Windows 8...  Why?

Microsoft released what they want you think of as an upgrade, but which really delivers nothing significant.  Name something Windows 8 does for you that Windows 7 couldn't.

Conscientious folks who need critical things to keep working don't just change out a working OS and complain to application makers that their having done so breaks their applications.  They test, they research.  THEN they migrate when it's safe to do so.

-Noel

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Sep 17, 2013 Sep 17, 2013

Copy link to clipboard

Copied

I think most people just get Win8 with their new machine and deal with it...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines