Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


zooming in and out disables layer masks. Why?

New Here ,
Mar 16, 2017 Mar 16, 2017

Copy link to clipboard

Copied

Hello,

I'm encountering a glitch where at certain zoom values my masks get disabled.

For example at At 60% it's fine but when I zoom out to 50% all the masks are disabled and you can just see all my paintbrush work splodged all over the screen.

Any ideas what's causing this?

Views

872

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Mar 16, 2017 Mar 16, 2017
Does turning off »Use Graphics Processor« in the Performance Preferences (Photoshop > Preferences > Performance > Graphic Processor Settings) and restarting Photoshop have any bearing on the issue?

Likes

Translate

Translate
Adobe Community Professional ,
Mar 16, 2017 Mar 16, 2017

Copy link to clipboard

Copied

Does turning off »Use Graphics Processor« in the Performance Preferences (Photoshop > Preferences > Performance > Graphic Processor Settings) and restarting Photoshop have any bearing on the issue?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2017 Mar 16, 2017

Copy link to clipboard

Copied

Yes it does! Thank you!

However,  do you know what am I missing out on if I turn that off?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 16, 2017 Mar 16, 2017

Copy link to clipboard

Copied

It is no proper solution as it invalidates GPU dependent features (like the Rotate View Tool, improved Liquify performance, …) but it indicates problems with the GPU driver or the OS.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 16, 2017 Mar 16, 2017

Copy link to clipboard

Copied

You may want to try changing the Advanced settings to see if one combination avoids the issue (and remember to restart Photoshop after changing any setting for it to take effect).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2017 Mar 16, 2017

Copy link to clipboard

Copied

I've turned it back on now and the problem has stayed fixed but if it comes back I will tweak some of those settings. 

Thank you very much!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 16, 2017 Mar 16, 2017

Copy link to clipboard

Copied

You’re welcome.

For some info on »Basic«, »Normal« and »Advanced« see:

Optimize performance Photoshop CC

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 11, 2018 Jun 11, 2018

Copy link to clipboard

Copied

LATEST

I have the same issue in CC 2018. Is an incredible pain. At certain zoom ratios, a mask on one of my layers is disabled. At others it still works. I found one workaround - Cmd A to select all, Image>Crop. Not ideal as you are cropping to your document bounds, losing anything outside the frame. But it seems to work.

Yeah agreed - as stated above, turning off the GPU is not an acceptable fix. At least not for professionals.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines