Adobe Photoshop Elements 2019 Organizer crashes after opening

New Here ,
Mar 04, 2019 Mar 04, 2019

Copy link to clipboard

Copied

After using the Elements 2019 software successfully for about 3 months, it recently began crashing immediately after I open Organizer. I typically upload and tag up to about 50 jpg images at a time. The last time I was able to upload images, I had uploaded only 4 jpgs. Now, whenever I open the Organizer, I see the Organizer dashboard and then I get the Adobe crash report dialog box, and cannot do anything in Organizer. As soon as I close the dialog box, Organizer closes. This has happened repeatedly now for at least a week of trying everyday AND filling out crash reports to send to Adobe. I am running the program on a Surface Pro 4 still running Windows 10 Pro Version 1803.

Does anyone know of any fixes to this problem?

Thanks!

Views

2.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Mar 04, 2019 Mar 04, 2019
Try resetting preferences.  Immediately upon launching the Organizer, hold down the alt, ctrl, shift keys.  Answer yes when asked to delete settings file.

Likes

Translate

Translate
Adobe Community Professional ,
Mar 04, 2019 Mar 04, 2019

Copy link to clipboard

Copied

Try resetting preferences.  Immediately upon launching the Organizer, hold down the alt, ctrl, shift keys.  Answer yes when asked to delete settings file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 05, 2019 Mar 05, 2019

Copy link to clipboard

Copied

Thanks! This worked.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 05, 2019 Mar 05, 2019

Copy link to clipboard

Copied

Both suggestions are working today. Thanks again!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 20, 2020 Feb 20, 2020

Copy link to clipboard

Copied

This does not work for me.  I've also tried the suggestion to run the program directly as administrator.  That doesn't work either.  I uninstalled and reinstalled the Photoshop Elements 2019 program, too.  I still get the crash message every time I try to open Organizer.  The Elements program itself works fine, it's just the Organizer that keeps crashing EVERY SINGLE TIME I try to open it!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Feb 20, 2020 Feb 20, 2020

Copy link to clipboard

Copied

I am running PSE 2020 on a Windows 10 desktop PC. When I hold down the alt, ctrl, shift keys when launching the Organizer, the Catalog Manager opens. Why? What's different?

Walter in Davie, FL

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 17, 2020 May 17, 2020

Copy link to clipboard

Copied

Thanks for these suggestions, but not a single one of these answers works.  The Organizer crashes within seconds Every. Single. Time.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 05, 2019 Mar 05, 2019

Copy link to clipboard

Copied

Try an admin launch. Start by navigating to:

C:\Program Files\Adobe\Elements 2019 Organizer

Scroll down to the files beginning with “P” and select (highlight) the application PhotoshopElementsOrganizer

Right-click the highlighted application and choose send to desktop. That will create a shortcut to launch the Organizer directly.

Go to your desktop and right-click the new icon and choose Run as administrator.

Let us know if that improves stability.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 05, 2019 Mar 05, 2019

Copy link to clipboard

Copied

Thanks, this worked, too.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 19, 2019 Mar 19, 2019

Copy link to clipboard

Copied

Hi All

in my new PSE2019 installed by WindowsStore on Win10 the Organizer does not work since the first run.

When I click the Organizer icon I get a sad "Internal programming error".

I can't see anything in the folder Programs\Adobe, the folder seems to be empty at all.
I enabled hidden file viewing but still I see no file in the folder.
Tried to reset the settings, as I read in a post here above, but it did not work.

Please anyone can suggest anything to resolve this shame?

Thank bye

errore PS organizer.PNG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 17, 2020 May 17, 2020

Copy link to clipboard

Copied

LATEST

There must be something in the Program Files folder, otherwise nothing would happen when you try to open the program.  You have at least gone as far as the splash screen.  (Does your language's OS have a folder called Program Files?  Are you perhaps looking in the wrong folder Program Files (x86)?

 

Ashampoo_Snap_2020.05.17_13h07m32s_003_.png

Also, are you opening the Organizer from the Welcome Screen, or via a shortcut?

 

In any event, perhaps your catalog file is corrupted.  Try pressing the Shift key when opening the Organizer program and create a new catalog in the Manage Catalogs dialog that should open.

 

Have you had any prior version of Elements on your computer?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines