Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Map not displayed in Photoshop Elements Organizer 2021

Community Beginner ,
Mar 06, 2021 Mar 06, 2021

Copy link to clipboard

Copied

Hi,

I cannot see the map anymore when clicking the "Location" tab. It used to work. I am also not able to add a location by clicking "Add location". Reinstalling the software didn't fix the issue. What's wrong here?

TOPICS
Bug, Organizer, Problem or error, Windows

Views

189

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Mar 28, 2021 Mar 28, 2021
Yes, I tried to change the country/region, but the issue still occurs. Since I have many photos to manage, I gave up working with Adobe Organizer and chose Windows Explorer/IrfanView as an alternative instead. Works fine and without dependence on the map. Adobe Organizer isn't only buggy in some things, but also slow despite of a fast CPU and 16 GB of memory.

Likes

Translate

Translate
Community Beginner ,
Mar 06, 2021 Mar 06, 2021

Copy link to clipboard

Copied

Problem resolved. It was a Windows issue. Fixed it with SFC.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 06, 2021 Mar 06, 2021

Copy link to clipboard

Copied

Awesome! And thanks for sharing the solution 🙂

 

More info on SFC here if anyone is interested:

 

Using System File Checker in Windows 10 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 27, 2021 Mar 27, 2021

Copy link to clipboard

Copied

Unfortunately the issue has occured again. This is quite annoying. 😞

Any ideas else?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 27, 2021 Mar 27, 2021

Copy link to clipboard

Copied

Did this coincide with updating to Photoshop Elements 2012.2?

 

If so, did you run the System File Checker again? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 27, 2021 Mar 27, 2021

Copy link to clipboard

Copied

Apparently yes. Running SFC didn't fix the issue unfortunately.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 27, 2021 Mar 27, 2021

Copy link to clipboard

Copied

Ok, that's strange, as the latest update only appears to affect the Editor and not the Organizer. This lends me to think that maybe the problem lies with a Windows system file that the Organizer is relying on rather than anything in the Organizer itself (which is why the System File Checker solution worked first-time round).

 

Have you tried changing your Country/Region Selection in the Organizer to United States?

 

Edit > Preferences > Country/Region Selection

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 28, 2021 Mar 28, 2021

Copy link to clipboard

Copied

LATEST

Yes, I tried to change the country/region, but the issue still occurs.

 

Since I have many photos to manage, I gave up working with Adobe Organizer and chose Windows Explorer/IrfanView as an alternative instead. Works fine and without dependence on the map.

 

Adobe Organizer isn't only buggy in some things, but also slow despite of a fast CPU and 16 GB of memory.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines