Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


White screen when starting Adobe Photoshop elements

New Here ,
Mar 31, 2020 Mar 31, 2020

Copy link to clipboard

Copied

Hi,

 

i can't start the application. When i try to start it, i only get a white screen and nothing happens. The application has never worked properly since I bought it. Even i have tried to format and reinstall my OS and the first time the application runs it works without problem but, after a few days....white screen.

 

When I try to run PhotoshopElementsOrganizer.exe from source folder I get "Adobe Aplication Manager" not found or damaged. I tried to install and run the app the last time before format and OS reinstallation but i didnt work.

 

Please, I cant believe i paid for this software and I cant use it!! 

 

P.D.: I have registered the software on my adobe account but i cant get any help for this.....i had to write here to get any help..... 😞

 

I'm using windows 10 Pro 64 bits, AMD Phenom II X6 processor, 8GB RAM

TOPICS
Problem or error, Windows

Views

260

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 31, 2020 Mar 31, 2020

Copy link to clipboard

Copied

Perhaps your catalog has become corrupted.  Try holding down the Shift key when opening the Organizer.  This should bring up the Manage Catalogs dialog.  Create a new catalog and try to open it from the dialog.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 31, 2020 Mar 31, 2020

Copy link to clipboard

Copied

If that doesn’t work, try updating or rolling back your graphics driver directly from the video card manufacturer’s site.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 08, 2020 Apr 08, 2020

Copy link to clipboard

Copied

LATEST

I reinstalled the app and, after that, the problem is gone. 

 

Thank you anyway. But the issue with the product registration and the help is still there

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines