• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
7

Morph cut - Analyzing in Background never completes

Community Beginner ,
Oct 10, 2015 Oct 10, 2015

Copy link to clipboard

Copied

I have a simple headshot cutting to the same head, same everything a few seconds later.

All other transitions work find. I try morph cut and see 'Analyzing in background.' Never see sign of progress - should I see it chewing through frames somehow?

I have gone to project settings. Tried both rendering settings. One thing - When I do GPU acceleration my still frames look like garbage - example:

http://www.screencast.com/t/rPiWL6yL

Software acceleration looks fine. No idea if these items are related.

Have run through all preferences. Don't see anything that might be turned off. BTW - working with MBP 15" late 2013. Latest OS.

Bug Unresolved

Views

108.9K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
74 Comments
Explorer ,
Feb 22, 2016 Feb 22, 2016

Copy link to clipboard

Copied

I have same issue. Can someone solve this?

Votes

Translate

Translate

Report

Report
New Here ,
Oct 18, 2016 Oct 18, 2016

Copy link to clipboard

Copied

Hello,

Morph cut on Premiere is not working, it analyzes in the background indefinitely. Has anyone else experienced this issue? If so, how did you resolve this error?

Thanks.

J

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 18, 2016 Oct 18, 2016

Copy link to clipboard

Copied

Hey Jonathan,

A few things to try:

  1. Modifying the duration of the morph cut transition

  2. Clear your caches/preferences.

  3. Create a new project and  import the old project into that.

Let us know how that goes.

Peter Garaway

Votes

Translate

Translate

Report

Report
New Here ,
Oct 18, 2016 Oct 18, 2016

Copy link to clipboard

Copied

Hello petergaraway

Unfortunately, I have tried all three of your suggestions, none of them work. My institution has an educational subscription, I'm asking around to see whether everyone is affected or just me. Who from Adobe should I contact for further assistance?

Jonathan

Votes

Translate

Translate

Report

Report
New Here ,
Oct 19, 2016 Oct 19, 2016

Copy link to clipboard

Copied

I had that same issue.

To most effectively use morph cut you literally have to :

Export the first clip to morph, export the second clip to morph, import the 2 new separate files and apply morph cut.

Adobe Premiere should do this automatically, however it runs into one of two issues.

Issue 1: The source file is too large. (my source files are 500mb - 25gb)

Issue 2: The MORPH CUT is being applied to the same clip, which causes the ANALYZING IN BACKGROUND error.

The best way to solve it is to reduce the source file size, export and reimport your clips, and morph between two different source files.

Adobe should do this automatically, but until then this is what we have to do. It's inefficient and redundant - I'm using a Morph Cut between two cuts, I should not have to cut before and after the morph cut in extreme attempts to reduce my source file size.

Michael James Webb

310 Digital Sales And Service

Votes

Translate

Translate

Report

Report
Contributor ,
Nov 19, 2016 Nov 19, 2016

Copy link to clipboard

Copied

I have the same issue, it's driving me nuts.  In the 2015 edition, after waiting a couple hours I was sometimes able to export the video 4 or 5 times and eventually by the 6th time it would work on one of the transitions, but not the rest.  I'm talking about a 15 frame transition, rather confusing as to why that should take *that* long.  I expected that the 2017 edition would have solved a lot of this, but the problem seems identical.  Very disappointing.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jan 05, 2018 Jan 05, 2018

Copy link to clipboard

Copied

This seems to have been the source of my problem, but I inserted a cut on both sides of the transition and it analyzed within seconds.

Thanks!

-- Dan Dunbar

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 15, 2018 Feb 15, 2018

Copy link to clipboard

Copied

I tried morph cut for the first time today. It is analyzing forever with no progress.

Votes

Translate

Translate

Report

Report
Explorer ,
Mar 02, 2018 Mar 02, 2018

Copy link to clipboard

Copied

I tried a bunch of other things first and this was the only thing that worked. Annoying. But the workaround did work for me.

Votes

Translate

Translate

Report

Report
New Here ,
Mar 12, 2018 Mar 12, 2018

Copy link to clipboard

Copied

I think I figured out a way to make this work - although it is a clunky approach.

1. Place cuts on both sides of the actual cut you want to morph, 8-10 frames should do.

2. Nest both of those small 8-10 frame clips

3. Apply the effect between the nested clips

4. It will usually tell you there is insufficient data, but just ignore and adjust the length of the effect

5. Adjust the morph to the number of frames you desire - 6 is usually my sweet spot

6. Render the effect to playback and see if you're happy with the length

I've found this to be the only way to keep it from analyzing for eternity. Hope it works for others!

Votes

Translate

Translate

Report

Report
New Here ,
Mar 16, 2018 Mar 16, 2018

Copy link to clipboard

Copied

I found that adding edits with the razor tool a few frames before and after the transition speeds up the 'analyzing' process, especially if the two clips are particularly long. Presumably the analysis needs to encompass every frame before and after the transition, so by shortening the clips, the process is much faster. It may not apply universally, but it solved my apparently interminable analyzing problem

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 16, 2018 Mar 16, 2018

Copy link to clipboard

Copied

This was actually quite helpful. It did help in a number of my cuts. Really appreciate it. It is still obviously a work around for an issue that still needs to be resolved,

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 16, 2018 Mar 16, 2018

Copy link to clipboard

Copied

Definitely helped a bit. I did this in addition to the recommendations by steban42 above. The combination helped quite a bit.

Votes

Translate

Translate

Report

Report
New Here ,
Jun 14, 2018 Jun 14, 2018

Copy link to clipboard

Copied

Thank you!! Agree with Juanito above, this was the only trick that actually got the effect to work (and sheledit's trick helped speed it up too). Hopefully Adobe sorts the morph cut issue with subclips soon, but in the meantime, merci merci merci for being a lifesaver with that trick!

Votes

Translate

Translate

Report

Report
Explorer ,
Aug 28, 2018 Aug 28, 2018

Copy link to clipboard

Copied

Thank you, steban4! This seems to be a good workaround to not have the "analyzing" banner show up in the exported clip! Sad that Adobe doesn't prioritize fixing a feature they are so proud to advertise!

Votes

Translate

Translate

Report

Report
Participant ,
Nov 27, 2018 Nov 27, 2018

Copy link to clipboard

Copied

Doesn't appear to be fixed....  Really need morph cut today, latest CC 2019 version 13.01 and stuck on "Analyzing in background". Windows 10 Pro on new Dell Laptop.

Votes

Translate

Translate

Report

Report
New Here ,
Nov 29, 2018 Nov 29, 2018

Copy link to clipboard

Copied

Now this has reared its ugly head for me, too.  Nothing seems to work.  Of course I'm on a tight schedule.  This software-as-a-service model stinks.  I miss the days of getting a boxed product that worked and wasn't being constantly "fixed" by patches that sometimes break as much as they fix.

Votes

Translate

Translate

Report

Report
New Here ,
Nov 29, 2018 Nov 29, 2018

Copy link to clipboard

Copied

YOU SAVED MY LIFE

Votes

Translate

Translate

Report

Report
New Here ,
Nov 29, 2018 Nov 29, 2018

Copy link to clipboard

Copied

One thing that might have made a difference in my case: The sequence settings didn't match the footage settings.  I cut out the section that I wanted to morph, pasted it into a sequence that matched the footage (XDCAM EX), and then rendered it.  Seemed to work, at least it got me through today.

Votes

Translate

Translate

Report

Report
Participant ,
Jan 19, 2019 Jan 19, 2019

Copy link to clipboard

Copied

I have continuing issues with morph cut. One thing I just noticed is that on a timeline with several morph cuts applied close to each other, when I click on the actual transition, sometimes the word "analyze" is clickable in the Effects control window, and with others it's not. It's as if PR is telling us which morph cuts it will attempt to work out and which it won't. ??

As for trying the others workarounds, I'm going to be hardheaded and wait for Adobe to fix it.

Votes

Translate

Translate

Report

Report
Explorer ,
May 29, 2019 May 29, 2019

Copy link to clipboard

Copied

This is so frustrating. The problem seems to persist, even after several updates. Workarounds like nesting, trimming and joggling everything around are ok for the moment... but in the end workarounds are NOT the solution. Is petergaraway Adobe actually adressing this problem?

Votes

Translate

Translate

Report

Report
New Here ,
Jun 26, 2019 Jun 26, 2019

Copy link to clipboard

Copied

The "correct" fix didn't work for my project. Converting the subclip into a masterclip suggested by blahbalhblah above worked. I have a newer version of Premiere, so the steps are different:

  1. Right click on the subclip in the bin to get to the Edit Subclip option and change the clip to a master clip
  2. Right click on the clip in the timeline and choose Replace with Clip > From Bin
  3. After a few minutes, the effect will render and analyzing in the background will disappear. The wait time will apply again if you make any changes to the morph cut after that.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 22, 2019 Oct 22, 2019

Copy link to clipboard

Copied

Thank you for this! It definitely helped. I also realized you can do the same thing with "render and replace" on just one of the clips 🙂

Votes

Translate

Translate

Report

Report
New Here ,
Jan 27, 2021 Jan 27, 2021

Copy link to clipboard

Copied

CUT RIGHT BEFORE THE MORPH ON FIRST CLIP THEN RIGHT AFTER MORPH SECOND CLIP WORKED FOR ME 4K FOOTAGE

Votes

Translate

Translate

Report

Report
New Here ,
Jan 28, 2021 Jan 28, 2021

Copy link to clipboard

Copied

Hi,

I think I may have found the issue - hopefully, this will be the same for others.

 

I found that the reason the effect wouldn't analyze when using Sub clips was because I still had In/Out markers in place on the original clip. I'm assuming this restricted access to the frames it needed to analyse. 

 

Once I remove the In/Out markers on the original footage the subclips were analysed and the effect worked.

 

Thanks

Votes

Translate

Translate

Report

Report