• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
3

Unexpected behaviors related to panel focus

Community Beginner ,
Feb 25, 2023 Feb 25, 2023

Copy link to clipboard

Copied

I recently switched from an old MacPro tower running Premiere 2017, to an M1 Ultra Mac Studio with the latest version of Premiere, and I'm running into constant flaky behaviors related to what panel / window has focus. Here's some of the things I'm encountering:

 

  1. When I have Premiere minimized, it pops open by iteself after a random interval and fills the screen again. HOWEVER, the app doesn't actually have focus, and I need to click on the window to make it ACTUALLY active.
  2. No matter what window I had active when I minimized Premiere, when I switch back to the app, focus is always on the search bar of the Project window. This is quite annoying, as I'm usually hitting space bar to play from the source window or the timeline. Nothing happens, and my search field now contains a space, so my bins are no longer displaying properly. So I have to hit backspace to delete the character, then click on the window I was originally on, THEN I can finally hit play.
  3. When I DO choose to do a search in the project panel, it always flakes out... because after I type 2 characters, FOCUS SWITCHES TO ANOTHER PANEL. So not only did I not do the search, I've now hit a bunch of random keyboard shortcuts. Great. I can always re-click on the search bar and finish typing what I started, but what a pain.
  4. In the effects panel, if I scrub to change the scale of a clip, the moment I stop scrubbing it switches away from the effects panel to the footage source window. ie: I was looking at the effects panel, but now it's gone and I'm staring at the footage... which I probably didn't want yet.

 

There are a few other behaviors like this, but these are the biggies. Very frustrating, and I've never run into anything like them before. Could it be specific to the M1...?

Bug Acknowledged
TOPICS
User experience or interface

Views

385

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Pinned Replies

Adobe Employee , Apr 26, 2024 Apr 26, 2024

Hello @Sailordoom,

Thanks for the message. It’s been a long time since you filed this bug, and I apologize for the lack of a response. Are you still having this issue? If so, the team will need more information from you to reproduce the bug. Can you provide the information required here? How do I write a bug report?

 

I'll move your post to the Discussions board while we await your information.

 

Thanks,


Kevin

Votes

Translate

Translate
Adobe Employee , May 08, 2024 May 08, 2024

Based on the description of this problem, we believe this has already been addressed in a recent version of PrPro. Please let us know if it's fixed for you now or not.

Status Acknowledged

Votes

Translate

Translate
16 Comments
Community Expert ,
Feb 25, 2023 Feb 25, 2023

Copy link to clipboard

Copied

Odd problems. I can't duplicate any of it. It's perfectly well behaved in the scenarios you mention.

Might you have some keyboard shortcut program running? AutoHotKey, HotKeyBind, etc... just a guess to help figure out something.

PP 23.2 / Win21H2

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 25, 2023 Feb 25, 2023

Copy link to clipboard

Copied

Nope, no keyboard shortcut programs running. I have a fancy mechanical keyboard, but it doesn't have any associated software. From your signature though, it looks like you're on Windows...? I'm on an M1 Mac, and I suspect it may be related to the issues.

Votes

Translate

Translate

Report

Report
Community Expert ,
Feb 25, 2023 Feb 25, 2023

Copy link to clipboard

Copied

Yes, I'm on Windows per above. It sounds like an OS thing, especially the first example. Perhaps @Kevin-Monahan and/or @Michael Grenadier will spot this post.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Feb 25, 2023 Feb 25, 2023

Copy link to clipboard

Copied

Hey SD,

Hope your Saturday is going well. Popping in here. I edited your post to indicate that there are various tentacles to this bug. 

 

I can reproduce issue #2 on an M1 MacBook Pro 13" 16GB RAM running Ventura, straight away.

 

I just upvoted. I'll ping the devs about your bug when I return to the office.

 

Take care,

Kevin

Votes

Translate

Translate

Report

Report
Community Expert ,
Feb 25, 2023 Feb 25, 2023

Copy link to clipboard

Copied

I have no idea what's going on, but thinking that as a temporary workaround, that when switching back to Premiere, you immediately use a shortcut key combo to make the desired window active, for example on my custom keyboard, I would hit command 2, to make the timeline window active..   Also, have you tried resetting your prefereces?  or resetting to one of the default keyboards... or running Premiere in Rosetta (if that's still possible).   And wondering if there's something going on with the mac system preferences:  keyboard...  

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 25, 2023 Feb 25, 2023

Copy link to clipboard

Copied

Yeah, I mean none of these bugs are work-stopping issues, there's easy workarounds (usually just remembering it happens and clicking on the correct window again before things spiral out of control), but they're still a pain in the butt. My general feeling so far is that Premiere and M1 Macs are in a delicate state, and it's just not THERE yet, if you know what I mean ; )

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 25, 2023 Feb 25, 2023

Copy link to clipboard

Copied

Thanks Kevin!

 

BTW, I think we've chatted in the past, many years ago on the creative cow forums...

Votes

Translate

Translate

Report

Report
Community Expert ,
Feb 25, 2023 Feb 25, 2023

Copy link to clipboard

Copied

Have you tried resetting your premiere preferences?  and changing your premiere keyboard?  simple things to try that might help us focus on the cause of this problem...  Don't mean to be snarky, but it's impossible to judge your level of experience from your post.   If we don't approach this in a systematic fashion, it's hard to figure out what's going on...  It may be a bug or it may be something specific to your system.  Troubleshooting from a distance is never easy.    For example, it could be caused by another program installed on your system...  And do you have anything attached to your mac besides keyboard, mouse and hard drives?  Another basic troubleshooting step is to create a new user setting with administrative privileges in mac:  system preferences: users and groups and log in as the new user and see if that helps...

 

And yes, these issues can be specific to an m1...  I was working on a first generation m1 macbookpro and had some serious issues.  With the help of Kevin and others, we were able to solve the problem.  First, by shifting to the rosetta version of Premiere which helped somewhat and then installing the beta version available at that time which solved the problem...  

 

And it's great that you've filed the bug report...  And I'm thinking of getting a macstudio.... so definitely interested in your experiences...  so keep us posted.  

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 25, 2023 Feb 25, 2023

Copy link to clipboard

Copied

Thanks for the response. To answer your question: I'm a VERY experienced user, I've been using Premiere to cut projects (including multiple feature films) for many years, and I'm very technically savvy.

In my experience, resetting prefs almost NEVER fixes the problem. It's like the old running gag on the show House, where "it's NEVER Lupus!" ; )

 

It's a brand new system, very recent install, no weird peripherals except a Thunderbolt connection to a housing with a Blackmagic I/O card, which seems highly unlikely to be a contributing factor.

 

Only software on the machine is various Adobe apps, and a Maxon package with Cinema 4D and various AE plug-ins. Running under Rosetta would likely degrade performance, which would be worse than dealing with the focus flakiness.

 

My general review of the Mac Studio so far is that the general performance is GREAT, far more responsive than my old Mac Pro. R3D files play buttery smooth, H246 exports are blazing fast... but it's just plain buggy. Lots of strange behaviors, some of them minor, some of them nasty. My 2 favorites, which so far have NO true solves, are external drives putting themselves to sleep every few seconds in certain circumstances (No, changing the power/energy settings doesn't fix it), and my Blackmagic Decklink output lags by 3 frames when using most conventional frame rates and settings (and again no, changing the appropriate setting in preferences does nothing).

So yeah... it'll be a fantastic machine some time in the future, but right now it's not quite ready for heavy duty work.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Feb 25, 2023 Feb 25, 2023

Copy link to clipboard

Copied

Hi guys,

Sorry for the frustration with Apple Silicon machines and Premiere Pro. I am switching over to using it full-time so I can understand the issues better. I hope the community and you can continue to file bugs that I can advocate for. 

 

The community is on your side, so I hope all reading your thread who are Apple Silicon users will upvote.

 

Best,

Kevin

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Feb 25, 2023 Feb 25, 2023

Copy link to clipboard

Copied

Hey now! Creative Cow? Now, that takes me back. The Cow was really a great community throughout web 1.0. 

 

I hope I helped you then, here to help you now.

 

Cheers,
Kevin

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 25, 2023 Feb 25, 2023

Copy link to clipboard

Copied

You were always a tremendous help! Great to run into you again here!

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Apr 26, 2024 Apr 26, 2024

Copy link to clipboard

Copied

Hello @Sailordoom,

Thanks for the message. It’s been a long time since you filed this bug, and I apologize for the lack of a response. Are you still having this issue? If so, the team will need more information from you to reproduce the bug. Can you provide the information required here? How do I write a bug report?

 

I'll move your post to the Discussions board while we await your information.

 

Thanks,


Kevin

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 26, 2024 Apr 26, 2024

Copy link to clipboard

Copied

Yup, it's still happening. Premiere un-minimizes itself at random (though it *may* be related to autosave?), and any time I come back to it after hiding it, the search bar has focus. I also had After Effects do that the other day, having the 'search help' bar active when I unhid it... though I'm now unable to reproduce it.

Still on an M1 Mac Studio, still running OSX 12.5.1 (because I have a documentary feature still in progress, and I never update my OS in the middle of a project). Currently on Premiere 24.1.0, but I was on the 2022 version when I originally posted.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Apr 26, 2024 Apr 26, 2024

Copy link to clipboard

Copied

OK. I'll change the discussion title slightly to reflect the bug description and move it back into the Bugs forum. Let me know if the new title better describes the issue.

 

Thanks,
Kevin

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 08, 2024 May 08, 2024

Copy link to clipboard

Copied

LATEST

Based on the description of this problem, we believe this has already been addressed in a recent version of PrPro. Please let us know if it's fixed for you now or not.

Status Acknowledged

Votes

Translate

Translate

Report

Report