Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Adobe Premiere Pro VERY SLOW playback on very high end PC

New Here ,
Dec 20, 2020 Dec 20, 2020

Copy link to clipboard

Copied

AMD 5900X

RTX 3080

32 GB RAM

Gen 4 PCIE SSD

 

Can't even play a 1080p file on 1/4 resolution smoothly. Playback is running at like 5 fps. I have Mercury Playback Engine GPU Acceleration On.

 

The weird this is when I'm on a different active window(like a folder or any othe program). The video playback runs smooth. When I have Adobe Premiere as the active window it stats to be very slow.

TOPICS
Hardware or GPU, Performance

Views

911

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Dec 20, 2020 Dec 20, 2020
try turning mercury playback engine acceleration off and see if that makes a difference.  Could be an issue with the driver for the graphics card.  Have you tried running Premiere without any other programs running? 

Likes

Translate

Translate
Adobe Community Professional ,
Dec 20, 2020 Dec 20, 2020

Copy link to clipboard

Copied

try turning mercury playback engine acceleration off and see if that makes a difference.  Could be an issue with the driver for the graphics card.  Have you tried running Premiere without any other programs running? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 22, 2020 Dec 22, 2020

Copy link to clipboard

Copied

So I got it back to work correctly. Turns out it's the Nvidia Drivers. I rolled back my driver to the October version and it properly now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 06, 2021 May 06, 2021

Copy link to clipboard

Copied

LATEST

I have the exact same system and just ran into the same problem. Working with essential graphic is a nightmare. Just downladed the new studio drivers 462.31 and will be doing a clean install of the nividia studio drivers. Lets hope it works. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines