Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Importing .mts AVCHD video into Premiere Pro CS5.5, HELP!

New Here ,
Jan 29, 2012 Jan 29, 2012

Copy link to clipboard

Copied

Hello,

I am new on Adobe forums and I nedd a question answered.

I have seen that there is no definite answer on how to import .mts files from my Canon Vixia HFR20 to Premiere Pro CS5.5.

I get "The file has an unsupported compression type" message. For now I convert the videos to .AVI but i would why would I continuosly convert them?

I bought the camera mainly for the HD, so help soon would be greatly appreciated!

Thanks in Advance,

Ethan

P.S: I have a PC to put that in mind...

Views

226.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2012 Jan 29, 2012

Copy link to clipboard

Copied

I have CS5 and MTS files import just fine, AVCHD support is native to PPro... copy the ENTIRE folder from the camera to your video hard drive and import from there

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2012 Jan 29, 2012

Copy link to clipboard

Copied

Okay, I tried that. I just dragged the folder into the Premiere pro folder, and still no luck.

Here, this is what I did:

I have my "import video data" folder

Libraries>Videos>Import Video Data> TVD_AVCHD>20120128

so I take the 20120128 folder and drag it there (NOTE: Along with the mts there are .cpi files corresponding to the video name ie 123123123.mts and 123123123.cpi)

still, unsupported compression type.

Sorry if it is confusing and thank you so much for your fast response!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 30, 2012 Jan 30, 2012

Copy link to clipboard

Copied

I don't think you want the .cpi files in there.

Have you tried just Ctrl+I and then selecting just the individual .mts files?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 30, 2012 Jan 30, 2012

Copy link to clipboard

Copied

Again, thanks guys for all the help,

But, I have taken the files i wanted (.mts) and put them into my Premiere Pro CS5.5 folder in the program files (My HDD), is there a certian place where I should put it?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 30, 2012 Jan 30, 2012

Copy link to clipboard

Copied

Well not there.  You shouldn't put anything on the C: drive but Windows and Programs.  You need a separate internal hard drive for Media.

And you need to copy the entire PRIVATE folder, not just the MTS files.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 17, 2012 Mar 17, 2012

Copy link to clipboard

Copied

Jim - So glad I found this post. I'm brand new to Premiere Pro and was struggling with how to import my AVCHD files.  Importing the entire PRIVATE folder worked!  Thank you!

(I'm on a Mac, OS 10.5.8 Leopard, using Premiere Pro CS5).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jan 31, 2012 Jan 31, 2012

Copy link to clipboard

Copied

Maybe its somthing to do with your camera or the settings your shooting in.

What are your camera settings ?

If you can create a new folder and take some test footage of anything.  Just make it short.

Then either zip it up or upload to one of the free sharing websites and others can test your footage and see if it works for us.

GLenn

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2012 Feb 15, 2012

Copy link to clipboard

Copied

I am having the same problem importing into Premiere Pro 5.  I have uploaded one of the .MTS files, a small 6MB file to https://www.transferbigfiles.com/c4767c5b-cd1f-4b82-85fe-a578a751f875?rid=US5patibm7CavSjfrvMeSw2.  So if you can have a look that would be hugely appreciated.  I viewed another link that suggested it might be the container or codec that it is compressed with/into and if I get the right codec it would work.  But I can't see this info from the file.

P.S. I am using a Macbook Pro running Lion if that has any relevance.

Kind Regards

Stu

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Feb 15, 2012 Feb 15, 2012

Copy link to clipboard

Copied

I downloaded the file and it plays fine for me but im on Windows.

I tested with CS 5.0.3

Do you have the Mac updated to 5.0.4 ?

Glenn

picture098.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2012 Feb 15, 2012

Copy link to clipboard

Copied

Thanks for your reply Glenn, I am not sure what the numbers 5.0.4 mean sorry.  This is the specs I could find:

Screen Shot 2012-02-16 at 10.48.20 AM 1.png

Can you tell from the file which 'container' or 'codec' the file is compressed with?  I tried downloading a Mac equivilent program to G-Spot to find this out, but it won't open this file for analysis.  If I know this it may be as simple as downloading the right codec for APP to read. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Feb 15, 2012 Feb 15, 2012

Copy link to clipboard

Copied

5.0.4 is what version of Premiere you should have with a Mac.

http://www.adobe.com/support/downloads/product.jsp?product=98&platform=Macintosh

picture099.jpg

Here is a link that Media Info says is the codec inside.  They have a Mac version.

http://www.videolan.org/developers/x264.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 16, 2012 Feb 16, 2012

Copy link to clipboard

Copied

Thanks again Glen.  Have downloaded Media Info, this program actually works.  I then downloaded the x264 codec and put it into my Premiere Pro folder, but the .MTS file still will not import.  I have the .MTS file in the PP folder in the same place as the .prproj file.  The same error continues "The file has an unsupported compression type".  Does the compression type relate to the Codec? Mmmmmmmmm any help appreciated!!!

And my version of PP is 5.0.0

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Feb 17, 2012 Feb 17, 2012

Copy link to clipboard

Copied

I would first update your Premire and see if that helps.

Just launch Premiere and hit Help and Check for updates.

Maybe that will fix it for you.

GLenn

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 20, 2012 Feb 20, 2012

Copy link to clipboard

Copied

Thanks for your help again.  Have updated PP, it now says I have version 5.0.4.  But unfortunately this hasn't fixed the problem, the same error is occurring.  With the codec that I downloaded, was I supposed to put this into some sort of 'codec folder' as such?  Maybe I just have this in the wrong place and it can't access it?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 20, 2012 Feb 20, 2012

Copy link to clipboard

Copied

Thanks for the suggestion, unfortunately it didn't work for me.  I even tried renaming the extensions as well but nothing is working.  Thanks anyway.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Feb 20, 2012 Feb 20, 2012

Copy link to clipboard

Copied

I wish I could help more.

Maybe start your own thread stating you have a mac and cant play the file.

It works on the PC version so it has to have something to do with the Mac but im just guessing.

Include a link to the file so someone else with a Mac can download it a try it.

You might have to convert it if nothing else works.

GLenn

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 21, 2012 Feb 21, 2012

Copy link to clipboard

Copied

Thanks Glenn, maybe this has helped Just4School anyway as a PC user.  I would be interested to hear from Just4School to see if it is now working with a PC.  If not, then there must be another answer out there.  I just jumped in on this forum as it was exactly the same problem as I was having, except I have a Mac.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Feb 21, 2012 Feb 21, 2012

Copy link to clipboard

Copied

I wonder if it has anything to do with it being Blu-ray

We all know how Apple doesnt like Blu-ray.

Just a guess.

What file extensions have you tried renaming it to ?

Have you tried .m4t ?

GLenn

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 22, 2012 Feb 22, 2012

Copy link to clipboard

Copied

Tried renaming with .m4t extension and PP wouldn't even allow me to view it, ,must not support that file type?  I am experimenting with different sequence formats, no success so far.  I can't find a AVCHD option, only DVCPROHD options and of course PAL and NTSC.  Which suggests to me that there is something missing.  Anyway I will keep trying.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Feb 22, 2012 Feb 22, 2012

Copy link to clipboard

Copied

Post a screen cap of what presets you have.

Maybe you have gotten the revert to trial bug and lost your options to play these files since they dont play in the trial version.

Here is what mine look like.

picture103.jpg

Here is the Properties of the file you uploaded.

picture102.jpg

And here is what sequence that was created when dragging to the New Item button.

picture101.jpg

See if you have the same options.

GLenn

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 26, 2012 Feb 26, 2012

Copy link to clipboard

Copied

Hi Glenn,

Thanks again for your help, was very helpful to see your screenshots.  I don't have anywhere near all the presets that you have.  Not having the AVCHD would definitely be why I can't import the .mts file.  It is like I have the trial version restrictions but can't unlock the presets.  I have tried:

Uninstalling and reinstalling

Uninstalling and downloading a version from online and installing from that file instead of my DVD Roms's

Using Adobe Cleaner Tool (very unsuccessful, wouldn't even remove APP 5 out of my apps folder) and reinstalled.

Not sure what else I can do to get these presets, my installation code is supposed to unlock the full version (I assume that there is no other files that I need to download in order to get the rest of the presets?).    Stu

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 26, 2012 Feb 26, 2012

Copy link to clipboard

Copied

Have you installed any codec pack?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 26, 2012 Feb 26, 2012

Copy link to clipboard

Copied

Hi Ann,

I downloaded the x264 codec folder and put it into my Premiere Pro folder (I didn't actually know what to do with the codec once I downloaded it), but the .MTS file still will not import.  I have the .MTS file in the PP folder in the same place as the .prproj file.  The same error continues "The file has an unsupported compression type".  Does the compression type relate to the Codec?  There is another folder called "Presets" in the APP folder, the presets seem to be the problem, is there files that I need to add to this folder maybe that will give me the other presets that would allow me to have the AVCHD option?  Any help appreciated!!!  Stu

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 26, 2012 Feb 26, 2012

Copy link to clipboard

Copied

is there files that I need to add to this folder

Not manually, no.  So far the only solution has been to deactivate, uninstall, run the clean script, reboot and reinstall.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines