Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Premiere Pro could not find any capable video play modules

Community Beginner ,
May 09, 2012 May 09, 2012

Copy link to clipboard

Copied

I downloaded the trial of Premeire Pro CS6 today, and after I launched the application, it said "premiere pro could not find any capable video play modules".

Tried again, no luck.

My graphics card is at the latest driver that HP has out.

What should I do before I give up?

HP DV7t Quad 17'' Laptop

i7 2720

AMD Radeon 6770HD (Switchable Graphics)

8GB Memory

Views

181.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , May 11, 2012 May 11, 2012
I was able to resolve this problem on a laptop. In the AMD control panel, the main GPU selected was the Intel integrated video card that come with the processor instead of the more powerfull AMD video card.So, for those of you out there that have an Intel processor with the integrated GPU, make sure adobe premiere isn't using the Intel GPU to launch.

Likes

Translate

Translate
replies 115 Replies 115
New Here ,
Jun 13, 2012 Jun 13, 2012

Copy link to clipboard

Copied

I am riunning Win7 64 bit using a Desktop with 16 GB of RAM, an Intel i7 2600K processor and a Radeon 6970 GPU. My motherboard is an Asus P8Z68-V Gen 3 Mobo and the rig is self built. I am using Lucid Logix Virtu to dual task my use of the built in Intel Graphics 3000 (driver 4/29/12) in my system with my 6970 GPU (Driver 4/4/12). This works perfectly on every other program I have on my computer including CAD programs and all Microsoft Programs, Nikon's CNX2 64 bit and I can even run CS5 Production Premium Pro without problem. I tried running CS6 Premiere Pro as an Admin and it started, so thre is obviously some bug in CS6 since it worked before in CS5 and  all my drivers are up to date. the idea of disableing my dual graphics configuration just to run this Adobe program does not appear to me to be the kind of solution Adobe should be putting forward. IF you made it work in CS5 you can make it work in CS6 without workarounds.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 13, 2012 Jun 13, 2012

Copy link to clipboard

Copied

>tried running CS6 Premiere Pro as an Admin and it started, so thre is obviously some bug

Not so obvious to me... I have CS5 and I MUST use the "Run as Administrator" option with Encore to create a dual layer DVD... but not with a single layer DVD... which is an "oddity" of Win7 permissions

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 13, 2012 Jun 13, 2012

Copy link to clipboard

Copied

After dinking around and rechecking all my drivers which are the very latest, I was still not able to run Premiere Pro or Encore, some of my other programs in CS6 seemed a bit unstable, i.e. they loaded but were either sluggish or hung. So I rebooted and then set Premiere Pro and encore and the other programs that seemed a bit skittish and set them up to all run as Admin. Problem solved! Everyone of them booted OK without problem. So now the question is why is this necessary in CS6 and not in CS5 (at least not in my set up though others have said they need to run some stuff in CS5 as Admin. I hope Adobe looks at this and comes up with a general fix.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 13, 2012 Jun 13, 2012

Copy link to clipboard

Copied

There is a fix, that has been around for ages, and that is to log in to Windows as an administrator.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 26, 2012 Jun 26, 2012

Copy link to clipboard

Copied

Hi all,

I have an HP DV6, 6 gb ram, radeon HD 6490M and apparently an Intel?  I downloaded the trial, but I am looking to buy the full CS6 master suite at the end of the week, but don't see the point if Premiere won't run!!

I have tried some of your suggestions; i.e. changing properties to "administrator"; logging in as secret administrator; tried looking for somewhere to change the display type, no luck, have a radeon, but can't find a separate control panel; changing the folder name and using shift!

ummm... any suggestions would be fantastic as I really want the software, but Premiere is one of the reasons I am thinking of buying it.

Can anyone please help??

thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 26, 2012 Jun 26, 2012

Copy link to clipboard

Copied

According to http://www.newegg.com/Product/Product.aspx?Item=N82E16834158580 that has a screen of 1366 x 768 - which will not work

Some ideas for a Laptop Video Editing PC from past discussions

http://www.adkvideoediting.com/

http://www.sagernotebook.com/ - http://forums.adobe.com/thread/957472

.

For effective HD video editing, a laptop with the following

-at least the Intel sandy bridge 2720 or 2820 quad processor

-and nvidia graphics such as the 460m with 1Gig video ram

-1280x900 display with OpenGL 2.0-compatible graphics card

-and 8 or 16 gig ram and Win7 64bit Pro

-and 2 internal 7200 HDDs minimum

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 26, 2012 Jun 26, 2012

Copy link to clipboard

Copied

Hello thedarksword

have you tried changing the BIOS settings as described at 25.

The steps you need are:

1) restart your computer

2) press F10 to access the BIOS while restarting

3) change the Switchable Graphics from Dynamic to Fixed.

Roberto

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 09, 2012 Jul 09, 2012

Copy link to clipboard

Copied

Hi.

I had the same problem and I found a solution.

Apparently, it has something to do with the Radeon graphics card.

1)Go to Catalyst Control Center (Right-click on the desktop and click on "graphics properties")

2)Click on the option "Power"

3)Click on the option "Switchable Graphics Method"

4)Choose the option "Select the graphics processor manually.", and apply it.

5)Go back to "Power" and this time, click on "Switchable Graphics"

6)Verify if it's written "High-performance GPU" in the text box. If not, click on the option "High-performance GPU" below.

That should work. Enjoy!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 26, 2012 Jul 26, 2012

Copy link to clipboard

Copied

Hello from France

i've got the trouble with PPRO with a  NVIDIA GE FORCE GTX 460.  behaviour varies from one driver to another.

driver 295.73 : pb ("ppro could not find any capable play module"  where AE or PS are running correctly).

driver 295.51 : No pb !

But the main issue is the automatic upgrade that goes me to the wrong version !

please hel.

regards, Philippe.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 26, 2012 Jul 26, 2012

Copy link to clipboard

Copied

Update your driver to at least 301.42 or 304.79

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 02, 2012 Aug 02, 2012

Copy link to clipboard

Copied

Hi,

Unfortunately, the 301.42 doen't recognize the GTX 460 and nver heard about the 304.79. file not found in Nividia web site.

regards, Philippe.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 02, 2012 Aug 02, 2012

Copy link to clipboard

Copied

use the nVidia Hack http://forums.adobe.com/thread/629557 - which is a simple entry in a "supported cards" file

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 02, 2012 Aug 02, 2012

Copy link to clipboard

Copied

Weird.

nVidia_driver.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 04, 2017 Jun 04, 2017

Copy link to clipboard

Copied

it did no work for me

answering your question, head to control panel>user accounts>user accounts>user account control settings>set it to never notify, and you are all set

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 06, 2016 Apr 06, 2016

Copy link to clipboard

Copied

I have had the exact same problem. I tried everything in this forum and others and couldn't get it to work -- it drove me crazy.

I just bought a new new laptop -- a very expensive one for gaming with huge specs -- and Premiere Pro worked super fast on it for about 24 hours and then quit.

I went through all the forums and finally had a brainwave:

I uninstalled AVG FREE.

I don't know why it was, but I had tested PP before I'd d/l-ed and installed AVG FREE and it worked fine. Once that program was on -- poof! No Premiere.

SO I took it off and now it works again. Crazy.

Hope this helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 12, 2012 May 12, 2012

Copy link to clipboard

Copied

There are many different steps you can try to resolve this error.

1) Recreate preferences.

Go to start & type "%appdata%" in the search box & you will see a roaming folder in the search results.

Open the roaming folder & then go to the adobe folder & then the Premiere Pro folder. Inside you will find the 6.0 folder. Right click on that & select rename & change the folder name to "6.0old".

Then try launching Premiere Pro while holding down the shift key while it loads the various components on the splash screen.

(Holding down the shift key refreshes the plugin information)

2) Update the NVIDIA & AMD drivers to the latest version. Do not run the automatic update. Manually go the NVIDIA or AMD website & then look up the latest available graphics drivers for your graphics card & then download & install them.

NVIDIA - http://www.nvidia.com/Download/index.aspx?lang=en-us

AMD - http://support.amd.com/us/gpudownload/Pages/index.aspx

3) Try disabling the startup items & services at some services running in the background could be blocking access to the graphics card for Premiere.

Click on start & type in "msconfig" in the search box & press enter.

It will open the System Configuration utility. Under general>startup selection select the option for selective startup & then uncheck "load startup items".

Go to the "services tab" & make sure to check the option for "hide all microsoft services" (Very Important)

Then click on disable all.

Now go through the list of services that are given & check any of the following adobe services you might find in the list like :

FlexNet Licensing Service

Adobe Switchboard

After checking the above services click on apply>ok>restart.

After restart try to launch Premiere Pro again.

Note : To re enable all your services again open the System Configuration utility again using "msconfig". Under general>startup selection select the option for "normal startup". Click on apply>ok>restart. This will reenable all your services.

4) Try logging in to the hidden administrator account.

Click on start & type "cmd" in the search box. At the top of the windows you will see cmd in the search results. Right click on that & select run as administrator.

It will open the DOS prompt windows.

In that type in "net(space)user(space)administrator(space)/active:yes" & press enter.

You should get the message comand completed successfully.

Close the window & restart your computer. After restart once you get to your login page you will see a new account called administrator. Login to the account & then try to launch Premiere.

For those users for whom the above DOS command does not work might have the administrator account disabled, just try to create a new administrator type user account & then try to launch Premiere in the new user account.

The above steps should solve the problem for atleast NVIDIA card users. For AMD card users it might not solve but I am looking into it & I will post try to post further steps after research.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 25, 2012 Aug 25, 2012

Copy link to clipboard

Copied

I am having the same problem. My graphics card is Nvidia 9800 GTX+. Drivers are up to date. I have gone through all the steps described above  and still unable to get Premier Pro 6 to start up. Had been running verion 5/5.5 successfully before. Any other thoughts out there? I am about to uninstall and go back to previous version?

Later that day..

OK, I now know why I can't get it to run. I ran GPUsniffer and found that it was rejecting my card due to insufficient memory.  My 9800 GTX+ has 512mb of memory. That seems to be less than the minimum required.  Guess I either have to upgrade my card or go back to last version.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 25, 2012 Aug 25, 2012

Copy link to clipboard

Copied

You "should" be able to use "just about any" card with CS6... but in software only mode if the card has less than 1 gig of video ram

If you have the card name entered in the supported cards file, you will have to reverse the hack and remove the name

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 26, 2012 Aug 26, 2012

Copy link to clipboard

Copied

Thanks. From what I have read, that is only a MAC fix. I am using Windows 7 and not sure what the equivalent is. I turned off CUDA support on my card and recreated the preference folder but that didn't seem to do it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 05, 2012 Sep 05, 2012

Copy link to clipboard

Copied

This is how I fixed my issue. I had did the system recovery and then installed my software one at a time. And then realized - "Constant Guard" from Comcast was killing the permissions! I uninstalled Constant Guard and now I am able to use Premiere Pro without issue.

I got the idea to uninstall Constant Guard from this link: http://forums.comcast.com/t5/Security-and-Anti-Virus/BEWARE-Constant-Guard-Incompatible-with-Adobe-P...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 17, 2012 Dec 17, 2012

Copy link to clipboard

Copied

I have the AMD card.  I followed the steps related to startup applications (refer to step 3 of Item " 13.Pallav A")

I selectively acitvated startup apps one at a time and found the application that was blocking Adobe Primiere Pro from starting was:

GuardedID by Strikeforce Technologies, Inc.

I uninstalled this application and problem went away.

I didn't have to do step 4.

Hope this helps

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 03, 2015 Oct 03, 2015

Copy link to clipboard

Copied

I had the same problem which i was able to fix for the first time but after have borrowed my laptop to a friend i was unable to make it work again.

I tried all the solutions given here, but didnt work at all.

Finally by an accident i fixed it. In windows 8.1 but i think this will work in all the systems and also brands of computers.

The solution was sooooo easy, not the graphic card, not any preferences, if not...

> Control Panel

> Power Options

> Choose or customize a power plan

>>>> HIGH PERFORMANCE PLAN or Balanced (better the first)

And that is all, works. My friend making me a favor puts the POWER SAFE mode, and all the programs are working except PREMIER PRO.

I hope this help whom can not revolve the problem wth the rest of solutions previously proposed!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 05, 2016 Mar 05, 2016

Copy link to clipboard

Copied

The Shift thing and renaming the folder thingy worked on my shit windows 7. Cheers!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 25, 2016 Mar 25, 2016

Copy link to clipboard

Copied

Can you elaborate. What did you do specifically?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 12, 2012 May 12, 2012

Copy link to clipboard

Copied

http://helpx.adobe.com/prelude/kb/error---preludevideo-play-modules.html

this worked for me after several days with Adobe and HP for HOURS!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines