Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Premiere pro runs extremely poorly for me, and I'm not sure why

New Here ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

I've looked into tutorials for months, and nothing I've seen works. 

 

Here's an example of what happens: I drop ONE SONG into a brand new project, then the whole software lags out like crazy. I don't even have to place a video into the project for it to do this.  

 

As I mentioned, this has been happening for months, but only recently it has started to become unusable.  Such as, for some reason, I can't place text into the project either. 

 

I've tried proxies, I changed the GPU resolution, I've cleared the media cache, I've tried a lot of things, I just don't know what the issue could be.  

TOPICS
Error or problem, Performance

Views

274

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

Forgot to mention reinstalling.  It worked temporarily last time I tried, but then problems got worse.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

What are the complete computer specs, including hard drives (how many, what kind, what is on each, what capacity, and how full)?

If NVIDIA graphics, make sure to use the latest Studio Driver from NVIDIA (NOT the Game Driver).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

Ryzen 7 3600X CPU

16GB RAM

1TB SSD (with everything I have on my computer, I don't have a hard drive) 

RTX 2700 super (I normally use studio drivers anyway)

 

I just updated my studio drivers, and it seemed to help a slight bit, but I still have issues with performance.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

Do you have this issue with all/any type of files, audio and video? Or it's limited to some audio type only?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

It's pretty all around.  I can really place anything into the timeline, and Premiere will lag out.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

@Astroman5CEA  Try these for starter

1) go to Preferences > Audio Hardware > Default Input => select "No Input"

2) Reset workspace: Window > Workspaces > Reset to saved layout

3) Make sure that NVidia G-Sync is off in driver control panel
4) If you are working with 2+ monitors, try if a single and most basic display setup (ie FHD/60Hz) has same issue

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 07, 2021 Apr 07, 2021

Copy link to clipboard

Copied

LATEST

That seemed to have worked, thanks!  I'll reply to this post if there's another problem that arises!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines