Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Adding Script to Robohelp Project

Community Beginner ,
Jan 13, 2021 Jan 13, 2021

Copy link to clipboard

Copied

Sorry - not very tech savvy regarding scripting.

My robohelp output (Frameless) is hosted on SharePoint. My company uses Edge and Chrome (Edge running in IE11 compatibilty mode for the output). Output shows fine in Chrome, but in Edge, the topic content briefly appears and then disappears (same in IE 11, which we are banishing - but still have for the mo).

 

Our resident hacker/tech guru provided the following info (in quotes):

:ok so window.TextDecoder

^ that exists in chrome, but not in IE

you are using a library that depends on that existing"

"use libraries that support IE or put this page somewhere other than sharepoint"
"try inserting this code into the very top of the body of the page:
<script src="https://unpkg.com/text-encoding@0.7.0/lib/encoding-indexes.js"></script>
<script src="https://unpkg.com/text-encoding@0.7.0/lib/encoding.js"></script>"

And ... lo and behold, that did the trick for the one topic that I pasted it into (after the <body> tag).
SO... I guess my questions are:

1) Is there a way to easily post those two lines into all topics (I assume I could do it with global S&R), or -
2) Barring that (preferable), is there any way to include those two scripts in the project and get them to run so I didn't have to go through the Search and Replace pain. Can I just grab the content from those scripts and paste them into the "topicpage.js" script?

Views

117

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 13, 2021 Jan 13, 2021

Copy link to clipboard

Copied

New Edge & Chrome are virtually the same - old Edge & IE didn't toe the line very well with HTML5 commands (as you can see) - not really much you can do about that because old Edge is being replaced as Win10 updates machines.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 13, 2021 Jan 13, 2021

Copy link to clipboard

Copied

We are using new Edge (Version 87.0.664.75 (Official build) (64-bit)). As stated - the output is on SharePoint 2013, and we've forced SP to run in IE11 compatibility mode - hence help broken on Edge (all the frame stuff shows - Nav bar, TOC, intro page tiles etc; however, click on a topic in TOC and topic content briefly shows up, then disappears).

 

But as stated - there is a workaround; just trying to figure out the best way to implement it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 13, 2021 Jan 13, 2021

Copy link to clipboard

Copied

Ok, so take a copy & try #1 and see how it works OR try with a copy of the project and use Master Pages to stick the script into the header.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 13, 2021 Jan 13, 2021

Copy link to clipboard

Copied

Yes - that worked. Many thanks ... Now just have to apply the master page to all topics.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 14, 2021 Jan 14, 2021

Copy link to clipboard

Copied

LATEST

To quickly apply the master page to all topics go to Reports > Topic List. Select all topics at the top of the page and right click, select Properties. There you can apply the master page in one action.

 

I have assumed you are using 2019 New UI or 2020 as you haven't said which version you are on. It's much the same in Classic versions except you go straight to Topic List.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation