Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Broken links created by Robohelp2019 conversion

Explorer ,
Jan 16, 2019 Jan 16, 2019

Copy link to clipboard

Copied

I am running Robohelp 2019.0.4.

Converting a Robohelp Classic project to Robohelp 2019 breaks links in my TOCs.

There are NO broken links in the Classic project, yet the 2019 broken now shows many broken links.

Why is this happening and how can I rectify this without touching every single one of these links?

TOPICS
HTML, New UI

Views

2.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 17, 2019 Jan 17, 2019

Copy link to clipboard

Copied

I see from another post that you are likely upgrading from 2017. I haven't encountered any issues with broken links in the TOC upgrading from 2017.

  1. Is this project one that was worked on in 2017? If not, try upgrading to that first if you can.
  2. Have you tried upgrading it to 2019 Classic first? If not, try that with a copy of the project rather than the original.
  3. Are these all links to topics rather than external links?
  4. 2019 Classic ships with Employee Care 3 as a sample. Try upgrading that.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 17, 2019 Jan 17, 2019

Copy link to clipboard

Copied

Thanks Peter.

1. Yes, this was a project that was converted from 2017. There were no broken links in the project.

2. Yes, I had converted the 2017 project to Robohelp Classic 2019 and there were no broken links there.

3. These are all links inside of TOCs to topics inside the project.

4. I converted the Employee Care 3 project and everything looks fine.

Ok, I just found out what is going on. During the conversion my .html files are being changed to .htm files while links those files are in still reference the html files. Yeah.

Is there a way to control this behavior during the conversion?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 17, 2019 Jan 17, 2019

Copy link to clipboard

Copied

No way that I am aware of. Sounds like a job for a little utility that

changes file extensions.

Peter Grainge

www.grainge.org

@petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 17, 2019 Jan 17, 2019

Copy link to clipboard

Copied

I question whether this is a necessary or desirable behavior by Robohelp 2019 and wonder why this isn't documented somewhere. It is certainly something I would warn the user about both in the documentation and the UI. It would be nice if your were warned, then given a choice whether to keep the html extension or not.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 17, 2019 Jan 17, 2019

Copy link to clipboard

Copied

Where did you .html files in a RH project? AFAIK you always had .htm ones in the project folders.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 17, 2019 Jan 17, 2019

Copy link to clipboard

Copied

Jeff,

When you create a new topic you can change the default .htm to .html. At some point in this projects long past, I was asked by development to use the .html extension. Later, this wasn't a requirement (or maybe they realized it wasn't) and I started just leaving things as htm. So some of the topics are htm and some are html. Not the best of practices I admit. Up to this point, this has not been a problem for Robohelp.

Looks like the solution is for me to touch each topic and get them all to have the .htm extension then I have to edit the broken links in the various TOCs to make it all happy once again. Just using a utility outside of Robohelp to rename the files won't work, as doing so will just break things further I imagine.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 17, 2019 Jan 17, 2019

Copy link to clipboard

Copied

Not following why you think it wrong to search for .html and replace with

.htm, provided you take a backup first. That would fix the links. Then the

utility would change the files to match.

Peter Grainge

www.grainge.org

@petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 17, 2019 Jan 17, 2019

Copy link to clipboard

Copied

I'll try it a couple of different ways and report back.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 18, 2019 Jan 18, 2019

Copy link to clipboard

Copied

2019 will support HTML, the issue was with the upgrade not recognising it. That will be fixed in the next update.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 30, 2019 Jan 30, 2019

Copy link to clipboard

Copied

I've decided to just wait until this problem gets fixed, along with whatever else I haven't run into yet. As Robohelp 2019 stands today, I cannot justify using it in production and will continue to use the "Classic" mode until things shake out a bit more. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 30, 2019 Jan 30, 2019

Copy link to clipboard

Copied

@Rick What will be fixed is the upgrade process that did not recognise the HTML extension. So you would need to upgrade again. The fix is not to restore the already upgraded project. Just wanted to be sure you are clear on that.

I am told that if you change the extensions in 2019, it will recognise HTML.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 30, 2019 Jan 30, 2019

Copy link to clipboard

Copied

Peter Grainge​, there is also a "unused file" component to the conversion problems as well. Files that are in the unused list are contributing to the broken links list. In my case these are "snippet" files that are no longer in use.

Should we delete unused files and graphics when we determine we don't need them? I guess, but in large old projects you may inherit all sorts of unused files. You might also exclude a file and be unsure whether you'll need it later. That said, I'm sure the development team is striving for a "one click" conversion of old projects and those issues will be dealt with programmatically.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 31, 2019 Jan 31, 2019

Copy link to clipboard

Copied

I believe from Update 1 all images get imported, whether used or not. I don't know about other file types.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 28, 2019 Jan 28, 2019

Copy link to clipboard

Copied

Hello All,

Problem for me as well. This has only begun happening to my files after downloading update 4.

Projects that were fine under Update 3 are chalk full of broken links. htm/html as well as .pdf/.gif confusion.

Also new with update 4, invalid characters in French text.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 11, 2019 Feb 11, 2019

Copy link to clipboard

Copied

I have the same problem while upgrading from 2015 to 2019, I have many broken links, and couldn't generate PDF due to this issue.

Please any solution has worked with you?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 15, 2019 Feb 15, 2019

Copy link to clipboard

Copied

Have you installed Update 5?

I posted a list of features and fixes at https://techcommtools.com/robohelp-2019-update-5-now-available/ and Fix #1 relates to upgrading projects.

-Matt

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 17, 2019 Feb 17, 2019

Copy link to clipboard

Copied

Hello Matt, Yeah I did, and still got the same error unfortunately.Broken links.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 18, 2019 Feb 18, 2019

Copy link to clipboard

Copied

Are there links showing as broken in the Broken Links report? Do any of them relate to an ALI file?


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 18, 2019 Feb 18, 2019

Copy link to clipboard

Copied

There 's a long broken links list. I don't know the reason for that. I've just upgraded the project from 2015 to 2019. Please let me know if there's any solution.

broken links2.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 18, 2019 Feb 18, 2019

Copy link to clipboard

Copied

Do you have Update 5 applied? If not apply that first.

Then please go to the Broken Links report where you will see a better picture and, as mentioned, whether any relate to the ALI file.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 18, 2019 Feb 18, 2019

Copy link to clipboard

Copied

Yes, it's up-to-date. This is the only thing that I can find related to ALI in the list.

ali.png

update.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 18, 2019 Feb 18, 2019

Copy link to clipboard

Copied

I don't think it will fix all your issues but it might help with a lot of them if you posted the area of the Broken Links Report that shows the ALI file entry. You are showing the screen for fixing the links, I want to see the screen you access that from.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 18, 2019 Feb 18, 2019

Copy link to clipboard

Copied

Does that explain the matter? I also don't know why there are many broken links for images and css.

ali.pngbroken link.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 18, 2019 Feb 18, 2019

Copy link to clipboard

Copied

Not quite but close enough.

  1. I was hoping the majority of the broken links were down to an issue with ALI files. I think the ones you see can be got rid of by locating the publish folder and seeing if there is a CSH folder. If there is delete it or, if you prefer, move it somewhere outside the project.
  2. See what things look like when you run the report again. If there are still many broken links, when did you upgrade this project from 2015? Was it with an early version of 2019 before any updates were released? Try upgrading again now that you have Update 5 applied.

Post back with wherever that gets you.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2
Resources
RoboHelp Documentation
Download Adobe RoboHelp