• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Failed the generate PDF file

Guest
May 24, 2006 May 24, 2006

Copy link to clipboard

Copied

Hi,

I've just installed a trial version and tried generating help in different formats.
While generation of Printed Documentation unknown error occurs.
This is the line in the log file:
Failed the generate PDF file 'E:\Program Files\RoboHelp Office\RoboHTML\Samples\Test\!SSL!\Printed_Documentation\Printed_Documentation.pdf'...

Doc file is created, Pdf - is not.

However, if I run then AdobePDF manually, it pops up a MessageBox with this error:
Cannot find 'E:\Documents and settings\Administrator\Application Data\1-Step RoboPDF\Empty.pdf\Empty.htm'

If I close messagebox then it works fine and generates PDF from the Printed_Documentation.doc generated by RoboHelp.
What could it be?

Alex.
TOPICS
Classic

Views

4.7K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 24, 2006 May 24, 2006

Copy link to clipboard

Copied

Welcome to the forum.

Follow this link and look at Snippet 33. Click here.

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
May 24, 2006 May 24, 2006

Copy link to clipboard

Copied

>> Follow this link and look at Snippet 33. Click here.
This link doesn't work.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
May 24, 2006 May 24, 2006

Copy link to clipboard

Copied

OK, now the link works.
I made the changes according snippet 33.
It solved issue with the MessageBox "Cannot find 'E:\Documents and settings\Administrator\Application Data\1-Step RoboPDF\Empty.pdf\Empty.htm".
Thanks.

However, RoboHelp is still unable to generate PDF.
Same line in log: Failed the generate PDF file 'E:\Program Files\RoboHelp Office\RoboHTML\Samples\Test\!SSL!\Printed_Documentation\Printed_Documentation.pdf'...
Still no clear definition of the error..

Any ideas?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 24, 2006 May 24, 2006

Copy link to clipboard

Copied

There is a limit to the number of help topics in the trial version (25?). Is what you are generating within that limit?

Was RH installed with your logon and does that have admin rights attached?

Finally, I notice you are referring to E:\Program Files etc. Where is RH installed and where is your project? Hard disk or network?

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
May 24, 2006 May 24, 2006

Copy link to clipboard

Copied

>> There is a limit to the number of help topics in the trial version (25?). Is what you are generating within that limit?
I explored several options: tried to compile samples, a project built from my source Doc file (may be more than 25 topics) and a manually created small project (1 topic). Behaviour is the same. Doesn't work. Doc file is generated. Pdf is not. If I manually load generated Doc into RoboPDF - it works.

>> Was RH installed with your logon and does that have admin rights attached?
Yes, same account, local admin.

>> Finally, I notice you are referring to E:\Program Files etc. Where is RH installed and where is your project? Hard disk or network?
yes, same disk, blah-blah. The folder name is correct. It does exist. And contains just generated Doc file.
Even samples which are included with a product can not be compiled.

Is there any way to enable an additional log or diagnostics?
Could someone look into source code to figure out where and with what conditions this message can occur?
"Failed the generate PDF file 'E:\Program Files\RoboHelp Office\RoboHTML\Samples\Test\!SSL!\Printed_Documentation\Printed_Documentation.pdf'..."

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 24, 2006 May 24, 2006

Copy link to clipboard

Copied

I am not sure what else to suggest. It is unusual for Program Files to be on anything but the C drive so I wonder if you have some sort of unusual set up that is maybe causing this problem.

It sounds like you may be using RH for Word. Have you tried the same thing in RH HTML and does it give the same problem?

The support here is from other users so no way of looking at the source code or conditions.

There is a topic on my site about Printed Documentation and Print Issues. Maybe a look at those will reveal something.

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
May 24, 2006 May 24, 2006

Copy link to clipboard

Copied

By the way, I found that this message "failed the generate..." is in PrintDocGenerator.dll
RoboPDF can generate PDF when launched manually.

It seems to me that PrintDocGenerator.dll is unable to invoke RoboPDF.

>>I am not sure what else to suggest. It is unusual for Program Files to be on anything but the C drive so I wonder if you have >>some sort of unusual set up that is maybe causing this problem.
I wouldn't say that there is anything unusial. System drive is E, everything is also on disk E. Disk C is occupied by WinSrv. I have 2 OS on my computer. Current OS is XP. (Of course RH was installed on same OS )

>>It sounds like you may be using RH for Word. Have you tried the same thing in RH HTML and does it give the same problem?
What do you mean? RH for Word vs. RH HTML? I'm using RoboHelp HTML. What is RH for Word?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 24, 2006 May 24, 2006

Copy link to clipboard

Copied

All I meant by "unusual" is that most RH users will have Program Files on their C drive. I don't know if perhaps RH looks on the C drive for RoboPDF, perhaps it shouldn't but that is not the same thing.

RH for Word is a version of RH that uses Word documents as source files rather than HTML files. You mentioned "a project built from my source Doc file" which made me think you were using RH for Word.

Have you looked at the "print issues" topic to see if anything there helps?

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 26, 2006 May 26, 2006

Copy link to clipboard

Copied

A bit late but I suppose you did tick the Generate PDF check box?

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 01, 2010 Mar 01, 2010

Copy link to clipboard

Copied

LATEST

Make sure the Adobe Acrobat PDF conversion toolbar plugin is

enabled in Microsoft Word:

http://kb2.adobe.com/cps/330/330984.html

This fixed this very problem for me! Crazy solution and crazy place to find the menu option to re-enable!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp