Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Filters not working with Robohelp 2015 Merged Responsive help!

New Here ,
Nov 15, 2016 Nov 15, 2016

Copy link to clipboard

Copied

I am using Robohelp 2015. My requirement is to merge the responsive outputs of different projects into one master project. The child projects are getting merged into master project, but the individual child's filters are not working in the master project as expected.

Views

429

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 15, 2016 Nov 15, 2016

Copy link to clipboard

Copied

I'm not certain, but it would seem only logical that in each project you would need to ensure the same identical set of conditional build tags. Then each project would also likely need the same exact filter settings in the SSL recipe too.

Perhaps Adobe or Willam van Weelden​ will pop in to confirm or deny.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 16, 2016 Nov 16, 2016

Copy link to clipboard

Copied

Hello Rick,

Thanks for the reply. I am taking exactly same number of conditional build tags. On merging, the filters of both the projects are getting reflected. But they are just acting fine on master's TOC, and not on the content.

Cheers,

Neha

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 16, 2016 Nov 16, 2016

Copy link to clipboard

Copied

Have you got all the patches installed? I know there were a few posts about filtering problems, and I think there has been a recent patch with filter related fixes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 18, 2016 Nov 18, 2016

Copy link to clipboard

Copied

I never tried this with a merged project either. Does the merged project have the exact same Dynamic filter settings available as the master?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 21, 2016 Nov 21, 2016

Copy link to clipboard

Copied

Can you please elaborate dynamic filter settings? I have given same screen layouts for master and child projects.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 23, 2016 Nov 23, 2016

Copy link to clipboard

Copied

How the Conditional Build tags are available, is set through the SSL. So if you want some content to be excluded in a child project, you have to specify that in the child project SSL. The SSL for the master project only controls the output for the master.

For dynamic filters, you set the available filters in the SSL as well. I haven't used this myself yet, but if you want the filter to be available in the output of the child project, you will have to apply the same filters and same name for every child SSL. Once it's merged, you can check whether the child topics/TOC/IDX pick up on the filter settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 28, 2016 Nov 28, 2016

Copy link to clipboard

Copied

Thanks for the reply. I have defined the same conditional build tags and applied to the content of all the child projects. Then I have added these conditional tags as filters in the SSL. But on merging these projects into master project, the actual content is not getting filtered(only TOC is getting filtered). In individual child projects, the filters are working fine.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 08, 2016 Dec 08, 2016

Copy link to clipboard

Copied

LATEST

As long as the filters work as excpected for the child projects separately, this is a bug. Please report your issue to Adobe here: Adobe Tracker

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 21, 2016 Nov 21, 2016

Copy link to clipboard

Copied

I am using the latest version of Robohelp 2015 4.1. The filters in the child project are not working in the master project. When I am trying other way round, the filters in the master are not getting reflected in the child either.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp