Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Output Project Title Link on Topic Page Broken after Updating to 20

Explorer ,
Nov 16, 2020 Nov 16, 2020

Copy link to clipboard

Copied

Hi,

I've recently upgraded from RH 2019 to version 20. The online help we were generating used the skin's home page in the output. The name of the project would redirect to the home page upon clicking it as expected. This occured in both the home page view and topic view. Upon upgrading to version 20, the behavior has changed. 

Now, when clicking the title link at the top of the help while viewing a Topic page, the body of the topic disappears and is replaced by the project title instead of redirecting. See the attached screenshots as an example of the different behavior as well as how the objects are identitied in the browser.

 

Through our own troubleshooting, we've noticed that this behavior occurs on our application when the homepage is "start.htm". We've been using this as our homepage name for a while, so we have a lot of legacy links to this page integrated into our application. However, when we generate the same set of help files with the same skin, and use a different homepage "index.htm" the behavior is back to what is expected.  To give you an idea of our environment that we're using, you can access a sample of our help with these links:

https://ussuhvvm0350.egdemo.info/rh_custom/start.htm 

https://ussuhvvm0350.egdemo.info/rh_oob/index.htm 

Is there a way to change the behavior back to what it was before so we can continue to use the start.htm file? Thanks in advance.

Views

119

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 16, 2020 Nov 16, 2020

Copy link to clipboard

Copied

Which output are you generating? Responsive or Frameless?

 

Start page, Default topic and Skin home page are different things. Can you confirm what value is in the three fields in your output preset? (I think Skin home page is only available for Frameless.)

 

if you attach files, please use the Insert Photo icon to add the images inline as it's easier to help. Plus the forum is buggy and regularly refuses to let us download attachments. Additionally, if we view attachments, we can't reply until we leave the page and come back, because more bugs...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 17, 2020 Nov 17, 2020

Copy link to clipboard

Copied

Thank you for your reply.

We are using the Frameless output.

  • Start page = start.htm
  • Default Topic = welcome.htm
  • Skin home page = start.htm

Attachment images below:

rh2019 help.pngrh2020help.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 17, 2020 Nov 17, 2020

Copy link to clipboard

Copied

The Start Page field is automatically generated by Robohelp for the output. It contains information to "stick" the toc, glossary, index, and topics together. In Classic, people would use the same file name in the Default Topic field and it would cause problems in their output. I imagine using it in the Skin Home Page Content field causes similar problems for the new Frameless output.

 

I think the Skin Home Page Content should be a topic in your project and will display that topic content below the toc tiles on your home page.

 

I checked both of your links and neither displays topic content below the tiles, which suggests you don't have a topic in your project called 'start.htm'. So you should be able to clear the Skin Home Page Content field without causing any issues.

 

If you do have a topic in your project called "start.htm" then I'd recommend renaming it to something else like "welcome.htm" (using Robohelp, not File Explorer). Robohelp should update all references, but it would be worth checking a few topics, the toc, index and output presets to make sure. If the developers have used links to "<webaddress>/start.htm" in the application, they shouldn't have to change anything as that file will still be in the output (created when you generate the project).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 17, 2020 Nov 17, 2020

Copy link to clipboard

Copied

I just realised 'welcome,htm' is your default topic, so if you have a topic called 'start.htm' then you'd need to rename it something else, obviously. (Sorry, my brain is in deadline territory 🙂 )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 18, 2020 Nov 18, 2020

Copy link to clipboard

Copied

Just to clarify: The start.htm file in our set is just a starter index file, so it doesn't have any topic content. The welcome.htm file is a topic file with content.

We like using the skin home page option because of the ability to stylize the page with tiles, so we don't have any intention on using a file that would have topic content, since that inserts the content below the tiles. 

I've removed the file from the Home Page field and regenerated the help, but that does not seem to fix the issue either.

 

Do you have any other suggestions as to what I might be able to adjust in order to make the project name link send the user back to the home page? Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 18, 2020 Nov 18, 2020

Copy link to clipboard

Copied

Can you access the start.htm file in your Contents panel within Robohelp? Or is it only available in your output?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 19, 2020 Nov 19, 2020

Copy link to clipboard

Copied

It is only available in our output

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 19, 2020 Nov 19, 2020

Copy link to clipboard

Copied

LATEST

The only other thing I can think of is to try generating to a new output folder, in case something is messed up. Theoretically everything is deleted when you generate, but I've seen reports in the past where people have said this has helped.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp