Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


RH2019 Indent Issues

Participant ,
Aug 06, 2019 Aug 06, 2019

Copy link to clipboard

Copied

Good afternoon ladies and gents,

Latest issue I picked up with RH2019, and I'm thinking it should have a simple fix.  The indentation of paragraphs is incomplete.  I want to indent the entire paragraph, but only the first line is indented.  It's not like this on the Classic layout and I assume it's because of a change in how the CSS is handled.  Before I could just select the whole section and hit tab, but now I have to click the Indent button and it's not working like it should.  Just one question:  How do I fix it?  Google isn't helping...

Example of issue:

TOPICS
HTML

Views

276

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Aug 06, 2019 Aug 06, 2019
If it is for all paragraphs with that style, open the CSS and apply some left margin. If it is just for selected paragraphs, do that in the Properties > General tab.If you regularly use indented and not indented, create a class (new style based on P) with the required indent.Peter Graingewww.grainge.org@petergrainge

Likes

Translate

Translate
Adobe Community Professional ,
Aug 06, 2019 Aug 06, 2019

Copy link to clipboard

Copied

If it is for all paragraphs with that style, open the CSS and apply some

left margin. If it is just for selected paragraphs, do that in the

Properties > General tab.

If you regularly use indented and not indented, create a class (new style

based on P) with the required indent.

Peter Grainge

www.grainge.org

@petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 06, 2019 Aug 06, 2019

Copy link to clipboard

Copied

I can do the indent, that's not the problem.  I'm just wondering if there's not a way to fix the default indent option.  It seems to create the following on the new layout when I indent a paragraph:

<p><span style="margin-left:40px;">text</span></p>

While on the old (Classic) layout it does:

<p style="margin-left:40px;">text</p>

And the latter works perfectly.  Why does the new layout force a span in there?  If I remove the span in the new layout and just force the style on the paragraph, it works just fine again.  It's quite frustrating...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 06, 2019 Aug 06, 2019

Copy link to clipboard

Copied

Because 2019 is stricter writing code.

What you should be doing is having two styles, one with an indent and one

without.

Peter Grainge

www.grainge.org

@petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 06, 2019 Aug 06, 2019

Copy link to clipboard

Copied

LATEST

That makes completely sense.  I didn't think about that (self taught here, don't know the "rules").  Thanks for that, Sir, much appreciated!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp