Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


RoboHelp 2015 - Android app external hyperlinks not working.

Community Beginner ,
Feb 16, 2016 Feb 16, 2016

Copy link to clipboard

Copied

Hi all,

I have a user guide for an app my company develops. The guide is created with RoboHelp 2015 with latest updates (12.0.2.384)

The user guide is generally viewed online via web browser, and I export it as "Responsive HTML" for this purpose.

Recently, the requirement has appeared to have the help available as an app on a mobile device running the actual app the help is for. (at this point no need for context sensitive help etc. - it's just a user guide available on the users' device).

I got the "Mobile App" output type working after a bit of playing, and I can now generate a very nice Android app version of my user guide.

It all seems to work very well, and is viewable equally well on phones, tablets etc.

The only fly in my ointment is that any external links to websites which appear in my user guide simply do not work.

ie. tapping a link does absolutely nothing (that I can see). No message, no popup, no jump to external browser, etc.

If I view the same user guide via the normal web browser mechanism, the links open a new browser window with the link properly opened.

I have checked over and over all settings related to the "Mobile App" output type, and I see nothing which seems to be related to this...I'm at a loss...

Can anyone shed any light on this?

regards

Robert

Views

549

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Apr 18, 2016 Apr 18, 2016
Hi Abhishek,I have installed the latest update (3) and can confirm that this is now working well.Many thanks for your attention during the resolution of this issue.

Likes

Translate

Translate
Adobe Employee ,
Feb 16, 2016 Feb 16, 2016

Copy link to clipboard

Copied

Hi Robert,

Thanks for reaching out.

This is a very basic use case and hyperlinks should work fine. However, we are getting this checked to see if there is any issue.

Will reach out to you with a resolution ASAP.

Regards,

Abhishek

Product Manager

Adobe Technical Communication Products

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 17, 2016 Feb 17, 2016

Copy link to clipboard

Copied

I also meant to mention that I have tried the help app on a number of devices, without any difference on any of them.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 17, 2016 Feb 17, 2016

Copy link to clipboard

Copied

Hi Robert,

We have replicated the same at our end and will be providing a fix shortly (within a day or two).

Sorry for the inconvenience caused.

Regards,

Abhishek

Product Manager

Adobe Technical Communication Products

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 17, 2016 Feb 17, 2016

Copy link to clipboard

Copied

Many thanks Abhishek,

Look forward to the update...

regards

Robert

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 23, 2016 Feb 23, 2016

Copy link to clipboard

Copied

Hi Abhishek,

Is there any progress on this?

regards

Robert

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 23, 2016 Feb 23, 2016

Copy link to clipboard

Copied

Hi Robert,

This is taking longer than expected at our end. The initial workaround that we thought of didn't work.

We are working on it and I shall update you as soon as a fix is available.

Thanks for your patience.

Regards,

Abhishek

Product Manager

Adobe Technical Communication Products

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 23, 2016 Feb 23, 2016

Copy link to clipboard

Copied

No Problems,

Just checking...

regards

Robert

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 23, 2016 Feb 23, 2016

Copy link to clipboard

Copied

Just to give you little more details on this, it's an issue related to how PhoneGap handles external links. It prohibits the application to open links in the browser outside application.

We are trying to fix the same.

Thanks !

Regards,

Abhishek

Product Manager

Adobe Technical Communication Products

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 15, 2016 Mar 15, 2016

Copy link to clipboard

Copied

Update:

The fix for this issue will be provided in an upcoming patch on 2015 release of RoboHelp.

Thanks !

Abhishek

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 18, 2016 Apr 18, 2016

Copy link to clipboard

Copied

Hi Abhishek,

I have installed the latest update (3) and can confirm that this is now working well.

Many thanks for your attention during the resolution of this issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 18, 2016 Apr 18, 2016

Copy link to clipboard

Copied

LATEST

Great!

Please reach out to us in case of more issues. We'll be happy to help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp