Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Robohelp 2019.0.14 - search box and image mapping

Explorer ,
Aug 27, 2020 Aug 27, 2020

Copy link to clipboard

Copied

Hi, I've recently updated from Robohelp 2019.0.10 to Robohelp 2019.0.14. Ever since I've updated, I've come across two issues on the project I am working on.

  1. Search box doesn't seem to be working regardless of the web browser I am using. I generated and published the project after the updated without making any changes and the search engine stopped working. I tried to do it again in the same way and it worked for 3-4 days and even though I haven't generated or published any content within that project it stopped working again after these 3-4 days.
  2. Image mapping seems to be all over the place after the update. I will attach some screen shots but if I add an image map in point A and add a link against it whilst I am in the project it will stay in point A. As soon as I publish it on my drive or live system it loses the format and it goes in point B even though it should stay in point A. I've not had this issue before the update.

Could you please assist?

Thanks,

image map when in project.pngimage map when published.png

TOPICS
Output presets

Views

111

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 27, 2020 Aug 27, 2020

Copy link to clipboard

Copied

Can you add your screenshots to the post? Use the little "Insert Photos" icon in the forum web interface.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 27, 2020 Aug 27, 2020

Copy link to clipboard

Copied

Thanks Jeff, I added the screen shot for the image map however there is not much I can add about the search box. If I populate it, it doesn't display any results.

 

search funtionality.PNG

 

Even if I used the exact name of the document it will still not display anything.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 27, 2020 Aug 27, 2020

Copy link to clipboard

Copied

Weird, now I can't seem to reply to this thread using the non-nested Reply button.

IIRC, your #2 is a bug - check the Tracker (https://tracker.adobe.com/) to see if you can find its status.
I'm not sure what's going on in your #1 - I've never heard of search working for a few days & then stopping - something's got to be happening outside of RH for that to happen. Where is the output located?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 28, 2020 Aug 28, 2020

Copy link to clipboard

Copied

Thanks for your help Jeff, very much appreciated!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 28, 2020 Aug 28, 2020

Copy link to clipboard

Copied

Hi Jeff, 

I am having the same issues. I published my project using the frameless output. When I try to search for certain words, the website freezes up. And it only occurs when using the search. Spent 2 hours with Adobe yesterday and could not get a fix. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 28, 2020 Aug 28, 2020

Copy link to clipboard

Copied

Is the image mapping issue when the screen is resized? If so that is a known issue. I think it is fixed in 2020 but if not, I think it is coming in Update 1. It sounds different but I want to be sure.

 

On the search issue, just for test purposes, add a new skin and generate with that. Does it then work?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 28, 2020 Aug 28, 2020

Copy link to clipboard

Copied

Hi Peter,

No, the issue is always presents regardless if the screen is resized or not.

For the second one I will try to generate it with a new skin and see if that works.

Thanks for your advice, much appreciated!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 28, 2020 Aug 28, 2020

Copy link to clipboard

Copied

I have removed a long legal disclaimer and a lot of personal information. Please reply direct to the forum if that cannot be excluded from emails.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 08, 2020 Sep 08, 2020

Copy link to clipboard

Copied

Thanks for doing that Peter, I am new to using the forum so very much appreciated!

Considering my previous message for #1: the issue with image mapping present regardless of resizing - has it been logged as an issue yet?  I understand you are aware of one where the issue appears when resizing but could they be linked?

 

It would be useful to know so we can check what other alternatives we have meanwhile.

 

Thanks again for your help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 08, 2020 Sep 08, 2020

Copy link to clipboard

Copied

I somehow doubt they are linked but are you planning to upgrade to 2020? If not the known issue will only be fixed in 2020 so that won't help you. Let us know your 2020 plans.

 

Given the search box issue, I am more inlined to something else being wrong. Try a new skin first.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 08, 2020 Sep 08, 2020

Copy link to clipboard

Copied


Does the search work okay on your local PC (before you publish)? If it's only a problem on the web server, it could be a server cache issue. You could speak to your web administrator and get them to clear the cache to see if it fixes it. If it fixes it and reoccurs, then they might need to adjust the caching settings. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

Hi both, thanks for your reply!

 

  1. search box - I haven't had any issues since I last asked about it so I am inclined to think it might have been a problem with our servers. As Amebr suspected, the search box was working when publishing on local drive.

 

  1. image mapping - I did some more investigation and I think you are right Peter, it might have to do with the resizing and with the size of the image I insert. If I zoom in or out I can see the image mapping moving all over the place. Does that mean it would be fixed in Robohelp 2020? Peter - I am currently spoke to somebody who is looking after our subscriptions with Adobe to see if we have the possibility to upgrade to 2020 but keep 2019 on my machine (so I can revert back to 2019 in case anything goes wrong). Once I have an answer I will then know if we can upgrade or not.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

This page shows what is fixed in 2020 and I can't see the image map issue shown but I thought it had been fixed. I will check.

 

If your 2019 version was not subscription, you can continue to use it as long as you like. With the subscription model you can keep as many versions as you want.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

Thanks Peter,

 

I have another example for two different versions I store on 2 different machines. If I open poject A in Robohelp 2019.0.10 the image mapping looks as per below (as we initially designed them):

 

Flow Robohelp 2019.0.10.png

When I open same project in Robohelp 2019.0.14 the same flow with same image mapping looks as per below (even if I re-position them they will just get back to same position once I generate and publish):

Flow Robohelp 2019.0.14 latest version.PNG

 

Therefore, I am pretty sure there is a new issue which appeared between the updates. I now have the free trial for 2020 to see if there are any issues like that and if it's worth updating. We do have a subscription package so I understand it shouldn't be a problem to keep both 2019 and 2020.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

  1. Adobe have confirmed the issue with resizing was fixed, albeit not listed as such.
  2. I am wondering if what you are now reporting is a cache issue. I had similar recently. Refresh did not work, I had to go into the browser settings. Maybe try a browser you haven't used for this.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

Hi Peter, I have cleared the cache from settings and other content it's updating fine - I can see the changes. Unfortunately, due to security reasons I only have permission to use Chrome or Internet Explorer and it shows the same on both. Thus, the screen shots I've sent are from Robohelp itself not from the published version. The image mapping changes as soon as I open the project in Robohelp.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

At first I thought you were saying that clearing the cache had fixed it but you then say "The image mapping changes as soon as I open the project in Robohelp."

 

I'm not clear on what the problem is now. Because of the way this forum works, I can't look at the two images side by side so the Spot the Difference game is tricky. Is it just the mapping or something else?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

Clearing the cache hasn't helped so sorry if I gave you that impression.

 

The problem is the image mapping after the update from 0.10 to 0.14. I have tried to combine the two versions in one image to have them side by side (see no. 17, 4 and 9). I zoomed in to take only 3 examples as I can understand it gets confusing. Yes, I think the problem is just the mapping - when the project is opened from version 0.10 the mapping is fine. When I open the same project in 0.14 (which is the version I currentlty have on my work machine) the mapping goes all over the place as per image below (Left image version 0.10, right image version 0.14). Note: this is not only once published; it happens as soon as I open the project in Robohelp 2019.0.14. I hope this clarify and once again sorry for any confusions.

Example side by side.PNG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

I'm just checking whether "it is fixed" meant in 2019 or 2020.

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

Fixed in 2020.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

LATEST

Thanks for the clarification Peter, I will upgrade to 2020 in that case and fingers crossed it will work!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp