Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


RoboHelp 2020.3.32 and GIT - SSH Key could not be added to the ssh-agent

New Here ,
Jan 26, 2021 Jan 26, 2021

Copy link to clipboard

Copied

RoboHelp version used: 2020.3.32

 

We followed the Adobe instructions to create a GIT key. We tested it and it works.

When we attempt to complete the Connections Profiles screen and put in the link to the SSH Private Key we get the SSH Error:

"SSH Key could not be added to the ssh-agent. Make sure that ssh-agent is running and the key is valid."

ssh-agent is running and key is valid.

We tried what was suggested here:

RoboHelp 2019 and GIT - SSH Key could not be added to the ssh-agent

 

We also tried this solution:

Is there a workaround to make Robohelp 2019 work with Windows 10 ssh-agent?

But we still get the same error.

Can anyone help us?

Thanks.

 

TOPICS
Version control

Views

206

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 26, 2021 Jan 26, 2021

Copy link to clipboard

Copied

I can't help you on this one but use the search on the forum RoboHelp on Adobe Support Community enter GIT.

 

There are other posts and hopefully one will help. If not and if no one else replies, try Support. See https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp for your support contact options.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 27, 2021 Jan 27, 2021

Copy link to clipboard

Copied

Thank you for your answer.

We did an extensive search using the keyword mentioned (and other keywords) before posting this question. Other members have similar issues but no solution has been provided.

I sent an email to Adobe support. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 27, 2021 Jan 27, 2021

Copy link to clipboard

Copied

Hi,

Please do the following:

1. Open terminal and test the SSH connection using this command: $ ssh -T git@<servername>. Also mentioned at https://helpx.adobe.com/in/robohelp/using/git.ug.html#setup-ssh-connection.

2. Let us know if this is successful. We will need to debug further.

If connection fails, you will need to follow the steps and again test the connection. Ideally if it works from terminal it should work from RH as well. In case it works from terminal but from RH then we will need to see if this is a firewall issue.

Also please try it without being on vpn connection.

Thanks and Regards,
Surbhi Maheshwari

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 03, 2021 Feb 03, 2021

Copy link to clipboard

Copied

Hello,

We checked the SSH connection and there is no problem: it works well.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 03, 2021 Feb 03, 2021

Copy link to clipboard

Copied

LATEST

We had the same issue.  I was able to clone my project from my repo, via cli on my mac, and on my windows VM, with no issues but hit that same error with robohelp when trying to create a connection profile.  

 

For me, i literally clicked around to different fields while on a support call and then, randomly, i was able to save it.   It has been working ever since. 

 

My co-workers were not that lucky.  Same deal - they were stuck with that same error message when trying to create their connection profiles.  My dev-op guy ended up finding the file that the RH was trying to write to with the info you supply on the connection profile page and manually populating it.  My coworkers can now push and pull with no errors.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp