RoboHelp 2020 - Custom bullet list in generated Microsoft Help (chm) file

New Here ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

I am using RoboHelp 2020.3.32.  I am working on a help project that was created with a previous version of RoboHelp and that I have upgraded to RoboHelp 2020.  From that project, I want to create a Microsoft HTML Help (.chm) file.  My help content contains bullet lists, which should have custom images (from an image file called TriangularBullet.png, which is in the /contents/assets/images folder of the project) as bullets.  The CSS from my original project contained a custom ul.ListBullet style, which, with the old version of RoboHelp, was working fine both when authoring the content in RoboHelp and in the generated .chm file:

 

ul.ListBullet {
  list-style: url(../images/TriangularBullet.png);
}
ul.ListBullet>li {
  font-size: 11pt;
  margin-bottom: 6pt;
  padding-left: 6pt;
}

 

In RoboHelp 2020, using the above style, the bullets are displayed correctly in both Author and Preview modes but, when I generate a .chm file from the project and open the .chm file, the custom bullets are replaced by default bullets (small discs).

I have tried to create a new class (TriangularBullet) using the class definition user interface in RoboHelp 2020.  This generated the following CSS:

 

ul.TriangularBullet {
--prefix-size: 48.5px;
--prefix-fixed-size: false;
--prefix-gap: 16px;
--list-indent: 48px;
--vertical-spacing: 0px;
counter-reset: item1;
list-style: none;
padding-left: var(--prefix-size);
margin-left: calc(var(--list-indent) - var(--prefix-size));
}
ul.TriangularBullet>li {
--prefix-size: 48.5px;
--prefix-fixed-size: false;
--prefix-gap: 16px;
--list-indent: 48px;
--vertical-spacing: 0px;
position: relative;
margin-top: calc(var(--vertical-spacing) / 2);
margin-bottom: calc(var(--vertical-spacing) / 2);
}
ul.TriangularBullet>li:before {
counter-increment: item1;
content: counter(item1, none)url('../images/TriangularBullet.png');
text-align: right;
position: absolute;
left: calc(-1 * var(--prefix-size) - var(--prefix-gap));
margin-right: var(--prefix-gap);
width: var(--prefix-size);
overflow: hidden;
}

 

Again, this displays the custom bullets correctly in both Author and Preview modes but, when I generate a .chm file from the project and open the .chm file, no bullet is displayed at all.

I would be very grateful if somebody could tell me how to create content with custom bullets in such a way that the custom bullets are correctly displayed in a .chm file generated from the RoboHelp project.

Many thanks in advance.

 

Views

238

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Community Professional , Jan 21, 2021 Jan 21, 2021
I suspect an oversight in the generation process and the image isn't being copied to the output. Try adding it as a baggage file - add to the TOC and tick the "hide in output" option. If that works, you can request features and report issues here: https://tracker.adobe.com/

Likes

Translate

Translate
Adobe Community Professional , Jan 22, 2021 Jan 22, 2021
After adding the image to the TOC you click on the entry for the image in the TOC. ________________________________________________________ See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate
Adobe Community Professional ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

Try putting the image in the same folder as the CSS.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

Thanks for the suggestion, but I had tried that and the result is the same (with both styles mentioned in my original post).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

I'll take a look tomorrow unless someone else responds meantime. 

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

Thanks. Have a nice evening.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

I suspect an oversight in the generation process and the image isn't being copied to the output. Try adding it as a baggage file - add to the TOC and tick the "hide in output" option.

 

If that works, you can request features and report issues here: https://tracker.adobe.com/

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 22, 2021 Jan 22, 2021

Copy link to clipboard

Copied

Thank you very much.  This does work.  With the image added to the TOC, the bullets are correctly rendered in the .chm file.  However, I do not see the "hide in output" option that you have mentioned, so the image does appear in the Table of Contents of the .chm file, which is not right.  Could you please clarify whether I can add the image to the TOC with it actually appearing in it?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 22, 2021 Jan 22, 2021

Copy link to clipboard

Copied

Sorry, I meant "add the image to the TOC without it actually appearing in it".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 22, 2021 Jan 22, 2021

Copy link to clipboard

Copied

Add the image to the TOC in the same way as a topic, then look in Properties. Tick the checkbox.

 

image.png

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 22, 2021 Jan 22, 2021

Copy link to clipboard

Copied

I don't get that checkbox.

 

Untitled.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 22, 2021 Jan 22, 2021

Copy link to clipboard

Copied

After adding the image to the TOC you click on the entry for the image in the TOC.

 

image.png

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 22, 2021 Jan 22, 2021

Copy link to clipboard

Copied

Ah! I found it!  I had not realised that I first had to open the whole TOC in Edit mode.  OK, so I have added the image to the TOC and checked the "Hide in input" check box and it all works now: I get the custom bullets and the image is not visible as a topic in the TOC.  Thank you very much for your help.  I would never have thought of all this on my own.  Strange that this is so complicated when I thought that using custom images as bullets would be something very common.  Anyway, I am happy to have found a way to make it work.  Thanks again!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 22, 2021 Jan 22, 2021

Copy link to clipboard

Copied

I think I'd consider it a bug that you get the checkbox when you use the sidebar properties panel, but don't get it when you right-click and open the Properties dialog box.

 

You can request features and report issues here: https://tracker.adobe.com/

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 22, 2021 Jan 22, 2021

Copy link to clipboard

Copied

LATEST

There's a lot to learn in the new UI. You'll soon get used to it.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp