RoboHelp 2020 Salesforce Lightning Integration Setup

New Here ,
Feb 01, 2021 Feb 01, 2021

Copy link to clipboard

Copied

I've been having issues configuring the Salesforce Lightning Knowledge integration. I have been able to successfully authenticate and choose items like article record type and data category, images successfully upload into Salesforce, but I get an error message when trying to publish a new topic/article. Here is the publish log:

 

checking user profile
uploading attachments to Saleforce "Files" section...
fetching existing files in 'Files' section
uploading attachment: /Users/me/Documents/My RoboHelp Projects/outputs/company/Salesforce/assets/images/2021-01-08_14-42-46.png
successfully uploaded attachment: /Users/me/Documents/My RoboHelp Projects/outputs/company/Salesforce/assets/images/2021-01-08_14-42-46.png
making the attachment /Users/me/Documents/My RoboHelp Projects/outputs/company/Salesforce/assets/images/2021-01-08_14-42-46.png accesible in knowledge
successfully made the attachment /Users/me/Documents/My RoboHelp Projects/outputs/company/Salesforce/assets/images/2021-01-08_14-42-46.png accesible in knowledge
successfully made the attachment /Users/me/Documents/My RoboHelp Projects/outputs/company/Salesforce/assets/images/2021-01-08_14-42-46.png accesible in knowledge
fetching attachment /Users/me/Documents/My RoboHelp Projects/outputs/company/Salesforce/assets/images/2021-01-08_14-42-46.pngdetails
successfully fetched attachment /Users/me/Documents/My RoboHelp Projects/outputs/company/Salesforce/assets/images/2021-01-08_14-42-46.pngdetails
failed to upload attachment: /Users/me/Documents/My RoboHelp Projects/outputs/company/Salesforce/assets/images/2021-01-08_14-42-46.png,[object Object]
uploading topics...
fetching existing articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
fetching existing next page articles
updating existing articles
fetching all existing article version ids..
successfully fetched all existing article version ids..
creating draft for new ArticleTest Topic
failed to create article: Test Topic
publishing chunk of draft articles
failed to publish articles, TypeError: Cannot read property 'substr' of undefined
= == == == == == == == == = 

 

Does anybody have suggestions on how to correct this?

Views

157

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 01, 2021 Feb 01, 2021

Copy link to clipboard

Copied

While it's not mentioned in the RH vague notes topic, your salesforce login needs to have Publish Articles permission. Double-check that as a first step.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 02, 2021 Feb 02, 2021

Copy link to clipboard

Copied

Thanks for replying! I checked the permissions on the SF article. I have full access to all of them except the translation and article import permissions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 01, 2021 Feb 01, 2021

Copy link to clipboard

Copied

I think this is the relevant SF help topic, but talk to your admin.

https://help.salesforce.com/articleView?id=sf.knowledge_setup_users_lex.htm&type=5

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 02, 2021 Feb 02, 2021

Copy link to clipboard

Copied

Someone has marked the answer as correct. Was that you and does that mean you can now publish? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

Hello,

 

Unfortunately I'm still running into the same issue and cannot publish.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

This is with the "Publish Articles" permission that Amebr mentioned?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 05, 2021 Feb 05, 2021

Copy link to clipboard

Copied

Correct I have full access to all these permissions from the SF knowledge link:

2021-02-05_12-28-55.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 06, 2021 Feb 06, 2021

Copy link to clipboard

Copied

Sorry but as this is a new feature there is limited support in the forums. I can only suggest you try Support.

 

See https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp for your support contact options.

 

Please post back with whatever they advise to help the next person who hits this problem.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 06, 2021 Feb 06, 2021

Copy link to clipboard

Copied

LATEST

Also check you have one article type with Rich Text Field. (I'm going off the documentation for Flare, but I think this reflects requirements on the Salesforce side, rather than tool specific.)

 

And you're generating Content Only output, yes?

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp