Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Template Error: can not resolve macro: OutputCurTocChunkDataBlock.xml

New Here ,
Dec 29, 2015 Dec 29, 2015

Copy link to clipboard

Copied

hi i received "Template Error: can not resolve macro: OutputCurTocChunkDataBlock.xml" when compile project to webhelp with substring search enabled

and this is the whole error:

Template Error: can not resolve macro: OutputCurTocChunkDataBlock.xml("0","1=book,name,url,target,images; 2=item,name,url,target,images; 4=project,name,url,ref,target,images; 8=chunk,name,url,ref,target,images;") in C:\Users\admin\Desktop\striphpp\!SSL!\WebHelp\whxdata\whtdata0.xml

...Template Error: can not resolve macro: OutputCurTocListChunkDataBlock("1") in C:\Users\admin\Desktop\striphpp\!SSL!\WebHelp\whgdata\whlstt1.htm

this error happened when compile large html  files to webhelp any ideas why this error accord but when disable substring search it build successfully without problem

TOPICS
WebHelp

Views

581

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 30, 2015 Dec 30, 2015

Copy link to clipboard

Copied

This sounds like some RH files were corrupted. Since when does this occur? Right after installing or did it start suddenly? Also, is this is a single project that is giving problems, or have the sample projects the same problem.

If it is a problem on all projects, I would first try a reinstall.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 31, 2015 Dec 31, 2015

Copy link to clipboard

Copied

this occured in RH 11 and 2015  single project contain  about 1500 HTML files sub string search will not work no matter what i do i think its bug in RH ... i will try to install it again and see what will happened

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 31, 2015 Dec 31, 2015

Copy link to clipboard

Copied

Before you do that, see if it occurs with one of the supplied sample projects.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 31, 2015 Dec 31, 2015

Copy link to clipboard

Copied

the sample projects works but my projects is very large it's imported from hpp project whenever i compile the project from generated web help or responded layout it finished with above error  and the whxdata folder  missing files and the size of folder is just about 200 kb when i reduce the number of html file in my project then it will works

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 03, 2016 Jan 03, 2016

Copy link to clipboard

Copied

That points at something in the project rather than the installation but the only note I have on Cannot Resolve Macro relates to installing RoboHelp without having admin rights.

Who installed Rh and did they have admin rights at the time?


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 04, 2016 Apr 04, 2016

Copy link to clipboard

Copied

LATEST

I have this same error and I just re-installed Robohelp 2015 with administrator rights.

The generation of the Web Help continues after the error and completes, and in the Batch Generate screen the project is marked "Generated" so, it seems like the error is insignificant, but it is disconcerting.

I have not actually looked at the output to see how it is affected by this,

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp