Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


WebHelps generated on laptops using RoboHelp 2017

New Here ,
Sep 16, 2020 Sep 16, 2020

Copy link to clipboard

Copied

Hi,

In our project RoboHelp 2017 is being used on laptops. Whenever we generate the WebHelp, we encounter issues such as loss of formatting and few topics with 0 KB in the folder. We have to regenerate at least 3-5 times for the files to appear correctly. The issues werent there when we used desktops. Can somebody please help? 

Views

246

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 16, 2020 Sep 16, 2020

Copy link to clipboard

Copied

The issue is with how RoboHelp was set up when you moved to the laptops.

  1. Was it installed on them with admin rights?
  2. Have you applied the updates?
  3. Is the project on your local drive?
  4. Are you generating to the same drive?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

Thanks Peter for your response. Here are my responses:

1. Yes, it was installed onto our laptops with admin rights.

2.I am not sure about this since the software installation team handles it. We raise the relevant software version request with them and they install it on our machines.

3 & 4. It is either saved on the default Desktop or Documents folder and generated to the same location. However, every file and folder is also automatically synced with OneDrive.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

Your version is easy to check, go to Help > About.

 

However I am thinking the One Drive is your issue. I have had problems with it in the past with RoboHelp projects and see this recent thread. https://community.adobe.com/t5/robohelp/my-entire-rh-2019-project-was-lost-anyway-to-recover-source-...

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

As a quick test, create a c:\output\ folder & generate into that (I'm pretty sure OneDrive only synchs with folders you've told it to - if that's not the case, you'll have to turn off the connection temporarily).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 18, 2020 Sep 18, 2020

Copy link to clipboard

Copied

The version currently in use is 13.0.2.334 and 13.0.0.257of RoboHelp 2017. I am afraid we have never needed to apply any of the patch updates since such issues were never faced when working on the files using desktops. 

At first, we thought the same that the issue had to do with OneDrive. I created a new help file on my laptop and generated it a couple of times. I encountered the same problems. Mind you, I wasnt connected to OneDrive while working on RoboHelp. Even Jeff's suggestion asking us to disconnect temporarily is not possible for few of the laptops as they come configured with OneDrive sync turned on at all times.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 18, 2020 Sep 18, 2020

Copy link to clipboard

Copied

You say that you have not needed to apply the updates but I see you have on one machine. It's always preferable to have all machines on the same version.

 

You thought the issue was OneDrive, I've had problems with it, another forum use has found it caused problems. I don't think you have much option but to get IT involved to test the theory.

 

Maybe RoboHelp Support can advise based on other users who have gone to them.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 18, 2020 Sep 18, 2020

Copy link to clipboard

Copied

AFAIK it's easy to stop the OneDrive connection  - just have your project up and running on your machine & disconect yourself from the Internet - can't synch without it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 22, 2020 Sep 22, 2020

Copy link to clipboard

Copied

Thanks Peter and Jeff for your help. Will revert with good news! 🙂
Funny thing is, a simple restart of the machine alleviates the problem to a certain extent. We now dont need to generate more than twice to have all the files appear correctly and with content.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 07, 2020 Oct 07, 2020

Copy link to clipboard

Copied

Hi,

How does one get in touch with the RoboHelp Support team? Till this monday, everything was working fine. We would still get a couple of files with 0kb, but a simple restart would alleviate the problem. However, for the last 2 days we have been seeing a lot of instances with 0kb. No matter, what we do? the problem hasnt gone away. We have restarted a number of times, delete the .cpd file, even turn off sync to OneDrive, create an output folder in C drive like Jeff suggested. I dont think the problem is with even the version that we use -13.0.0.257 of RoboHelp 2017 since the files work fine on desktop.This version has been used for more than 4 years now. In earlier thread, i mentioned by mistake 2 different versions, but i want to clarify, the team uses the same version 13.0.0.257. 

I am having to think that it must be some desktop vs laptop issue. Is it possible that because desktop CPUs are more robust than laptop's, that is why we didnt face any issue with Adobe software like RoboHelp and Captivate? What is the hardware specs that are required in a laptop to run Adobe software? Does anybody know?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 08, 2020 Oct 08, 2020

Copy link to clipboard

Copied

The first thing Support will want you to do is apply the updates so I would suggest you do that before doing anything else. Updates need to be applied by an admin so you will need to involve IT. They can either apply the two updates from within RoboHelp or download once from https://www.adobe.com/support/robohelp/downloads.html. The fixes can be accessed from there and do not list this problem but that doesn't mean they might not fix it.

 

It might also be worth trying a complete uninstall and reinstall. It doesn't take long and does not affect your projects.

 

Now let's get back to laptop versus desktop. Your laptop could be the issue but most definitely not just because it is a laptop. There are many laptops that are way more powerful than most desktops. If the issue is your laptop it is simply because of the way it is set up. The published requirements are very low and misleading. They are what is required to make a project work but with no mention as to how well. Think how well a small truck would work with the engine out of your car. It would move but show it a hill and it would crawl. Virtually any modern Windows laptop will do but low ram will impact. If you have at least 8mb, that should suffice. Even with less, I don't think what you are seeing would be the outcome, I would expect it to simply fail to complete.

 

What I would be doing now is get IT to do the following.

  1. Uninstall RoboHelp and reboot the machine.
  2. Log in and install RoboHelp again and apply both updates.
  3. Get them to open RoboHelp once and close it.
  4. Disconnect the machines from the network.

 

Then I would open RoboHelp and check the version shows update 2 has been applied. Just to be sure. Then I would generate the project.

 

Avoid OneDrive like the plague while this is going on. If IT insist that you must have some synchronisation, explain that others have had issues with RoboHelp and OneDrive. I have used Google Drive successfully but it is vital you ensure the taskbar shows synchronisation is complete. You cannot use any cloud solution to have two people are working on the same project at the same time. For that you need source control.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 08, 2020 Oct 08, 2020

Copy link to clipboard

Copied

Thanks Peter for your response. We have approached the software installation team. They are going to look into the issue. You have talked about source control. Can you please explain a bit about this practice? Also, what are the challenges that writers usually face if they work on their RoboHelp project using a remote desktop or VDI setup? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 09, 2020 Oct 09, 2020

Copy link to clipboard

Copied

Source control is complex to set up and not something I can help you with.

 

Remote desktop working is fine as effectively it is the same as working directly on that machine.

 

Virtual Desktops though are another thing. Are you saying that you are working on a virtual desktop and did that start when you went to the laptops? If the answer is yes, I suspect that is where your problem is.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 09, 2020 Oct 09, 2020

Copy link to clipboard

Copied

We work on the RoboHelp project locally on our individual laptops. We zip and share our source files. We either import the updated topics into the project of the writer who will generate the WebHelp or if the changes are minor then only one writer works on the source files and not the entire team.  I simply wanted to know about working on a RoboHelp project in various setups. The current WFH situation and RoboHelp issues have made me curious.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 09, 2020 Oct 09, 2020

Copy link to clipboard

Copied

OK. It seemed like a possible explanation. Let us know what happens when IT have done their bit.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 19, 2020 Oct 19, 2020

Copy link to clipboard

Copied

Posting an update:
1. Installed RoboHelp 2019 - so far, what we've found is that if we generate using WebHelp (merged Responsive HTML5) option,  no 0 kb files get generated. Does this mean that changes in WebHelp output implementation for one RoboHelp version is affecting the other older RoboHelp versions for WebHelp output? 
2. We do not encounter 0 kb files issue with our responsive Help files while using RoboHelp 2017 to generate. Hence, the problem seems to be with only WebHelp output.

3.I have some questions about webhelp output generation in RH2019. Do I post it on this thread or start a new thread? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 20, 2020 Oct 20, 2020

Copy link to clipboard

Copied

I will take another look but it will not be this week. Sorry. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 23, 2020 Oct 23, 2020

Copy link to clipboard

Copied

Installed RoboHelp 2019 - so far, what we've found is that if we generate using WebHelp (merged Responsive HTML5) option,  no 0 kb files get generated. 

When I said apply the updates I meant to 2017. Are you now talking about 2019 Classic or 2019 New UI? 

 

Does this mean that changes in WebHelp output implementation for one RoboHelp version is affecting the other older RoboHelp versions for WebHelp output? 

Are you trying to work on a project in two different versions? If that is what you mean it is not something you should do.

 

Am I right in thinking you cannot share one of these projects with me so that I can take a look? 

 

If you are still on Classic, have you tried deleting the CPD file from an errant project and then generating?

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 12, 2020 Nov 12, 2020

Copy link to clipboard

Copied

Thanks Peter for your response. Sorry for the late reply. Earlier, we thought of applying patch updates for RoboHelp 2017, but we came to know from the software installation team that support was not available for this version and this was one of the reason why the team only had RoboHelp 2019 in their catalogue. So, we went ahead and moved to a higher version. No worries, we managed to update RoboHelp 2019 as well (14.0.14.002).

We are using RoboHelp Classic 2019 as it has features that we need to use most frequently for our Help. Even after we had moved to 2019, we still saw 0 kb files in our folders. Eventually, due to some backend system updates (all of us think this is the reason) 2 writers in our team have been able to generate the WebHelp with no empty or 0kb files. Sadly, I am still facing this problem.
Yes, we cannot share our project files outside the organization.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 08, 2021 Jul 08, 2021

Copy link to clipboard

Copied

@Peter Grainge 
Posting an update on this issue- meant to write this 2 months back, but got busy with work. It seems that a simple reimaging of the OS can fix this problem. In my case, the IT team customised my OS as per organization's rule since the laptop came with customisation done by the vendor. Also, they replaced Windows 1909 with 1809 in my laptop. However, RoboHelp works fine in either of this version. So, I guess one can put it down to system issue.

It works fine now. Apparently, my file gets generated in much short amount of time now- 1 hour.

But if I were to have the file generated on someone else's machine, it takes 2 hours. It seems that this other person will have to give her laptop to the IT team for a check-up (she also experiences the occasional 0KB files).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 12, 2020 Nov 12, 2020

Copy link to clipboard

Copied

Eventually, due to some backend system updates (all of us think this is the reason) 2 writers in our team have been able to generate the WebHelp with no empty or 0kb files.

 

I think that pretty much gets RoboHelp off the hook and establishes the issue is environmental. If a project on your machine is copied to another machine or multiple machines and works on all other machines, there has to be something about the machine set up. By copying you know all the settings in the SSL are the same, the tags are the same and so on.

 

Ask IT to create a new profile for you without deleting the old one and then generate again. I have seen different issues fixed by that but it's a last resort as the settings for all your other programs will be affected.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 08, 2021 Jul 08, 2021

Copy link to clipboard

Copied

LATEST

Thanks for confirming it was the environment.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp