Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Vendor Stock access - site is not working ERR 400

New Here ,
Apr 23, 2020 Apr 23, 2020

Copy link to clipboard

Copied

Hello

I try to become a contributor by uploading images via my Adobe ID account and I encounter following problems: 

1. Firstly, the site is automatically redirecting to the Suisse (french language) as I am living in Switzerland.  I find id odd that based on geography, the sites can be accessed only in local languages ( German and French). What about the poor ex-pats living in the country? Why not disconnect the language choice from geography? 

2. Despite being automatically redirected to the french site and having my city and street address of my account registered to Switzerland, the country is shown as "United States" and the selector does not work, despite Switzerland (Suisse- in french) appearing in the drop-down menu.

3. I try to access the vendor area to upload pictures, but I get the following error: 

This page isn’t working

If the problem continues, contact the site owner.

HTTP ERROR 400
4. There is "no direct way" to contact the site owner, the "contact us" function takes you to the forum and "help yourself area where there is no topic about Adobe STock errors. 
5. Error 400 is not listed anywhere where the "virtual assistant" is sending me. 
6. Does anybody know how to fix such a problem? 
TOPICS
Account management, Licensing, Troubleshooting

Views

111

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation