Type 1 fonts not visible to Adobe apps on Win7

New Here ,
Apr 21, 2010 Apr 21, 2010

Copy link to clipboard

Copied

I need to use some Type 1 fonts that are standard for my employer, on a Windows 7 machine. Based on other threads here, I used Afm2pfm to generate the missing .pfm files. I was then able to copy the font files into the Windows font folder. They are now available in Microsoft Office applications (e.g., Word, PowerPoint), but not in Adobe CS3 applications (e.g., Illustrator, InDesign). I also tried creating a \Program Files\Common\Adobe\Fonts directory (it did not exist), and copying the font files in there. But that did not help.

In case the video driver matters, the machine is a Lenovo ThinkPad W500 and the video driver is ATI Mobility Radeon HD 3650.

Any clues?

Views

14.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Apr 22, 2010 Apr 22, 2010
Actually there was a known bug in the CS3 applications (but not in the CS4 versions of the same applications) whereby Type 1 fonts installed in the standard Windows font directory (nominally C:\WINDOWS\FONTS\ ) do not show up in the CS application font menus for both Windows Vista 64-bit and Windows 7 64-bit versions. You have two workarounds:(1)     Upgrade to CS4 (or very soon, CS5) and the problem does not occur.(2)     Install a copy of the .PFB and .PFM files in the private font directory o...

Likes

Translate

Translate
Adobe Employee ,
Apr 22, 2010 Apr 22, 2010

Copy link to clipboard

Copied

Janet,

Our Type QE wizard, Ernie March, tested a few of our old Type 1 fonts in his Windows 7 machine and had no problems. Everything worked fine in Word, Illustrator and InDesign.

If the fonts are working in Word, that's a good sign which means they're properly installed. In InDesign, are you sure the fonts are not in the bottom of the font menu list or something?

If you're still having problems you can put the fonts directly in a folder named "Fonts" inside InDesign or Illustrator folders.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Apr 22, 2010 Apr 22, 2010

Copy link to clipboard

Copied

Actually there was a known bug in the CS3 applications (but not in the CS4 versions of the same applications) whereby Type 1 fonts installed in the standard Windows font directory (nominally C:\WINDOWS\FONTS\ ) do not show up in the CS application font menus for both Windows Vista 64-bit and Windows 7 64-bit versions. You have two workarounds:

(1)     Upgrade to CS4 (or very soon, CS5) and the problem does not occur.

(2)     Install a copy of the .PFB and .PFM files in the private font directory of the CS3 applications.

     - Dov

- Dov Isaacs, former Adobe Principal Scientist (April 30, 1990 - May 30, 2021)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2010 Apr 25, 2010

Copy link to clipboard

Copied

Thanks! I'll try #2 on Monday. Upgrading is not an option at the moment. Is the "private font directory" different from \Program Files\Common\Adobe\Fonts? Because I did already try putting the fonts there.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 27, 2010 Apr 27, 2010

Copy link to clipboard

Copied

Option #2 worked for me. Because I'm running 64-bit Win7, I needed to put the fonts in \Program Files (x86)\Common Files\Adobe\Fonts. Should have thought to look there before.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 02, 2010 Jul 02, 2010

Copy link to clipboard

Copied

Actually, I landed here looking for a solution to my Type 1 fonts not being visible in InDesign CS5 running under Win7 64, so the problem still exists or has resurfaced in CS5?

The work-around was to put the pfb/pfm files in Program Files/Common Files/Adobe/Fonts [not in Program Files (x86), probably because I'm using the 64-bit version of Photoshop CS5].

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Jul 02, 2010 Jul 02, 2010

Copy link to clipboard

Copied

There is no known problem with Creative Suite 5 in terms of Type 1 fonts installed in the Windows Fonts directory not being seen by the Creative Suite 5 applications. I personally am running three systems with Windows 7 64-bit with Type 1 fonts installed in the Windows Fonts directory (and via links to that directory) and have encountered no problems accessing same in the CS5 applications.

You may be seeing a problem in which the Adobe font name cache files are out of sync with what is installed. With all Adobe applications closed, delete all occurrences of files name AdobeFnt##.lst where ## is a 2 digit number. Those cache files will be properly rebuilt the next time you run the applications.

          - Dov

- Dov Isaacs, former Adobe Principal Scientist (April 30, 1990 - May 30, 2021)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 03, 2010 Jul 03, 2010

Copy link to clipboard

Copied

Strangely, when I deleted the Program Files/Common Files/Adobe/fonts folder I had added as a work-around, I could still access the Type 1 font I desired, and its location was reported to be in the c:\windows\fonts folder. Perhaps the font name cache files were updated "globally" when I added the .../fonts folder?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 15, 2011 Jun 15, 2011

Copy link to clipboard

Copied

Got mine FIXED here is what i did:

Windows 7 64bit SP1, CS 5

Postscript fonts (comprising of *.pfb + *.pfm files) did not show up in any CS5 app, but showed OK in Word, Excel, Notepad etc.

Tried activating through Suitcase Fusion 2 and also through FontExpert 2009 - but neither of them made the fonts visible in CS5 apps

1) open Start Menu/Control Panel/Fonts

2) on the sidebar there is "Font settings" item

3) set the settings as i did

[    ]  Hide fonts based on language settings
[ x ]  Allow fonts to be installed using a shortcut (advanced)

FIXED mine,

now i can use Suitcase Fusion 2 to install any PFB/PFM fonts without any problems...

PLEASE IF THIS WORKED FOR YOU TOO, LEAVE A MESSAGE HERE SO OTHERS KNOW IF THIS FIX IS 100% WORKING

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 15, 2011 Jun 15, 2011

Copy link to clipboard

Copied

2 more TIPS:

1) after activating/deactivating fonts ALWAYS CLOSE Suitcase Fusion 2 before starting any CS5 applications

2) never use "," COMMA in your font file path

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 18, 2011 Jun 18, 2011

Copy link to clipboard

Copied

1 more TIP:

today some of my Type 1 PostScript fonts  (comprising of *.pfb + *.pfm files) that were PERMANENTLY ACTIVATED using Suitcase Fusion 2 on Windows 7 64-bit did not show up in any CS5 app !

- OPEN Suitcase Fusion 2 and CLOSE it

THAT FIXED IT...

fonts immediatelly appeared in all CS5 font menus...

YOU HAVE TO DO THIS FIX AGAIN AFTER EVERY PC RESTART...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 19, 2015 Feb 19, 2015

Copy link to clipboard

Copied

LATEST

Hello,

I've done everything suggested in this thread:

-created a \Program Files\Common\Adobe\Fonts folder and put .pfb, pfm, otf and tff font files there

put .pfb, pfm, otf and tff font files in \Program Files (x86)\Common Files\Adobe\Fonts

deleted AdobeFnt##.lst

and finally

1) open Start Menu/Control Panel/Fonts

2) on the sidebar there is "Font settings" item

3) set the settings as i did

[    ]  Hide fonts based on language settings

[ x ]  Allow fonts to be installed using a shortcut (advanced)

Nothing works.

My PC OS is Windows 7 enterprise and I use Adobe Photoshop CS6, extended; the same file works on a different PC, apparently with  same settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines