I cant use my GPU in Premiere Pro 2018, Adobe Media Encoder, After Effects

Explorer ,
Jan 17, 2018 Jan 17, 2018

Copy link to clipboard

Copied

Hello I have a big problem.

My GPU dont works. I cant use it for rendering (OpenCL)

I have a Asus ROG Strix RX 470. And i5-6600k

It must work my GPU is good 😕 I have all 2018 versions. I mean PePro2018, AE 2018, MEncoder 2018...

I've just buyed 32GB of RAM for AE... I'm a student I dont have much money and I dont want to spend again a bunch of money for a CUDA graphics card...

I dont understand why it shouldnt work with my RX 470.

There's no reason why it shouldnt work...

[And I still dont understand why AE is using only CPU for the most rendering... we have 2018 guys.. but thats now another topic..]

does anyone have any ideas?

I already tried this tutorial:

HowTo Enable OpenCL for AMD Cards in Premiere Pro CC 2017 - YouTube

I think it worked only in 2017. Adobe removed this trick in 2018, and thats also very sad and unfair

TOPICS
Hardware or GPU

Views

64.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Contributor , Feb 03, 2018 Feb 03, 2018
For systems with multipls GPUs, the solution is to Disable OPENCL support for the INTEL GPU in the registryComputer\HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenCL\VendorsIt will show  AMD and Intel.  Set the intel dll to 1 to disableI was looking for a solution for two years and found it this week!

Likes

Translate

Translate
LEGEND ,
Jan 17, 2018 Jan 17, 2018

Copy link to clipboard

Copied

Unfortunately, in all versions of After Effects you're permanently stuck with CPU-only rendering if you're not using an Nvidia GPU. In addition, the Ray-Tracer GPU feature has been depreciated by Adobe, in favor of a mostly CPU-only version of the Cinema4D renderer. (This means that although it's been updated to permit some newer Nvidia GPUs to use it, no new features are being added.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 19, 2018 Jan 19, 2018

Copy link to clipboard

Copied

So, should I get a Nvidia GPU? Would it be worth?

Because ,,Mercury Playback Engine'' would benefit from it. How much would be the benefit?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 19, 2018 Jan 19, 2018

Copy link to clipboard

Copied

That all depends on what effects and features you use in your workflow.  Do you do much scaling or frame rate changes?  What media?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 19, 2018 Jan 19, 2018

Copy link to clipboard

Copied

I use much animations and keyframes. Also much transitions. In Full HD always. (Im speaking about after effects)

In Premiere Pro I just cut everything together. I do mainly everything in AE.

What do you mean with ,,what media''?

Also one problem is that ,,Mercury Playback Engine'' doesnt works with my GPU in the Adobe Media Encoder. And that costs a lot of render time 😕

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 19, 2018 Jan 19, 2018

Copy link to clipboard

Copied

In a CMD window run "GPUSniffer.exe" Here is an example from my system.

It will tell us something about your RX 470

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 20, 2018 Jan 20, 2018

Copy link to clipboard

Copied

He you go!

(i already tried deactivating my Intel Graphics/GPU in BIOS, and in Windows, I still cant use my RX470)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 20, 2018 Jan 20, 2018

Copy link to clipboard

Copied

Well that looks good.  If you really want to see your GPU working in Premiere try running my Premiere Pro BenchMark (PPBM)

You should be able to see 99% GPU Loading in GPU-Z on the Sensors Tab on the MPEG2-DVD Timeline export with GPU acceleration (Step 2)

What do you see in Premiere when you go to File/Project Settings/General

Here is my CUDA verification, you should see your OpenCL option

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 21, 2018 Jan 21, 2018

Copy link to clipboard

Copied

Thats the problem that I also have in Media Encoder and After Effects, there isnt listened the option ,,OpenCL'' 😕

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 20, 2018 Jan 20, 2018

Copy link to clipboard

Copied

That doesn't look good, especially since you currently have both the integrated Intel HD graphics and the discrete GPU enabled, which in Premiere causes major conflicts with one another. And since Premiere does not currently permit the selection of the GPU being used, that means that as long as you fail to disable the integrated Intel HD Graphics in your system's BIOS / EFI, the Premiere MPE renderer is semi-permanently locked to the integrated Intel graphics.

EDIT: I saw that you already tried that. The only to properly disable that Intel GPU is to not only do what you did, but also completely disconnect everything from the motherboard's video (DVI, HDMI, DisplayPort) outs, and (if necessary) completely uninstall the video drivers and software for the Intel IGP.

Hope this helps,

Randall

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 20, 2018 Jan 20, 2018

Copy link to clipboard

Copied

Randall,

Thanks for that info.  I guess then that even if the OP had an nVidia card it would not make any difference.

Bill

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 23, 2018 Jan 23, 2018

Copy link to clipboard

Copied

Anybody has been able to solve this?

OpenCL works perfect on 2017, but not on 2018. How is this possible? I has to installed both.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 23, 2018 Jan 23, 2018

Copy link to clipboard

Copied

thats also my problem I think. I dont checked OpenCL on 2017, but on 2018 it definitely doesnt works

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 24, 2018 Jan 24, 2018

Copy link to clipboard

Copied

Running MEdia encoder 2017 give me the option to use my graphics card. Even After Effects and Premiere let me select it, but Media Encoder 2018 wont let me select my graphics card and only lets me use the software renderer.

2018 is really making me upset because everything worked fine and used my graphics card until I upgraded. Premiere will randomly not recognize it and I've updated the drivers to the most recent drivers multiple times.

Beyond aggravating.

-Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 24, 2018 Jan 24, 2018

Copy link to clipboard

Copied

Neil,

Have you tried the GPU-Z trick.  Install GPU-Z and when you do set it to run when you open Windows If it is running before you start Premiere it should stop the intermittent problem

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 24, 2018 Jan 24, 2018

Copy link to clipboard

Copied

Thanks Bill. I tried that and does nothing. It is something with Premier 2018. At the moment I have 2017 and 2018 installed in the same computer. If I open 2017, I can select the OpenCL and it is fine. But in 2018, I can select the OpenCL and there are plugins that I can't use.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 27, 2018 Jan 27, 2018

Copy link to clipboard

Copied

well I cry why is adobe doing this to us

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 31, 2018 Jan 31, 2018

Copy link to clipboard

Copied

Here you can see Premier Pro CC 2017 and 2018. Both installed in the same machine and running at the same time. AdobeSupport​ Please fix this.

ThanksPremier 2017-2018.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 01, 2018 Feb 01, 2018

Copy link to clipboard

Copied

Hello,

In Windows/system32  rename/delete this file:

amdocl64.dll

also i think for 2018 they put this amdocl12cl64.dll

Just rename and OpenCl Mercury will be available. (might not actualy use your GPU but option will be there) I noticed it still uses my Intel GPU not my AMD

/J

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 03, 2018 Feb 03, 2018

Copy link to clipboard

Copied

For systems with multipls GPUs, the solution is to Disable OPENCL support for the INTEL GPU in the registry

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenCL\Vendors

It will show  AMD and Intel.  Set the intel dll to 1 to disable

I was looking for a solution for two years and found it this week!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 03, 2018 Feb 03, 2018

Copy link to clipboard

Copied

Now there is a real simple but brilliant solution!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2018 Feb 08, 2018

Copy link to clipboard

Copied

Hey

Thanks for your response

I was just wondering if you could please tell me if I have followed your instructions Correctly

cheers

jh.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 09, 2018 Feb 09, 2018

Copy link to clipboard

Copied

Yes, setting intel dll to 1 will disable it..

It has worked for me 100%

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 09, 2018 Feb 09, 2018

Copy link to clipboard

Copied

Didn't seem to work, oh well I'll have to use intel UHD graphics

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 09, 2018 Feb 09, 2018

Copy link to clipboard

Copied

Simply doing that without restarting your system won't do.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines