Questions
Recently active
Hi,The Java version for the Cold Fusion 11 in the Development and Test environments is: Java Version 1.7.0_51 The Java version for the Cold Fusion 11 in the production environment is Java Version 1.8.0_25 Is it possible to bring the development and test up to the Java version in production without installing the Cold Fusion build that was used in the production install?If so, how would this be done?Thanks,Mike
HiThe Java version for the Cold Fusion 11 in the Development and Test environments is: Java Version 1.7.0_51 The Java version for the Cold Fusion 11 in the production environment is Java Version 1.8.0_25 Is it possible to update the Cold Fusion Java version in the Development and Test enviroments with the version rom the production install without installing the build used in the production install?If so, how would this be done?Thanks,Mike
So, we're having a issue where some of our longer running processes are crashing with a 503 IIS error of Server Unavailable. We have tried all the suggested settings of tuning the connectors using the "workers.properties" and "server.xml" files. We've rebuilt all the connectors after the most recent updates. I've even disabled IIS Rapid Fail. But the issue continues to happen.We have CF11 Update 5, Win 2008 R2, IIS 7.The crash usually occurs at around 60 seconds of a page load. All the timeout settings I can find I've set for 240 seconds or more yet we keep hitting this 60 second wall.The only thing that looks to be a clue is in the ISAPI logs which seems to show the connector constantly restarting. Also, we suspect some of our processes are taking extra long to complete due to this known bug. I believe this is related to an issue Ben Nadel has also blogged about. We've had huge processes in the past that took 4 to 5 minutes to complete without
For consumption of external web services, is there anyway to force all calls to use Axis 1 across the server?I know you can do it at the application level:this.wssettings.version.consume = "1";and at the invoking level:this.wsobj = createObject("webservice", wsUrl, {wsversion="1"});But I'm looking for a way to force it for all applications and invocations.I've tried to change the value under "Web Service Version" to "1" in the administrator, but it didn't work at all. I think this setting is just for web service publishing, not consumption.Thanks.Nick
I currently am using CF11 and I need to install the latest mySQL driver. I have downloaded it but am unsure which folder it needs to go in. Also, are there any configurations that need to be dealt with in CF Administrator for this new driver?The driver that I intend to install is mysql-connector-java-5.1.35-bin.jar
I've been developing CF for many years, but it's been a while since I built any CF apps from scratch and I'm looking for a good refresher. I'm especially looking for any book or tutorial in which one or more actual advanced CF applications are built over the course of the entire book, as opposed to just going over all the features chapter by chapter (like in the CF Web Application Construction Kit). I'll keep looking on my own, but just in case anyone knows of something off the top of their head, I'd appreciate any suggestions. Thanks!
I recently applied Hotfix Update 5 (hotfix_005.jar) through a silent install to one of my Sandbox Linux Servers. After doing this, I went to the Server Update->Updates->Installed Updates and see only "There are no installed updates". I then ran the interactive update and saw the message "this update has already been applied". Are there any other indicators in the CF11 Console that indicate that this update was made?Server DetailsServer ProductColdFusionVersion11,0,0,289974EditionEnterprise Operating SystemUNIX OS Version2.6.32-431.20.5.el6.x86_64 Adobe Driver Version5.1.1 (Build 0001) Thanks!Doug
I there a way to export a formula with report builder? I want to export =E4*F4 on the first line then =E5*F5,etc. My user want to be able to change the value (Yield Rate Percentage) in E4.Any guidance is appreciated
Hello,I have successfully connected and queried a Progress Open Edge database 10.2B and have dumped the data using <cfdump>. I have tried to use <cfoutput query> with out success.Please see below,<cfquery name="list" datasource="progress1> SELECT "Employee"."Employee-ID","Employee"."Employee-Name"FROM "sams"."BUB"."Employee" Where "Employee"."Record-Active"='1' ORDER BY "Employee"."Employee-Name"</cfquery><CFDUMP query="list"> / Displays all of the fields from the select above.When I try using <cfoutput> #"Employee"."Employee-ID"# </cfoutput> I receive errors. I have tried with " and ' and with only # and many others.Please advise if some one knows and has successfully displayed this data using <cfoutput>Thanks,TJ
Hello, we're trying to debug problem we have with custom jar files that keep hanging our ColdFusion 11 instances with nothing being logged anywhere. One of the troubleshooting steps we want to do is to switch our new ColdFusion 11 Update 5 setup to run on JDK 1.7 instead of 1.8, because we know these jar files run just fine on our ColdFusion 9 JDK 1.7 platform. So, we repointed the instance we want to run in JDK 1.7 to correct JDK directory and tried to start the instance but the service will not start. We looked at the log file and Server Event Viewer shows this error: "... service terminated with the following-specific error: The system cannot find the file specified". The ColdFusion-our file doesn't have anything in it for that error (I don't think ColdFusion even gets to that point). The coldfusion-error.log file doesn't have anything specific either. Can someone help us debug this? Is there a way to increase the debug level so that we can get more info in ColdFusion log files? Tha
Helping the nonprofit globalgoodspartners.org create a working archive of their recently retired CF site (they moved to Shopify). The CF site has been relocated to new host and will be accessed only for historical needs.We're getting "Error Executing Database Query. FUNCTION globalgoods.fullname does not exist " when accessing the admin. The error is preventing the admin menu from displaying.Original CF developer is not available, and I do not know CF.Here is the full output of the CF error...==========The web site you are accessing has experienced an unexpected error.Please contact the website administrator. The following information is meant for the website developer for debugging purposes.Error Occurred While Processing RequestError Executing Database Query.FUNCTION globalgoods.fullname does not exist The error occurred in D:/home/globalgoodspartners.org/wwwroot/admin/contact/contact_view.cfm: line 32Called from D:/home/globalgoodspartners.org/wwwroot/admin/contact/contact_view.cfm:
Running CF 11 on Ubuntu 14.x . Attempts to connect to a Sybase installation yields:java.sql.SQLException:nullIf I give it a bad username/pw combo I get a login FAIL, which is what I'd expect. I can't find info on the sybase jdbc driver - does it require certain versions of the Sybase to work? I believe this one is on Sybase 11.Thanks,N. Alexander
I had a motherboard fail on a server. We were in the middle of converting from SHA-1 to SHA-2 certificates. When we replaced the motherboard, CF9 seemed to work. But then we finalized the SHA-2 certificate and were advised to delete the older SHA-1 certificate. That was done and CF9 still seemed to work. Then we returned a month later to start using the server for production again and got errors that indicated we now had a developer edition rather than a standard edition. I changed the license serial number and it seemed we should be functional again. Now only the localhost (127.0.0.1) https admin section is functioning. No files https or http, cfm or html, are being delivered. The error is 404 or failure to connect but nothing is registered in the logs as to why templates are not working. I am not sure if the motherboard exchange is involved, IIS or the certificate -- or all three. I don't think the facts lead to ColdFusion 9 as being at the root of the problem, but still CF9 is not w
Considering upgrading from CF8 up to CF11... notice in the CF11 support matrix that Sybase Adaptive Server Enterprise 15.0, 15.5 is not supported. While we primarily connect to Oracle DB, we do need to connect to Sybase DBs periodically.Is the plan for CF11 to support Sybase again in the near future?
Hi,I have just installed Colld Fusion 11 in the production environment. I am not able to replicate the issue in the other non production environments using Cold Fusion 11.Some users are able to use the date picker using the below. Other users are not able to use the date picker. It appears bu when selected it does not work....cfinput type="datefield" .....Some of the users are using IE 11, IE 9 or IE 8.I can access the functionality using IE 11 and 9.This affecting the users performing there important functions.Is there a solution to this issue?Thanks,Mike
Anyone have a solution to or a work around for the issue with cfexchange not talking to Exchange 2010? We are migrating to 2010 within our company and I have several applications reading Exchange 2002 and 2007 calendars.Ryan
I recently installed CF11 (Enterprise in Trial mode) on a new Server 2012 R2 system. I have an ERP application that uses a Progress database. I installed the vendor specific 64bit ODBC driver (Progress OpenEdge 10.2B) and configured it in the 64bit ODBC Data Source Mgr on the server. I tested the connection from within the Data Source Mgr and it was successful. When I attempt to create a DSN in CF11 though the vendor specific driver does not appear in the dropdown list. I tried to create a DSN using "ODBC Socket" and filled in the same "Data Source Name" as that used in the OS's Data Source Mgr, but after a minute or so this error appears, "The ColdFusion ODBC Server service is not running or has not been installed." I confirmed that the CF11 ODBC Server and Agent services are running on this server so I am not sure why this error is claiming otherwise.I would greatly appreciate any assistance on this. I was able to create a MS SQL DSN in CF11 with no problem, so at least some are work
Hi,Is it possible to update existing PDF text and image using cfpdf?Thanks,
what plug ins do i need for cfgrid to work in web browsers?
Hi,I installed Hotfix 005 to my CF11 Installation .After that I get the error:Element STATUSCODE is undefined in CFSTOREDPROCwhen executing stored proceduresExample:<cfstoredproc procedure="is_authorized" datasource="test" returncode="YES"> <cfprocparam type="in" cfsqltype="cf_sql_varchar" value="#username#" > <cfprocparam type="in" cfsqltype="cf_sql_varchar" value="CUST_W" ></cfstoredproc><cfoutput>#cfstoredproc.StatusCode#</cfoutput>In the earlier Release everything was okay.Any ideas?Thanks Claudia
I have a dynamic site.When I insert an integer (a whole number) in a raw materials purchase table, I get the following message:Error Executing Database Query. [Macromedia][SQLServer JDBC Driver][SQLServer]Cannot insert explicit value for identity column in table 'tblRawMatlPurch' when IDENTITY_INSERT is set to OFF. When I change to or insert a numeric, decimal, or money value, I get the following message:Raw Materials DecisionCompany: GrandeYou have NOT successfully submitted the Raw Materials Decision formPlease note that the purchase amount must be a whole number, please do not enter a decimal for this number.Return to correctI have two programs: one is in the secure section, and the name is secure/raw_materials_decision_action, indicating that the raw material purchase variable (rawMat) is a money variable. Giving this information I set it in SQL as a money variable. Here is the file: <!--- get Company
While testing clustering, I realized that each ColdFusion instance will write CFIMAGE temporary files to its own ./tmpCache/\CFFileServlet path. The issue is that CFFILESERVLET gets a mapping (alias, virtual directory) in the webserver to one folder. If I have two ColdFusion instances setup on a cluster, within the same server, the image is generated and stored in one of the two instance installation folders. There is a 50/50 chance that the file is stored in the folder that isn't mapped in the web server configuration.Is there a "proper" way to handle this, when using two ColdFusion instances installed on the same physical server?
We are running Coldfusion in production and I am setting up a developer edition for local development. When I enter http://someServer.com/ml.cfm?aID=378 it works just fine. When authenticate and start passing session CFID & CFToken (http://someServer.com/ml.cfm?aID=378&CFID=12345&CFTOKEN=54321), I receive the 403 error page. Is there something in Coldfusion that is throwing the error?
Would like the know if anybody has done authentication with ADFS 2.0. Need pointers on how to go about.Basically, when user arrives to my site, if the token is not present, direct him/her to ADFS login page and get the SAML token, then decipher the SAML token to extract the username.
Hello,I am using jQuery AJAX to call a function from a .cfc page. As of now, I am just using console.log(result) to see what response I get. And what I got is the content of the coldfusion component page. And if I type the url on the browser I get the same...This is my code to make the call using AJAXindex.cfmjQuery.ajax({ url: 'sch_acc_maint_func.cfc', type: 'POST', data: {method: 'student_info', accnumber: accnumber, dsrc: dsrc}, //variables are defined , but I have not posted the code... success: function(student){ console.log(student); }});The contents for sch_acc_maint_func.cfc, can be seen on the picture.I am running Coldfusion 9 on a unix server.Has anybody experienced this situation? Any advise will be really appreciated.
Remix with Firefly Community Gallery
Thousands of free creations to fall in love with and remix in Firefly.
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.