Questions
Recently active
I recently moved from coldfusion 8 to coldfusion 9 but all the pages with cfgrid: is throwing the following error. Any suggestion would be of great helpcoldfusion.jsp.JRunTagLibraryInfo$NoSuchAttributeException: The tag handler gridcolumn does not have a setter for the attribute autoExpand specified in the Tag Library Descriptor.at coldfusion.jsp.JRunTagLibraryInfo.getPropertyType(JRunTagLibraryInfo.java:627)at coldfusion.jsp.JRunTagLibraryInfo.buildTagInfo(JRunTagLibraryInfo.java:585)at coldfusion.jsp.JRunTagLibraryInfo.getTag(JRunTagLibraryInfo.java:267)at coldfusion.compiler.NeoTranslationContext.findTagName(NeoTranslationContext.java:346)at coldfusion.compiler.NeoTranslationContext.isKnownTag(NeoTranslationContext.java:222)at coldfusion.compiler.CFMLParserBase.isKnownTagName(CFMLParserBase.java:589)at coldfusion.compiler.cfml40TokenManager.TokenLexicalActions(cfml40TokenManager.java:6704)at coldfusion.compiler.cfml40TokenManager.getNextToken(cfml40TokenManager.java:6586)at coldfusi
A while back I posted an issue relating toCFThread GC Overhead Limit Exceeded. Someone marked a reply as the answer but the issue is still ongoing.After months and months of reading and taking different approaches to try and implement a working solution I'm still no further forward.Most recently I've started trying to use the MAT plugin within Eclipse to determine if I'm encountering my issue due to a memory leak issue, however I do not understand the information that is being displayed to me.Can anyone analyse what is being displayed below please?Do I have a memory leak issue that needs addressed? And is it likely this is what is causing my CPU usage to get maxed out and the CF service (and eventually the system) come to a standstill?
Hello,I have an instance of CF10 running behind a proxy server. For the CF Admin to be able to get CF Updates, I had to add this line to the JVM Arguments.-Dhttp.proxyHost=xxx.xxx.xxx.xxx-Dhttp.proxyPort=xxxxThat worked fine. For my scheduled tasks to work locally I needed to add the following line.-Dhttp.noProxyHosts="localhost|127.0.0.1|10.*.*.*"That worked fine for 2 years as well as after all the updates. This past weekend I applied Updates 14 & 15. After the updates (which I manually executed) it seems like the JVM is no longer respecting the noProxyHosts entries. I have a scheduled task that points to:http://localhost/fileToExecute.cfmBefore the updates, this worked as expected. After the updates, all I get is a message from the proxy server telling me this site is forbidden. Don't get to hung up on the message from the proxy server. It is a government public webserver and we use a proxy server to control access to the internet
I've just installed ColdFusion 11 on a clean Windows Server 2008 R2 machine and the ColdFusion application service looks like it starts, but then a minute later, shows that it is not running (in the services panel). When I try to restart it, it simply will not start. It comes back with the typical error "This application took too long to respond..." so now it just hangs in a "starting" state. I've rebooted the server several times, there is nothing else running on the server. Any help would be appreciated. Thanks.
I finally go approval to do my upgrade not as a stand alone, side-by-side upgrade which was requiring me to do a major hack that wasn't working due to our funky coding and security twists we have implemented in the code.Unfortunately, when I do the upgrade/installation it installs, but I can't move on to the migration/configuration stage of the installation. I can't see anything in the error logs. Sometimes I'll get the 500.19 error message when I try to connect to the administrator myself, other times nothing. When I get the HTTP Error 500.19 Internal Server Error it refers to the ApplicationHost.config or web.config file that contains malformed xml element. When I look at the old web.config file it contains about 9 handlers that are using either jrun_iis6_wildcard.dll or jrun_iis6.dll. I do have the IIS6 to IIS7 configuration selected in the new installation of CF11, but I can't move forward. I want to just copy these 2 files from my CF9 installati
Hello,I have a new web server that I am testing before turning it on live. I have run into a cfmail issue. The server isWindows 2008 R2, 64Gig ram, 64-bit, IIS 7.5, Coldfusion 9.0.2 multi server, clustering 2 CF instances, JDK1.7.0_71We had a company setup CF and harden so this may be related to the hardening but I am not sure. <cfmail is not sending email to recipients outside of our domain/work domain. The 1st <cfmail> tag below sends the email but the 2nd one does not. This is what I see when trying to send via the 2nd <cfmail> tag with external recipient email address domain- no errors on the page I run in the browser- email is not received at me@home.com (syntax is correct)- attempt #2 shows up in mail/Undelivr folder- mail.log has this error "Error","scheduler-3","01/15/15","10:13:27",,"javax.mail.SendFailedException: Invalid Addresses; nested exception is: com.sun.mail.smtp.SMTPAddressFailedException: 550 5.7.1 Unable to relay- application.log -
Hi,Coldfusion version 10.The app hangs using IE9 when I do a REST cf function call from js file. Observing the console, I see Pending status. However, it works fine in later versions of IE, Chrome and Mozilla.When I changed cffunction httpmethod from DELETE to PUT it worked. So, I figure that maybe javascript function call and cffunction header mismatch. ------------------------------------------------------------------------------------Here is cffunction;<cffunction output="no" name="zeroUpdateCredits" access="remote" produces="application/json" consumes="application/json" returnType="struct" httpmethod="DELETE"><cfargument name="DATA" type="struct" required="yes"/><cfset var retStatus = StructNew() /><cfset retStatus["success"] = true /><cftry><cfset var qSponsDetails = APPLICATION.cfc.properties.getsettings(DATA.employee_id)><cfif qSponsDetails.allow_credits> <cfset temp = saveCredits(credits = 0, employee_id = DATA.employee_id, eff
I am running CF11 using Tomcat 7 and jdk1.7.0_45. I have non-SSL sites that execute the exact same task fine. However for my SSL enabled sites, the task will not run. Does anyone have an idea as to what is causing this?
I have two servers which I have connected to the cfbuilder. First one is localhost, which works okay, even debugger.Second is vmware XP image, which i can connect to the builder via new add server setup window.settings:Name:Vmware XPtype: Other hostname:192.168.21.2port: 80All other settings are blank.At the mappings I have mapped my localpath to the server remotepath:Local path:C:\Projects\Coldfusion\ProjectRemote path: \\vmware-host\Shared Folders\Project.After I do that, the server comes to the server list, shows running. CFBuilder can connect to rds server. But I cannot start debug yet, so I go to preferences and add the wmvare xp server to the project, and see that the rds configuration is ok (no password is needed, so I clear the login imfo and the prompt for password checkbox)After that debug works, and all is well.Then after I shutdown cfbuilder, and restart it, ONLY the localhost server is found! the vmware xp is nowhere, it has just vanished from the server list. And of cours
I have a table usersdev that contains my users information. It has 73 fields.I want to create a trigger so that when a certain field named active_indicator is updated I insert information into a table named audit_users.I have successfully created that trigger See code below. But for the trigger I am only concerned when the active_indicator is updated.The problem is that when any of the other fields is updated the update doesn't save.How do I set the trigger so that all off the fields in the usersdev table can be updated -not just the active_indicator field?Its almost like I need to disable the trigger if the active_indicator field wasn't being updated.This code right below works to save the active_indicator change information to an audit_users table.But again only the active_indicator keeps the updated informationUSE [mydatabase]GOSET ANSI_NULLS ONGOSET QUOTED_IDENTIFIER ONGOALTER TRIGGER [myTriggerUPDATE2]ON [usersdev]INSTEAD OF UPDATEAS
I'd grateful for help in creating a hash value that is "base64 encoded, hashed (SHA-256) with the secret key string that is a concatenation of the a few values I have (accountId, userId, and Time)"The documentation given to us has a sample and shows us how to create the hash via PHP, but I need to know how to do this in using ColdFusion. Below is the sample starting values and the correct output for those sample values. If I can recreate this then I can create what I need with real values. Sample Values from Documentation (using PHP) $key = 'abc123';$accountId = 123;$userId = 123456;$time = 1379605500; // 9-19-2013 15:45:00 GMT$signatureString = $accountId . $userId . $time;$signature = base64_encode(hash_hmac('sha256', $signatureString, $key, "true"));So, using the above sample values the documentation show that the string "1231234561379605500" will be converted to this hash, "DSJHPt7kUbRdB8U9XfCXXe4eTXDkiqpGud1Z0fO9EPg="Does anyone know how to do that in ColdFusion? I'm too emb
OK, I got CF 11 set up with IIS with Distributed Mode. All set after lots of searching and posting to this Forum. Thanks for that but now I have two new problems I need to get resolved.Seems simple enough, but I got Multi-Homing set up via the server.xml in Tomcat side, but when you enter the domain only (www.site.com) you get "You do not have permission to view this directory or page." wand if you enter /index.cfm at end of URL all works as expected. Very Troubling.I have attempted these things already: WEB-INF/web.xml to define welcome pages and no luck. Read a few posts with similar issues on CF9 but not answers. Just wondering how to over come issue here.Send issue, is communication to site is over HTTPS via SSL. Not a problem, right. Well communication between IIS server (in DMZ) to CF server (inside firewall) is not encrypted. Determined by packet sniffer. I am open to any comments or suggestions on how to resolve this i
We have a ColdFusion 10 x64 server running on Windows 2008 R2. Fairly regularly but at sporadic times the ODBC server stops responding to Access databases. MySQL and MSSQL still work and verify, but access times out. The only way to resolve is to restart IIS, ColdFusion, and the ODBC server. I've tried just resetting each individually, but the only fix is to restart all services. I installed the latest MDAC and I configured all the Access data sources to use the new driver under the 32bit version of ODBC. "Microsoft Access Driver (*.mdb, *.accdb)". All of the updates are applied to ColdFusion 10 and Windows 2008. Is there anything I can look at or something someone can recommend? Again, only the Access data sources time out. The MySQL and MSSQL data sources continue to verify. Thanks!
HiWe've just upgraded to CF11 update 3 on a 64bit Windows 2008 Server from CF10 and have found that my previous code to clear cached database queries no longer works as instantly or reliably as it did previously.I'm currently using the following code in my application.cfc file. This code would run if I were to hit the following page on the website... index.cfm?reinit=yes<cffunction name="onRequestStart" hint=""><cfif structKeyExists(URL, "reinit")><cfset cacheRemoveAll()> <!--- Added 7th Jan 2015 without improvement---><cfset onApplicationStart()><cfobjectcache action="clear"></cfif></cffunction>Here's an example of a query I'm trying to clear the cache of<cfquery name="rs_Issue" datasource="#APPLICATION.dsource1#" cachedwithin="#CreateTimeSpan(0,1,0,0)#">SELECT Issue_ID, Issue_NameFROM IssueWHERE Issue_Status = <cfqueryparam cfsqltype="cf_sql_varchar" value="Current"></cfquery>Has anyone got any suggestions of what I'm
Hi friends,I am working on coldfusion 10 and i have the following requirement,How I need to display 100 records in first page with 18 records visible and remaining 82 records visible should be through scroll bar.Your help is greatly appreciated.Thank you in advance.
I have a form field I want to control what a user can enter. It's for a blood product unit number.The format will always be:W1202 follow by the last 2 digits of the year 14 followed by 6 numbers 123456Final entry W120214000001.That is what the unit number will look like - eye readable. The issue I have is that there is also a barcode and it's obviously easier for staff to enter it accurately if the scan it.The barcode has start (=) and stop (00) characters, so in this example it would look like =W12021400000100.Is there a way to detect if the first character is an = and strip it, preferably on the form? Then, if it is over 13 character and the last 2 character are 00, strip those as well? And while we are at it, make sure the unit number is a total of 13 consecutive characters? Your guidance is greatly appreciated.
Hi All,I am creating the captcha using cfimage. In my project we have three different environment dev, stage , production. However I am getting the the captcha image for production and dev but in stagging I am not getting the captcha image. When I am checking captcha in firebug I am getting the image "src" attribute as, "/CFFileServlet/_cf_captcha/_captcha_img2787831475697289656.png" for all three environments but the image not displaying only for stage.Please help me.ThanksSaurav
I'm hoping to use cfpdf to add a certifying signature to a pdf. There's no obvious way to indicate you want a certifying signature (as opposed to an approval signature), and no obvious way to indicate permitted actions after certifying. Is this functionality just not there?Bob
In CF11, Update 1, & Update 2 in the CF11\config\wsconfig\#\ folder there was a file called iprestriction.properties that contained the following;*/CFIDE/main/ide.cfm=**/CFIDE/adminapi/*=**/CFIDE/administrator/*=**/CFIDE/componentutils/*=**/CFIDE/wizards/*=**/CFIDE/ServerManager/*=*After updating to CF11 Update 3 and then rebuilding one of the connectors that file has been removed along with the reference to it in the isapi_redirect.properties file.Was this done on purpose or was this a regression because it looks to contain security related settings?
Does anyone know what to do to fix a non-working <cflocation> tag?Upgrading web site from WS2003 ColdFusion 8 to WS2008/64bit ColdFusion 10. Upgrading CF application has required a number of CF code and database tweaks. Application is processing normally with the following exceptionWorking on site upgrade few days ago, one <cflocation> tag in web application stopped transferring to its target page. I've placed <p> debug statements before and after the <cflocation> tag in question; and <p> debug statement at the start of the target page. the <p> before <cflocation> displays. But then the page ends without transferring. No error is indicated by either CF, CF logs, or the web server. Could this be an server application pool problem? IIS is using DefaultAppPool application pool. I've verified Cookie session is maintained. Also adding CF10's SessionRotate() to application home page, made no change to <cfl
I was wondering if for each file the cfindex is indexing, if I could get the last modified date of the document and insert into my custom field called "sort_date_s". I notice in the cfdump that the author and title field is extracted automatically but can I get it to extract anything else.<CFINDEXCOLLECTION="mycollection"ACTION="UPDATE" URLPATH="htttp://mywebsite.com/myfolder"TYPE="path"KEY="D:\Websites\mywebsites\myfolder"EXTENSIONS=".doc, .docx, .xls, .xlsx, .pdf, .pptx, .ppt"RECURSE="Yes"searchtype_t="docs"language="english" sort_date_s ="last modified date here">My goal is display search results from 2 collections ( a database one, and the file location one (above)) and display to the users the most current information first so that is why my files need to have some sort of date. If there is a better way, I am open to suggestions.
cflayout type="tab" name="mainTab" ><cfloop query="qgetdcfg"> <!--- Each layoutarea is one tab. ---> <cflayoutarea title="#qgetdcfg.dsource#-#qgetdcfg.djobnamespec#" name="#qgetdcfg.dsource#-#qgetdcfg.djobnamespec#" selected = "true" > <h2>Tab name</h2> <p> <cfset datasource = "#qgetdcfg.dsource#"> <cfset duser = "#qgetdcfg.duser#"> <cfset dpassword = "#qgetdcfg.dpassword#"> <cfset djobnamespec = "#qgetdcfg.djobnamespec#"> <cfinclude template=all_js.cfm> </p> </cflayoutarea></cfloop></cflayout>The above almost works. The all_js.cfm has only two parts to it, it formats a pie chart and then displays a few rows of data based on the datasource, user and password and djobnamespec variables.The two tab sho
Is there a way to display the value of cfqueryparam upon a database error? For example:<cfquery name="causeError" datasource="#application.dsn#"> select street1 from house, #table2# where house.houseid = #table2#.houseid and house.houseid = #form.houseid#</cfquery>The variable table2 is dynamically generated and let's say an error is caused table2 being an empty string or a table that doesn't exist. So the error given is:[Macromedia][Oracle JDBC Driver][Oracle]ORA-00903: invalid table name4 : <cfquery name="causeError" datasource="#application.dsn#">5 : select street1 from house, #table2# where house.houseid = #table2#.houseid and house.houseid = #form.houseid#6 : </cfquery>SQL select street1 from house, where houseid = 123;So I know that the user was trying to look at a house with houseid = 123. I can then try to replicate the error using the same record in the database which can ultimately can help me
Hi,I am using Cold Fusion 11.When I browse to obtain the file to upload, the location and file in the text box is: S:\App\test.xml<cfform action="fileaction.cfm" enctype="multipart/form-data" method="post"> <P>Enter the complete path and filename of the file to upload:</P> <CFINPUT type="file" name="FileUp" size="90"> <P><input type="Submit" value="Upload"></P> </CFform>But when the above code execute, the following location appears in the variable:D:\ColdFusion11\cfusion\runtime\work\Catalina\localhost\tmp\neotmp803964384012527716.tmpWhen I remove the enctype="multipart/form-data" from the code, the file is found, but the error message in the Cold Fusion admistration is:Invalid content type: application/x-www-form-urlencoded.The files upload action requires forms to use enctype=""multipart/form-data"".Is there something in the Cold Fusion 11 administration or configuration files that needs to be changed?This
Hi All,I have used Cybersource's Hosted Order Page for the past 8 years, but they are eliminating that option and are offering Secure-Acceptance in it's place. The only trouble is, Cybersource offers no ColdFusion support or API. I have pulled apart their PHP example and thought I'd share what I have working so far. You should follow the steps in http://www.cybersource.com/resources/collateral/pdf/Secure_Acceptance_WM_Quick_Start_Guide.pdf to get the AccessKey, ProfileID, and SecretKey you'll need for this example. Here are the two pages I created "payment_form.cfm" and "payment_confirmation.cfm". You can get the payment.css, payment_form.js and jquery.js from the PHP download link in the PDF I mentioned. I'll post more, as I get father along...Have a good one,- Shawn=================================================payment_form.cfm=================================================<html><head> <title>Secure Acceptance - Payment Form E
Remix with Firefly Community Gallery
Thousands of free creations to fall in love with and remix in Firefly.
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.