Questions
Recently active
Hello,I am getting ready to upgrade a server to RH6/CF10. I have been unsuccessful getting ODBC connections to work with ColdFusion on Linux. Does anyone know if the upgraded versions have solved this issue, or will we still have to use JDBC instead of ODBC?Thanks!Dejah
We are using coldfusion10 enterprise edition. Now we have issue on ColdfusionAdmin schedule tasks page. It shows null pointer error and we couldn't open or edit schedules task page from coldfusionadmin. Can you help us?here is an error belowThe system has attempted to use an undefined value, which usually indicates a programming error, either in your code or some system code. Null Pointers are another name for undefined values. Resources: Enable Robust Exception Information to provide greater detail about the source of errors. In the Administrator, click Debugging & Logging > Debug Output Settings, and select the Robust Exception Information option. Check the ColdFusion documentation to verify that you are using the correct syntax. Search the Knowledge Base to find a solution to your problem. Browser Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0) Remote Address 127.0.0.1
I'm having a problem with my cfspreadsheet. I try to create an excel file which will trigger the browser to download and open the file created. Its work fine in other browser But I'm having a problem to save and open the file with IE 8. The file successfully create in the directory but fail to call the file create to download. It only can be done if I put a direct link to open the excel file. This is the code that I use to trigger the file to save and open. Does anyone knows the other way?<cfheader name="Content-Disposition" value="inline; filename=file.xls"> <cfcontent type="application/vnd.ms-excel" file="template\excel\file.xls">
I was using CF10 and my site response time was quick, especially on my local development machine. I upgraded my development and live servers to CF11 and both seem to have a delay in first access. It seems to be client and possibly browser specific. If I just walk away for about 10 minutes and come back, then when I try to load my site (on my local machine) it takes about 10 seconds to load. As long as I keep using it it is fast and responsive, but if I walk away for 10 minutes again and come back, it seems to have to wake up.Is there a setting that I can tune? Is anyone else seeing this?I will also make note that even if one website I am developing on is quick and responsive, as soon as I try to access another website using the same IIS and CF11 then it has a wait time. It is like it is figuring something out with the browser before it is willing to load.
This week I've been working on getting clustering setup for a client. Initially we were using CF10 with the latest patches. Ideally we wanted non-sticky load balancing with session replication. We want really high availability with the option to reboot a server at any time and not have to wait for session draining or lose customers if a node goes down. Adam Cameron points out that there is an issue with CF10 and not having an option to turn on session replication Adam Cameron's CFML Blog: Problem with session replication with CF10 clustering. Trying various fixes I could not get the session to replicate we moved to CF11 which restores that issue. There is a bug open for CF10 with some weird responses but I never saw any sort of fix for this.CF11 as noted solves this odd issue, so I thought we were in the clear. Following the limited cluster setup guides found online there is some manual configuration to do on the remote instance. First, I am not sure if the default cfusion instance jus
Hi all,I am working on a calendar scheduling function for a school that I'm having a hard time wrapping my brain around. My DB table has 3 columns - ApptDate, ApptTime, ApptSlots. Most ApptDates are listed more than once because there is more than one time available for a date. See below for example: ApptDateApptTimeApptSlots9/9/20143:00 PM29/9/20143:30 PM29/9/20144:00 PM2The page queries this table for all data. Then, there is a query of that query that selects distinct dates and outputs them in a drop down--the first step in a user choosing their appointment. The next form field I'll have is a drop down for times. What I'd like to happen is based on the user's date selection, the corresponding times will appear in the time drop down, as long as ApptSlots gt 0. Before the user selects a date, I'd like the time drop down to be hidden or disabled.Is this a possibility or am I dreaming?Thanks for the help!
I finally got my Mac 10.7 setup with CF 10 and Apache using multiple virtual hosts. I'm now trying to get my first REST service up and running but not having much luck. I solved my 500 server errors and the 404 issues. Now I have a service registered. Problem is when I call the service it writes this to the application log."Component crude could not be found.Check if the path is correct or the application has been registered succesfully. The specific sequence of files included or processed is: '''' "When I access it using cfhttp it returns a status code 200 but the filecontent is empty. When I access the service using my browser I get a status code of 200 but nothing returned.Any suggestions on what could be going on? Rest service mapping in CF AdminRoot path: /Users/myaccount/Documents/AdobeColdFusionBuilderworkspace/00localDevService mapping: restappApplication.cfc app name is restapp<cfset This.name = 'restapp'>My file calling the rest service.<cfhttp url="http://testapp:85
CF9.01: I see undesired entries in http.log. The appear to be generated by some hostile code on the server. But the log does not show which file generated the log entry. Is there a way to determine this? I have text-searched for hard coded links as shown in the examples below but found none. I am using IIS6. Examples of the unwanted"Information","jrpp-34","08/20/14","21:43:52",,"Starting HTTP request {URL='http://www.stopforumspam.com:80/api?ip=74.86.158.106', method='GET'}"The referenced IP is not on our system.Another: "Information","jrpp-41","08/20/14","23:23:57",,"Starting HTTP request {URL='http://3264335898:80/n/a.txt', method='get'}"
Where did the 9.0.1 Update go? I can't find it anywhere
I am facing an Issue while reading Excel sheet (xls/xlsx) created from Microsoft Office 2013.Here is the error#1: An error occurred while reading the Excel: org.apache.poi.EncryptedDocumentException: The supplied spreadsheet seems to be an Encrypted .xlsx file. It must be decrypted before use by XSSF, it cannot be used by HSSF.#2: An error occurred while reading the Excel: org.apache.poi.hssf.record.RecordFormatException: Unknown encryption info 4.I tried with CF9 and CF10. Found same error on both versions.Also, I updated POI jar files with updated POI 3.10 but no luck.Followed these links :https://issues.apache.org/bugzilla/show_bug.cgi?id=56564https://issues.apache.org/bugzilla/show_bug.cgi?id=35897Any help will be appreciated. Tx
HI, I can't seem to figure out what is the issue with this query, maybe someone can help me pleaseError Executing Database Query.[Macromedia][SQLServer JDBC Driver][SQLServer]Incorrect syntax near ','.Error Executing Database Query.[Macromedia][SQLServer JDBC Driver][SQLServer]Incorrect syntax near ','.Rishi
I am using CF Ver 9.0.0I have created a Solr Collection via CF AdminOnce Indexed the Solr collection shows 65262 KB data but 0 documents. This is consistent with other Solr collections but not their verity counterparts.Documents are located on a separate drive and I am indexing txt, pdf, doc, and xlsAm I doing something wrong?Thanks
So I've installed the 64 bit CF 11 Developers Edition on a Windows 7 machine, working with IIS, What I'm seeing is that when I have CF set to start automatically in the Windows Service Manager, the CF application service fails. In the Window System Event log I see this error."The ColdFusion 11 Application Server service terminated with service-specific error The system cannot find the file specified."In the CF log I see this."Either the server is already running or some other application is using the AJP port 8014"When this happens, I somehow lose my ability to access the internet, though I appear to be connecting to my router without an issue. I've tried looking for port 8014 in the Windows Resource Monitor and I don't see it being used there by anything. If I change the CF services so that they don't start automatically, then boot up, log in, and start them manually, then everything works fine.Any insight into this problem would be greatly appreciated.
I am having issues installing CF 11 on CENTos 6.5 Although a test installation working on a virtual machine (preparing the installation in development), it fails with these errors from the log:Execute ANT Script: Script: unix_basic_commands.xml Status: ERROR Additional Notes: ERROR - unix_basic_commands.xml:210: Execute failed: java.io.IOException: Cannot run program "/tmp/580148.tmp/temp-init.sh" (in directory "/tmp/580148.tmp"): error=13, Permission deniedExecute ANT Script: Script: unix_basic_commands.xml &
I using a cffileupload to upload a file into server, but the component give me an error "Status code:403". Somebody have any idea?
I have a new 64bit laptop that I plan to use for developing. I am working on a project that uses CF 10. I'd really like to get a copy of the 64 bit CF 10 so I can install the developer version on my laptop. Is there any way to get one? I have a copy of the 32 bit installer on my current laptop, but I don't really want to install that version.
I would like to confirm session replication working in CF10 cluster set up.First, I am using 30-days trial version (just installed for one or two days). If cluster will not work with 30-days trial version, then we could stop here. After following the instruction at<a href="http://help.adobe.com/en_US/ColdFusion/10.0/Admin/WSc3ff6d0ea77859461172e0811cbf363c31-7ffa.html">http://help.adobe.com/en_US/ColdFusion/10.0/Admin/WSc3ff6d0ea77859461172e0811cbf363c31-7ffa.html</a>, with J2EE session enable and distributable existed in web.xml,I could see log entries like "INFO: Replication member added:org.apache.catalina.tribes.membership.MemberImpl... "To me, the node was recognized within cluster at this point. Next, I would like to confirm session replicated as well. I used sample at<a href="http://help.adobe.com/en_US/ColdFusion/9.0/Developing/WSc3ff6d0ea77859461172e0811cbec22c24-7c30.html">http://help.adobe.com/en_US/ColdFusion/9.0/Developing/WSc3ff6d0ea77859461172e0811cbec2
Win 7-64bit, CF 11.Tried installing a new download of CFB3 ( 8/21/2014 download ) and came up with a "Standard edition trial expired" problem. I participated in the CFB3 alpha and beta, but never tried the released version. Is there a way to completely clean out CFB3 so I can try the released CFB3?Thanks,Doug
We've recently upgraded to CF11 Enterprise and have noticed that files seem to be getting written to our {CFHOME}\cfusion\logs folder. The files take the format of OUT1_23539608830713455679092769999515830316.tmp and appear to be getting created when we call CFPDF with the merge function although I have not confirmed this is the triggering event yet. Can anyone tell me why we would see *.tmp files get created in the \cfusion\logs folder and how to stop it from happening. I don't think these files are in any way wanted or needed. Thanks.
Been a few years since I worked with tag based cf.Was trying to create a search form to search db records that matched the user inputs. I basically copied old tutorials code from cfwack 9 and the OWS examples files. These files use a derby database and of course work fine.I copied the search,cfm and results.cfm templates and just replaced all the values with my database vals. Im using an access database and i get an error when I run the query.As you can see, it says Im missing an operator in the WHERE clause. Again, this same code seemed to work fine in the ows tutorial db. Im wondering if its because its an access db and the operators may be different?Here is my query: <cfquery name="plm" datasource="dawnFoods"> SELECT ProductDataSpec.ID, ProductDataSpec.projectName. ProductDataSpec.desc, ProductDataSpec.skuDetails FROM ProductDataSpec WHERE 0=0 <cfif FORM.projectName IS NOT ""> AND projectName = #FORM.projectName# </cfif> ORDER BY ID </cfquery> Not sure why t
My error template is throwing an error itself and its coming from the Java object. See below error message, can some one please tell me what is going on here. Does the application have to have permission to access? Here is the error messageValue must be initialized before useIts possible that a method called on a Java object created by CreateObject returned null.The error occurred in errorHandler.cfm: line 1513 : }14 : //produce the event list15 : events = factory.DebuggingService.getDebugger().getData();16 : //restore debugging status17 : 
CF10 reverted to the Developer Edition seemingly overnight. I checked other posts about the license.properties file and making sure the serial number is in there. We have uninstalled / reinstalled as well as restarted the service and server. Need some help on new next steps.
Could someone read this and maybe suggest some different approaches to resolving this??ERROR MSG:•Connection verification failed for data source: mysqldbv2com.mysql.jdbc.exceptions.jdbc4.MySQLNonTransientConnectionException: Could not create connection to database server. Attempted reconnect 3 times. Giving up.The root cause was that: com.mysql.jdbc.exceptions.jdbc4.MySQLNonTransientConnectionException: Could not create connection to database server. I've entered the following lines in CF11 administrator: CF Datasource name: mysqldbv2JDBC url: jdbc:mysql://localhost:3306/mysqldbv2Driver class: com.mysql.jdbc.DriverDriver Name: mysql 5.0User name: rootPassword: 123 (this is development computer offline)I'm using MySQL Workbench 6.1Windows 7 machine. Using CF11.I've tried everything I can think of. Firewall is off. Log files in CF admin offer no help. Same with MySQL.
Hello,Can anyone give tips re the following: I need to create a load balanced ColdFusion environment consisting of 2 servers each with a webserver that is connected to it's own CF10 server.The traffic to the ip adress is encrypted via https.The load balancer should be able to assign a client session to a specific server and keep it there during the duration of the session - so effectively making it sticky.What would be the best setup here?Do I need to create a cluster of 2 CF10 instances and assign the cluster to webserver 1 and webserver 2 so it is stcky? Or else, if I use 2 standalone ColdFusion instances, how can I make sure the sessions are replicated or sticky?Thanks,Marc
I have two related questions:1. CF10 and integration with Java Web applicationsWe have a couple of Java applications running on JRun and interfacing with CF9 applications. The JRun clusters were created through the JRun Admin and, apart from lack of Axis 2.0 support, have served us well for years now. And, as would be the case, the ColdFusion9/Java/Flash application is a critical public-facing application that the business uses for bidding on projects.It appears that with ColdFusion 10 on Tomcat, we will not be able to run those Java applications on a Tomcat-CF10 JVM cluster. Is this correct? IF so, what are our options? 2. J2EE Application Servers supported by Adobe for CF10Which of these is correct?A. This URL (http://www.adobe.com/products/coldfusion-enterprise/faq.html) states "ColdFusion 10 supports IBM® WebSphere, Oracle® WebLogic, Adobe JRun, Apache Tomcat, and JBoss."B. This URL (http://wwwimages.adobe.com/www.adobe.com/cont
Remix with Firefly Community Gallery
Thousands of free creations to fall in love with and remix in Firefly.
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.