Questions
Recently active
I am trying to consume webservices on my CF 10 environment. I keep getting a CompilationFailedException error looking for java/utils. I have uninstalled CF, uninstalled the jdk, used the bundled jdk, reinstalled jdk 17.0_25 but to no avail. I tried replacing C:\coldfusion10\cfusion\lib\tools.jar with the same file in the latest JDK as recommended on this forum on earlier releases encountering this error.I have pasted the text from coldfusion-out.log but changed the name of the server with the wsdl.Any direction is very appreciated.ThanksJun 21, 2013 11:29:09 AM Information [ajp-bio-8012-exec-1] - Starting Web service request.Jun 21, 2013 11:29:09 AM Information [ajp-bio-8012-exec-1] - Creating Web service proxy {url='https://serverdomain/rpc/soap-axis/confluenceservice-v2?wsdl'}Jun 21, 2013 11:29:15 AM Information [ajp-bio-8012-exec-1] - Using Axis 1 for consuming the service https://serverdomain/rpc/soap-axis/confluenceservice-v2?wsdl.Jun 21, 2013 11:29:16 AM Informa
Am making progress with:Windows 2012Apache Tomcat 7.0.42ColdFusion10 EnterpriseSince we need /CF to be our Context for ColdFusion web applications, I deployed ColdFusion as CF.war; everything has functioned nominally... until now: Session-replication is not functioning correctly. Question: are the errors below a consequence of deploying ColdFusion as cf.war (and a Context of /CF) instead of cfusion.war (and a Context of /Cfusion)?INFO: Starting clustering manager at /cfOct 30, 2013 2:31:44 PM org.apache.catalina.ha.session.DeltaManager getAllClusterSessionsINFO: Manager [/cf], requesting session state from org.apache.catalina.tribes.membership.MemberImpl[tcp://{167, 131, 75, 31}:4000,{167, 131, 75, 31},4000, alive=844838, securePort=-1, UDP Port=-1, id={-45 53 -56 -7 80 21 76 28 -110 113 71 -46 -62 -41 -88 52 }, payload={}, command={}, domain={}, ]. This operation will timeout if no session state has been received within 60 seconds.Oct 30, 2013 2:31:49 PM org.apache.c
GreetingsI have 3 distinct user types for my app- admins, appraisers and clients.All have their own directories and each directory has it's own Application.cfm:1) <cfapplication name="appraiseri" applicationtimeout="#CreateTimeSpan(0,2,0,0)#"clientmanagement="Yes" sessionmanagement="Yes" sessiontimeout="#CreateTimeSpan(0,2,0,0)#"SetClientCookies="Yes">2) <cfapplication name="appraiserview" ......3) <cfapplication name="clientview" .......Each have their own login which simply uses their ID in the DB as the session variable.login_do.cfm:1) Appraisers: <CFIF auth_direct_appraiser.RecordCount NEQ 0 ><cfset Session.appraiser_user_id =auth_direct_appraiser.appraiser_ID><cfset Session.appraiser_fname =auth_direct_appraiser.appraiser_fname><cfset Session.appraiser_lname =auth_direct_appraiser.appraiser_lname>2) Admins: <cfset Session.user_id =auth_direct.staff_ID> ......3) Clients: <cfset Session.processor_user_id =auth_direct_processor.processor_I
HiI recently upgraded from CF8 to CF11 and now CF11 does not seem to be able to send emails.In CFAdmin, I entered the mail server and settings to the point where, when I Verify Mail Server Connection I get a success message, "Connection Verification Successful", but no email gets sent.When i view the Log files for Mail in CF I see this error repeatedly:avax.mail.MessagingException: Could not convert socket to TLS; nested exception is: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested targetHas anyone else encountered this error? I can post plenty of additional detail if needed, both from the CF server and the Exchange server, if needed.Thanks in advance,Rich
I don't have the exact text of the error message right now, but for the last couple of weeks, on a nearly daily basis, when I launch CF Builder (v2) I get an error that says I don't have the adobe application manager installed, and my builder has been crippled to a 'lite' version or something. I then re-re-re-re-re-install the application manager, re-launch builder, re-input my serial number, and things are fine, just as they previously were for several years. The next day, however, I am likely to be told once again that I don't have the application manager installed, and have to repeat this process.Obviously, this is extremely frustrating. Any suggestions? Anyone? Please?Thanks,Dave
I have a database full of options for additions to houses. Porches, driveways, carports etc. Each of these options has a possibility of having different sizes depending on the house size. What I have right now is an admin page with a checkbox that is next to each option. If checked that option gets listed on the web page. My issue is that I need to include random sizes for each option if needed. For example, the web page would look something like this:Porch: 10' x 10'Now the checkbox would be for including the word porch, but how do I include the dimensions? I never know the exact size, and there is no set sizes. My thought was to put a form field next to each option that inputs the size manually. But how would that get transferred to the web page?\\This is what I am thinking of howNow the checkbox will add the words but the dimension form field is where I'm confused. How do I get the dimension field into the web page? Any help would be appreciated.
By dynamic, I mean the ability to change markers once the map has been drawn. As examples, Find Us | Tesla MotorsWhere you have, at screen bottom toggles to change what so show and render them without having to redraw CFMAP. Thanks.
Hi all,This is on Windows server 2008 R2, IIS 7.5 and Coldfusion 10 or 11. I have Coldfusion running under a local user on the machine and that works fine. I am trying to encrypt some folders using Microsoft EFS. I create the certificate for the user that runs Coldfusion and encrypt a folder. When I upload a file through Coldfusion to that folder, the file is not encrypted. If I login as the Coldfusion user on that machine and copy a file to the encrypted folder it does encrypt. For some reason when the file is placed there by Coldfusion, Windows is not recognizing that the file should be encrypted.First, has anyone else encountered this kind of behavior? Second, if not, could someone please try to confirm this behavior. If someone else encounters it I will log it as a bug.Thanks!Jim
OK,So apparently ColdFusion 11 has some new cluster functionality that uses a database. The supported databases include Oracle. However, as we have Oracle ExaData which uses service_name in connect strings rather than a SID we can't use the "normal" Oracle driver but rather have to use "other" and define the connection using the standard Oracle jdbc driver and connection string. This then means we can't use the Oracle database for the cluster schedule stuff. This is presumably wrong, as any SQL used to create tables or "use" them must be Oracle compatible.So, does anyone know either:How to connect to ExaData (or RAC using service_name as apparently that's basically the same) with the "standard" Adobe Oracle driverHow to persuade / tell ColdFusion that the "other" driver is in fact an oracle back end so I can use itI'd obviously rather not install a single point of failure in the form of either a simple MySQL database or a basic Oracle database just to make scheduling's cluster function
No matter what I try, I can't get this to work:<cfexchangeconnection action="OPEN" connection="conn1" server="[server]" username="[domain]\[username]" mailboxname="[mailbox]" password="[password]" protocol="https" formbasedauthentication="True" formBasedAuthenticationURL="https://[server]/owa/auth/owaauth.dll" serverVersion="2010">I've followed the instructions to the letter. The Exchange server has HTTPS enabled. It is running Exchange 2010. I've installed the HTTPS certificate on my server. Still, I get this:Could not login to the Exchange server.Verify the server name, username, and password. Ensure that proper client certificates are installed.What the heck am I doing wrong?
Just installed CF11 but I cannot open up any cfm pages
I have CF Builder 3 Trial installed as standalone application. Every time I restart CF Builder, the RDS mapping settings for the remote server I have are gone and also the remote ColdFusion server I set up is gone and I need to recreate it. Is there anything I can do to prevent that from happening? Thank you for any help on this issue, so far I spent few hours searching for a fix but can't find anything.
I've downloaded the ColdFusion Builder 3 trial and am experiencing some odd and very annoying behavior.I've customized some code editor text font and color settings. I've added an entry to the CF Servers panel for an instance of ColdFusion 10 running inside a VMWare virtual server on my laptop.When I restart Eclipse, all the code customizations I've made are reverted back to the default install settings and the entry in my CF Servers panel is gone.I've been an IntelliJ user for well over a year, but in doing much more cfscript-based development the CF Plugin for IntelliJ is proving to be a hindrance so I thought I'd give CFB 3 a try and see if there were any improvements over CFB 2. However, I can't take this kind of behavior. Hopefully someone can give me a setting or someone else has seen this before and can give me an idea of where to start looking.I have CF Builder installed as a plugin into Eclipse Kepler 64-bit for Mac. I added the CF Builder update site and have updated to CF Bu
I am running CF10 on IIS 7.5 with URL Rewrite module installed.All the rewrite rules work perfectly and ColdFusion is returning the correct pages. In order to get the page displayed in the browser I have to manually set the 'content-length' value in Application.cfc like this:<cfcomponent><cffunction name="onRequestEnd"><cfheader name="Content-Length" value="#getPageContext().getCFOutput().getBuffer().size()#" /></cffunction></cfcomponent>Without this code the browser does not display the page. However, even though it is now displaying the page, it is not doing it correctly. The page never finishes loading fully and not all of the HTML content seems to be on the page.I have tried to add a <cfflush> tag after setting the 'content-length' but it makes no difference. I don't understand why this is happening but I know that it has happened to someone else who was using htaccess: http://forums.devshed.com/coldfusion-development-84/page-not-finishing-loadin
Hello.I am trying to apply for a 30 days free trial on adobe connect, however when I submit my application this error occurs. What should I do? I have Windows 8/ google chrome.Please keep the answers short since I have a bit hard to to understnd difficult meanings.
It there a maximum amount of Ram that can be allocated the the virtual file system? When I specify more than 1 GB size, the system returns a negative number for the remaining free space, and any attempt to store a file resuts in storage limit exceeded errors.I've been unable to locate much detail about the VFS configuration via web searches. Any details are appreciated.Ronnie
Addition information. ColdFusion Application Server is not running and will not start error logAug 13, 2014 2:58:49 PM org.apache.catalina.core.AprLifecycleListener initINFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\ColdFusion11\cfusion\lib;C:\ColdFusion11\cfusion\jintegra\bin;C:\ColdFusion11\cfusion\jintegra\bin\international;C:\ColdFusion11\cfusion\lib\oosdk\classes\winAug 13, 2014 2:58:50 PM org.apache.coyote.AbstractProtocol initINFO: Initializing ProtocolHandler ["http-bio-8500"]Aug 13, 2014 2:58:50 PM org.apache.coyote.AbstractProtocol initINFO: Initializing ProtocolHandler ["ajp-bio-8014"]Aug 13, 2014 2:58:50 PM org.apache.catalina.core.StandardService startInternalINFO: Starting service CatalinaAug 13, 2014 2:58:50 PM org.apache.catalina.core.StandardEngine startInternalINFO: Starting Servlet Engine: Apache Tomcat/7.0.52Aug 13, 2014 2:58:57 PM org.apache.catalina
We installed CF 11 Standard 32 bit on a Win 2012 R2 server with IIS 8.5. We tried installing both with 32 bit "Enabled = False" and "Enabled = True". Both resulted in Error 500 or 500.19.Below are more details, with images following for the errors and the Handler Mappings.The CF11 HKLM software key is under the WOW6432Node key. We get the 500.0 error when the DefaultAppPool 32.bit setting is "false" and a Test.htm program works just fine. If we enable 32-bit, the result is a 500.19 error for both the CF admin and the Test.htm.
We have custom JAVA code that we are trying to interface with. The JAVA code works as expected within Eclipse JUnit. But when we try to reference the code in ColdFusion we get a "Cannot instantiate class: com.sun.jndi.fscontext.RefFSContextFactory" error. We have tried to put the fscontent and providerutil jars everywhere we could think of to get this resolved. We even tried to run JHades as a servlet listener to see what was happening with the class loading (the server would not even start with the listener in place.)We are using the context factory to access a .binding file that access IBM MQ message queues.We have tried to get this to work with CF9, 10, and 11. We have run 10 and 11 as standalone servers, then we even tried running 11 as a JEE application in JBOSS. Same error.
Greetings All,I was just recently upgrading my servers and ran into some trouble. I had ColdFusion 8.0.1 Standard up and running just fine on Apache 2.2.11 on a 64-bit CentOS 5.1 server. I got a new server, install CentOS 5.3 64-bit and then OpenSSL, Apache 2.2.11 and then tried ColdFusion 8.At first CF8 wouldn't install because the httpd binary I build was 64-bit, something I had never had a problem with before. So I recompiled apache with export CFLAGS=-m32 first and that got me a 32-bit apache httpd and ColdFusion would install.Once I started the ColdFusion the apache connector failed. I remember this problem from ColdFusion 7, but I don't remember ever having this problem with 8. I've look through all of the 64-bit related information and nothing works for me. I continue to get stuck trying to compile the mod_jrun22.so by hand. Here is the output when I try to compile it:/Error running "/opt/coldfusion8/runtime/lib/wsconfig/1/build_jrun22": exit code was 1Could not build Apache2 we
I have two variables date_end and Date_end_time. The form when being dumped is setting date_end to a {t 00:00:00} and not passing the date. When i look at the scope i see:DATE_END=01/01/2014DATE_END_TIME=but when i dump the form i get:DATE_END{t '00:00:00'}DATE_END_TIME[empty string]When i dump the form in application the variables are corect. Is there some funky coldfusion bs going on? like _required? this is annoying.
When we do a query.columnList on a table that contains a geometrydatatype column it errors with unsupported data type. This does notseem to be fixed in CF10 - Update 11. Have you heard of this, seenthis or have a solution to this issue?Super easy to reproduce, just create a table with a geom or geographycolumn, run a query Select TOP 1 * FROM TABLEWITHGEMO, whatever andthen do the queryname_columnList which normal returns column namesthat you can loop through (as you most likely know).
Coldfusion Builder 2 won't turn off Auto-Insertion of Matching Characters , even though nothing is checked in Typing Preferences. For example every time I type " or ' I get "" or '' Does anyone have this problem?
Small Cold Fusion shop and our setup has long been that we've each had our own CF server (development version) on our desktop that we developed against. We are being forced to move to a single server environment so I am researching best ways to do this. The first thing that jumped out was that we'd need multiple instances of the server so that each developer could hose/restart/etc their CF service. That obviously points to CF Enterprise and it's hefty price tag. After some research, it appears that the developer version WILL work the same way as the Enterprise version (multiple instances), with the same limitations as dev (localhost and one other IP address). This sounds like a much better solution, but I just wanted to confirm - is it safe to assume the ip restrictions are per instance? Seems it'd be silly to allow multiple instances, but still limit the ip's at the overall server level. We'll be looking for a setup where developer 1 (and thei
Hi,We seem to have run in to a problem with two CF instances having high CPU usage after 1-2 hours.We have three servers, two of which are back ends to a load balancer, the third is just on its own. They all have the default installation of CF 11 Enterprise running on W2012 R2 / IIS 8I noticed that CF installed on the two backend servers started using a lot of CPU (30-40%) after a couple of hours, then as time went on further so did the CPU usage. If left overnight it would be hitting 100% constantly.These are fresh installs and have no content being served except for the default web site in IIS. So this rules out dodgy code etc.All three servers have the same software installed on them and the same IIS configuration. I went through the CF 11 lockdown guide to see if this would make any difference, the issue occurs with or without the changes in this guide. I have changed the jre to a different version and this has made no difference. I have made changes recommended for the workers.pro
Remix with Firefly Community Gallery
Thousands of free creations to fall in love with and remix in Firefly.
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.