• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

Document opens in print mode

Participant ,
May 01, 2012 May 01, 2012

Copy link to clipboard

Copied

I have downloaded a few pdfs from a site I pay to access.  I can't attach an example here.  We are allowed to post them for our staff to read, but the only way I can download is to print them to a pdf.

When I save the file and try to open it, it automatically opens the print dialog box.

The document is not protected and I can change the properties on it.

How can I have this open as a plain old pdf and not with the print dialog box open?

Thank you

TOPICS
Create PDFs

Views

67.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , May 01, 2012 May 01, 2012

There's probably a script embedded in it that is causing it.

The easiest way to confirm that would be to disable JS from the preferences

of Acrobat and then try to open the file.

Votes

Translate

Translate
Community Expert ,
May 01, 2012 May 01, 2012

Copy link to clipboard

Copied

There's probably a script embedded in it that is causing it.

The easiest way to confirm that would be to disable JS from the preferences

of Acrobat and then try to open the file.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 01, 2012 May 01, 2012

Copy link to clipboard

Copied

Wow, that was a fast answer.

OK, so that fixed the problem for me, but is there a way to remove the embedded script so it won't open in print mode for other users?

Thanks again.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 01, 2012 May 01, 2012

Copy link to clipboard

Copied

Yes, you can remove it by going to Tools - Java - Document JavaScripts and

delete it from there. This is assuming that the file has not been protected

against modifying it, of course.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 01, 2012 May 01, 2012

Copy link to clipboard

Copied

Hmm, I'm using Acrobat 9 and I don't see that setting.

I did find Advanced > PDF Optimizer > Discard Objects and selected both Discard all JavaScript actions and Discard embedded print settings.

When I click OK I get Conversion Warnings > An error was encountered while processing images.

If I go to File Properties the Security Method says No Security and everything is set to Allowed.

You've been very helpful, any other suggestions?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 01, 2012 May 01, 2012

Copy link to clipboard

Copied

In that version it will be under Advanced - Document Processing - Document

JavaScripts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 01, 2012 May 01, 2012

Copy link to clipboard

Copied

OK, I found that, but there aren't any JavaScripts listed to delete.

I checked a couple other of these documents and it's the same thing, they open with the Print Dialog box, but there aren't any JavaScripts listed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 01, 2012 May 01, 2012

Copy link to clipboard

Copied

Another option could be that it was embedded into the PageOpen action of

the first page. Open the Pages panel, right-click the first page and select

Page Properties. Go to the Actions tab and check if there's a PageOpen

action defined there. If so, delete it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 01, 2012 May 01, 2012

Copy link to clipboard

Copied

try67 wrote:

Another option could be that it was embedded into the PageOpen action of

the first page. Open the Pages panel, right-click the first page and select

Page Properties. Go to the Actions tab and check if there's a PageOpen

action defined there. If so, delete it.

Nope, no actions.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 01, 2012 May 01, 2012

Copy link to clipboard

Copied

Without seeing the file, I don't have any other ideas for you at the

moment. But yes, "re-frying" the file (printing it to the PDF printer),

should get rid of it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 01, 2012 May 01, 2012

Copy link to clipboard

Copied

While not ideal, a poormans work around is to reprint it to a pdf. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 06, 2023 Jun 06, 2023

Copy link to clipboard

Copied

I could not find preferences etc but rather just printed the problem file as "adobe PDF",  The newly created .pdf file did not replicate the print dialogue box and also had the page slider restored to the right, which seems connected to this problem.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 25, 2023 Oct 25, 2023

Copy link to clipboard

Copied

LATEST

1. click on the pdf file and open it with Google Chrome.
2. print it as pdf and name it differently

3. problem solved! 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines