• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

PDF shows partially blank with Adobe Acrobat on Mobile device and chrome extension

New Here ,
Jan 13, 2023 Jan 13, 2023

Copy link to clipboard

Copied

I have a certain type of system generated PDF which works fine with other application or open it with Acrobat desktop. But it shows partially blank (certain components in PDF page) if users open it from Acrobat on their phone or chrome extension. Could someone help me to slove the issue or identify it by investigate the PDF file?

TOPICS
General troubleshooting , Standards and accessibility

Views

442

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 13, 2023 Jan 13, 2023

Copy link to clipboard

Copied

All mobile PDF viewers lack features compared to what you find in the Adobe desktop applications (that includes Adobe's own mobile version of the Reader). If you can share one of these files here, we can certainly take a look, but  unless you are in full control of that "system generated PDF", and what goes in it, there is very likely nothing you can do to make these work better on mobile devices. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 13, 2023 Jan 13, 2023

Copy link to clipboard

Copied

Thank you so much for a quick reply, the attached file is one sample, it looks fine if open with desktop but only shows header lines if open on mobile or chrome extension. When I said system generated, it's by a javascript and has some css styles in xml file, so I think probably I can fix it if I can identify the issue and nothing related to backend PDF engine.

 

[ Mod: File attachment removed as requested by question author ]

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 16, 2023 Jan 16, 2023

Copy link to clipboard

Copied

I think I find the issue but want to have some PDF expert opinions to avoid similar issues. The PDF is generated by xml to PDF libirary with css styles, and there is a line of css 'text-decoration: underline;' casue the issue on everything below but not itself when the pdf is opened on acrobat mobile or Chrome extension. Do you have any ideas on how it happens?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 17, 2023 Jan 17, 2023

Copy link to clipboard

Copied

Hi @Alex27933355o67q,

 

Hope you are doing well. 

 

Thank you for sharing the file with us. I will share the file with the product team and get back to you with my findings.

 

While I do so, would you mind sharing the below given information to speed up the investigation process:

1. The application version of Acrobat Reader Mobile you are using;

2. The operating system [Android/iOS] you are using on your device;

3. A screenshot of what you see on your device when opened.

 

Look forward to hearing from you.

 

-Souvik.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 17, 2023 Jan 17, 2023

Copy link to clipboard

Copied

LATEST

1. Newest on Andriod

2. Andriod and Chrome extension

3.

Alex27933355o67q_0-1673976867202.png

 

Again, I already identify the reason of issue is because one css line 'text-decoration: underline', but want to know why does that cause the issue. Also could you please delete the file I posted before, it doesn't contain too much sensitive information but still don't want to share in a public forum, thank you.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines