Third party acrobat plugin is not loading in Acrobat DC

New Here ,
Feb 15, 2017 Feb 15, 2017

Copy link to clipboard

Copied

Hello,

I developed a plugin for PDF manipulation functions by adding a new menu item under Edit menu.

It is working fine in Acrobat Pro XI but it is not loading in Acrobat pro DC.

I am using:

1. Acrobat Pro DC(2015-Classic)

2. Operating System - Windows 7

NOTE: According to my observation, first time when I installed Acrobat DC, my plugin was working fine. But when my trial version completed, I reinstalled it now and it is not working now.

For the case, If I did something wrong in the code, to check this, I placed a BasicPlugin from Acrobat Plugin SDK. It is also not working for Acrobat Pro DC.

But both are working fine for Acrobat Pro XI.

Please help!

Thanks.

TOPICS
Acrobat SDK and JavaScript

Views

13.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2017 Feb 15, 2017

Copy link to clipboard

Copied

For your more information, when I try to delete those plugin from the path C:\Program Files (x86)\Adobe\Acrobat 2015\Acrobat\plug_ins keeping Acrobat open, then It says "The action can't be completed because the file is open in Adobe Acrobat DC"

This logically means that plugin is loaded somewhere.

BasicPlugin from Acrobat SDK also adds one menu to acrobat in Acrobat Pro XI. Both plugin does not show Anything in Acrobat Pro DC.

I don't understand what went wrong. Please help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 15, 2017 Feb 15, 2017

Copy link to clipboard

Copied

First thing to check: what are your preference settings for "verified plugins only" and "protected mode"?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2017 Feb 15, 2017

Copy link to clipboard

Copied

Where can I check that?

I checked in Edit > Preferences > General, I don't see any such option there. Where can I get those options?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 15, 2017 Feb 15, 2017

Copy link to clipboard

Copied

"Use only certified plug-ins" is at the bottom of the "General" category, protected view is in the "Security (enhanced)" category.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2017 Feb 15, 2017

Copy link to clipboard

Copied

Option "Use only certified plug-ins" was unchecked in the preferences.

"protected mode" mode is not there in  "Security (enhanced)" . Its "Enable enhanced security" in there.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2017 Feb 15, 2017

Copy link to clipboard

Copied

This is what my configuration looks like in Edit > Preferences > Security(Enhanced) tab.

I  unchecked the "Enable Enhanced Security" checkbox and tried but still did not work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 15, 2017 Feb 15, 2017

Copy link to clipboard

Copied

Then you need to run Acrobat in the debugger and set breakpoints on the handshake methods to see where the loading of the plug-in fails.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 15, 2017 Feb 15, 2017

Copy link to clipboard

Copied

Ok at this point I suggest testing the Acrobst installation. Get a commercial third party plugin (or free or demo) and see if it loads. If it loads you have a specific issue with your builds. At that point I would be using depends.exe.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2017 Feb 15, 2017

Copy link to clipboard

Copied

As I said, I tried your BasicPlugin in the Acrobat plugin SDK itself.

It is working fine with XI but not with Acrobat Pro DC.

And If it is working fine with Acrobat XI, How can it be the code issue?.

And as per your product description plugin compatibility issue is only with Mac and not with Windows.

Acrobat DC removes Acrobat XI and plug-ins compatibility issue

Above link says:

"Note: This issue is specific to Mac OS only, and does not occur on Windows. On Windows, the existing third-party plug-ins can continue to be installed to the Adobe\Acrobat DC\Acrobat\plug_ins subfolder of the installation location for the subscription license and Adobe\Acrobat 2015\Acrobat\plug_ins for the Classic (Perpetual) license."

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2017 Feb 15, 2017

Copy link to clipboard

Copied

Most interesting part is :

When I add my third party plugin in Acrobat Pro XI C:\Program Files (x86)\Adobe\Acrobat 11.0\Acrobat\plug_ins folder,

I see this:

"Currently in Certified Mode: No"

And, When I add my third party plugin in Acrobat Pro DC's, C:\Program Files (x86)\Adobe\Acrobat 2015\Acrobat\plug_ins folder,I see this:

"Currently in Certified Mode: Yes"

What went wrong?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 15, 2017 Feb 15, 2017

Copy link to clipboard

Copied

Are you sure you are doing this in Acrobat, and not the free Adobe Reader? What you show in your second screenshot looks what Reader would display. If it's not Reader, then I would assume that something in your installation is corrupt, and I would uninstall, then run the Acrobat Cleaner (Download Adobe Reader and Acrobat Cleaner Tool - Adobe Labs ) and then re-install again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 15, 2017 Feb 15, 2017

Copy link to clipboard

Copied

Did you tried a third-party plugin like "Quite Imposing Plus" or "Enfocus Browser"?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

Hello,

I just installed Acrobat Pro DC on my another machine. And tried to load the plugin. It is loading now. I can see the menu-item that was created in PluginInit() method.

However, after clicking on the menu item, Acrobat gets crashes.

When I try to debug the plugin,it gives me this error:

When I press Yes and continued to debug, every time debugging behavior is different.

I set the breakpoints in handshake method along with my required modules.

**Sometime it says without hitting

**Sometime It says "Acrobat has triggered the Breakpoint" and do nothing.

It does not hit any breakpoints.

Please help!

Thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 20, 2017 Feb 20, 2017

Copy link to clipboard

Copied

See the troubleshooting tips on this page about debugging Acrobat plug-ins on Windows: Acrobat DC SDK Documentation

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 15, 2017 Feb 15, 2017

Copy link to clipboard

Copied

Your "currently in certified mode" is what I'd expect. It says YES if no plug-ins loaded. I've made my recommendations for the next steps in troubleshooting. By a third party plug-in I meant a fully compiled one, because the chances are the problem is in building or deployment rather than code; building another plug-in from code seems to confirm that.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

Hi, Finally were you able to install/import the plugin. I am getting the same issue not sure what is the reason? 

Does it required license as well? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

LATEST

If you have the same issue in 2022, check also whether Acrobat is 64 bit or 32 bit, and whether the plugin build matches. This was not an issue in 2017. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines