Adobe Fonts will not load AT ALL. Please help!

New Here ,
Jan 15, 2021 Jan 15, 2021

Copy link to clipboard


Please help, this is driving me crazy.

For over a month now, NONE of my fonts will load. I am SO over this. It is a newly built computer (November 2020) with no old versions of any Adobe Apps on it.

I have tried calling, tried the popup chat window and nobody will help. I just sit on hold for hours wasting more and more time.

Everything is activated in Adobe Fonts.  All of the preferences are activated on Creative Cloud Desktop.  But NONE of my 277 activated fonts will show in any app anywhere.  I can't get any work done at all. I am just wasting hours and hours of time uninstalling, reinstalling, updating, activating, deactivating, sitting on hold waiting and waiting for the chat to respond.  NOTHING works. It's ridiculous.








Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation