• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Dynamic Link Server connection – or lack of it...

Participant ,
Mar 28, 2021 Mar 28, 2021

Copy link to clipboard


I'm so f*ing tired...


In short, I can't render stuff from AE by choosing 'Add to Media Encoder queue'. I can add to the queue all right, but as soon as I either click the green Play button or click on the preset to edit settings, it's stuck on 'Establishing Dynamic Link Server connection' (or whatever it says), and after a couple minutes of this, it plays a goat-like error sound, and that's that.


I have tried EVERYTHING. Every tip or idea or workaround from the forums here or places like Reddit, and NOTHING fixed the issue so far. I'm on the newest version of all CC apps, macOS 10.15.7, I have granted Full Disk Access to Media Encoder, AE, Premiere, AE Rendering Engine and anything else that somehow made sense. Firewall or antivirus are not an issue either. Tried re-installing,  resetting preferences...


And the worst thing is, this issue goes back at last a year (if not more), so it's neither new nor tied to any recent updates (none of them fixed it, though). I can hardly find the energy to write this post as it's probably futile and a waste of time, but on the off-chance that someone finally decides to fix the damn Dynamic Link Connection... please help. Please.

Dynamic link






Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation