Painfully slow render times

Explorer ,
Jul 10, 2018 Jul 10, 2018

Copy link to clipboard

Copied

I can only assume this is due to settings that I am missing, but since AE dropped the ability to render to h264 (what I've always used) I've had to make the jump to Media Encoder. That's ok, I know ME is a way more robust tool for rendering, at least that is what I have been led to believe.

This may all be moot... I am using Ray-traced 3d, maybe that just takes 10x longer as a rule. I have not done a side by side comparison.. well I cant since AE no longer supports h264.

Anyway to my question. Can anybody provide some feedback as to the best settings to use when rendering motion graphics in the most versatile format (assumed to be h264)?

I see that in AE the Bitrate Settings are in kbps. I'd normally set my number to 10,000 for a very clean and manageable output.

In ME the default Bitrate is in mbps and there is a min and a max it's mine is now set to 5 and 10 respectively and my render time looks to be about 2 hours... better than the 7 hours it wanted with "match source"

Any feedback is great, If you can help me optimize ME I'd be eternally grateful.

Frank

ps. I'm not 100% attached to h264, I'm all ears if somebody has a better solution. It's what I knew so it's what I used. Real bummer that AE dropped it.

Views

798

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jul 13, 2018 Jul 13, 2018
Rendring to any format that compresses between frames has never been something that After Effects handles well.You could try rendering to Best Settings/Lossless from AE to a Watch Folder for Media Encoder that's set to encode to H264.  That's two steps, but in your first pass you're rendering frames that don't rely on other frames.  Then, in your second pass the other frames already exists when you are rendering frames that rely on other frames.  As far as speeding up H264 goes, have you read up...

Likes

Translate

Translate
Adobe Community Professional ,
Jul 13, 2018 Jul 13, 2018

Copy link to clipboard

Copied

Rendring to any format that compresses between frames has never been something that After Effects handles well.

You could try rendering to Best Settings/Lossless from AE to a Watch Folder for Media Encoder that's set to encode to H264.  That's two steps, but in your first pass you're rendering frames that don't rely on other frames.  Then, in your second pass the other frames already exists when you are rendering frames that rely on other frames. 

As far as speeding up H264 goes, have you read up on CPU Hardware Acceleration that's available via QuickSync?  With the right OS version and hardware, the latest release of Media Encoder enjoys some good speed improvements for encoding HEVC and H264.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 26, 2018 Jul 26, 2018

Copy link to clipboard

Copied

Frank,

The ray-traced 3D renderer is obsolete. You might try using the C4D renderer moving forward. I agree with Warren's idea to create a master file using ProRes or Cineform. You can do this in the Render Queue, then create your H.264 from that file in Media Encoder.

Thanks,

Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 24, 2018 Dec 24, 2018

Copy link to clipboard

Copied

LATEST

I’ve spent a week trying to resolve this issue and many more problems, such as problems with importing music (very long conforming times).  At the end of a long save process (2 hrs to save a 30 min video) the result was that that without music  the vid was fine, but adding music tracks caused huge sound clicks and hisses.

I cursed the day I upgraded to PE 2019!

After a week with no success I decided to run a PC health check (perrfmon /report).  This revealed that there were early problems with the my hard drive. Moving files to an external drive solved the issue (that and changing the audio input to no input) resolved all issues.  My PC has show’s few other problems Other than the stress of processing a PE video.

What Christmas joy at finding the answer!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines