After Effects: Why does my background revert to black when I export?

Community Beginner ,
Dec 24, 2013 Dec 24, 2013

Copy link to clipboard

Copied

For a recent project, I chose a deep red background, but when I exported it, it was black!

Thanks for any help.

TOPICS
How to

Views

85.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Dec 24, 2013 Dec 24, 2013
If you want a background of a specific color, create a solid-color layer of that color and make it your bottom-most layer.

Likes

Translate

Translate
Dec 24, 2013 Dec 24, 2013

Copy link to clipboard

Copied

If you want a background of a specific color, create a solid-color layer of that color and make it your bottom-most layer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 07, 2014 Jan 07, 2014

Copy link to clipboard

Copied

That answers a question I also had regarding the background that is white in the AE file becoming black in ME.

It also begs the question, why is it set up this way?
Why doesn't ME simply honour the background colour of my composition without needing this extra step?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 07, 2014 Jan 07, 2014

Copy link to clipboard

Copied

The composition colour is just what you use to work with, it has no reality to it. It enables you to do things like turn transparency on and off, which you can't do with an actual background.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 07, 2014 Jan 07, 2014

Copy link to clipboard

Copied

Except that if you render directly out of AE, it does use the background colour of the comp.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Jan 07, 2014 Jan 07, 2014

Copy link to clipboard

Copied

If you want this to be handled differently by AME, submit a feature request for Adobe Media Encoder:

http://adobe.ly/feature_request

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 07, 2014 Jan 07, 2014

Copy link to clipboard

Copied

yancowles wrote:

Except that if you render directly out of AE, it does use the background colour of the comp.

The difference is that AME renders After Effects comps via the Dynamic Link protocol, which always assumes that an alpha channel is present (background is transparent) when it renders the After Effects comp. (This does not necessarily reflect whether or not the exported file has an alpha channel. You choose that in the export settings.)

As Todd says:

1) Best practice in After Effects is to use a colored solid layer if you want a colored background; it provides more control when compositing layers.

2) Please file a feature request if you'd like to see AME behave differently.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 13, 2018 Sep 13, 2018

Copy link to clipboard

Copied

I used a white background, AME made it black.

I used a green for video effects, AME made it black.

I finally put a white rectangle behind my cartoon/animation — okay, it showed the white BUT the attempt to make a simple logo with motion was destroyed.

I do NOT want a rectangle shape, a random shape is needed.

How the 7734 can I get this to work!!

Oh & in AE, PS, PP "NO BACKGROUND" should be a video option.

(I know that no background is force-ably available in PS, have gone through the backdoor to do that for years.

It should be an initial option NOT an open, new layer, delete base layer, annoying system.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 24, 2018 Mar 24, 2018

Copy link to clipboard

Copied

Didnt help. Still black.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 04, 2016 Aug 04, 2016

Copy link to clipboard

Copied

Just had the same problem. I created a white background comp and it exported black.

All you need to do is, go down to the lower left panel where your comp is, right click, create a new solid, make this white (or the colour you want) and hit ok. Make sure this is on the bottom of your layers and you are right to go.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 12, 2017 Oct 12, 2017

Copy link to clipboard

Copied

Hi everyone,

I'm also running into this problem. I have an AE project and I'm rendering it in AME. When it plays back, shows a black background for some parts. I went back to my AE project, added a white rectangle where needed, and it still rendered black. I went back a third time and added a solid layer filled with white, which is at the very bottom of all my layers, and it's still black.

Any thoughts/help? I'm somewhat new to AE/AME and could use your advice!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 25, 2019 Oct 25, 2019

Copy link to clipboard

Copied

This worked for me too.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 05, 2018 May 05, 2018

Copy link to clipboard

Copied

I know this is a really old post, but what worked for me was putting the file in the AE queue first, and selecting the H.264 codec. Then when you go to render out in AME, it will render with the color you see in your original file, even if you haven't added a colored layer for the background. I have no clue as to why.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 29, 2018 Aug 29, 2018

Copy link to clipboard

Copied

It's ridiculous. I'm sick of having to work with a solid at the bottom of every comp. You can't just select all of the layers in your comp and perform operations on them, you always have to select all, then scroll down, and deselect this extra layer. Either they should commit to the stupidity and remove the background color selection in AE, or have AME honor AE's background color, or allow AE to render with AME presets.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 18, 2020 Jan 18, 2020

Copy link to clipboard

Copied

Even worse, I kept using a white solid in the bottom layer, and for some reason it wouldn't show up with full opacity. I selected FFFFFF in the menubar, where there is no alpha selector, made sure the layer itself was 100% opaque, and still my export would go to AME and render grey instead of white. 

Finally had to (and I'm almost getting an aneurysm just typing this) create a white PNG file and import it into the bottom layer. 😡 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2019 Nov 18, 2019

Copy link to clipboard

Copied

I ran into the same problem, and this is what I found - 

If exported via the 'Add to Render Que' command (which usually outputs in .AVI format in the 2019 or later versions), the output will show the preset background color.

If exported via Media Encoder (i.e., using 'Add to Adobe Media Encoder Que'),  which gives us more render setting options, the output will not include the background color. In this case, we will unfortunately need to create a separate solid color as the bottom layer in order to show the color. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 06, 2020 Apr 06, 2020

Copy link to clipboard

Copied

Make sure you increase the opacity to 100.... I was going crazy with a white background then I added a white layer with no change... then I changed my background color to expose the fact that the new shape layer was set to 0% opacity. I guess that's the default... changed that to 100% and it worked fine. still curious as to why it doesn't just honor what you have set in Ae... just make transparent an OPTION for those who want it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 06, 2020 Sep 06, 2020

Copy link to clipboard

Copied

thanksss omg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 25, 2021 Mar 25, 2021

Copy link to clipboard

Copied

LATEST

Almost 10 years later and it seems like nothing has changed ... Situations like this really makes me wonder how this program is industry standard. And this is just one of the 10+ problems I ran into for 1 simple project. Such terrible UX and so many backwards unexplained little surprises for me to discover. Wonderful

 

Also, why am I unable to post this reply? When trying to post I get this ridiculous message about spam??? Haven't said a word on here in ages and you want me to wait 10h before I can post something? What?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines