• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Components move when updating

Community Beginner ,
Aug 23, 2023 Aug 23, 2023

Copy link to clipboard

Copied

I created a library in a separate file. I have integrated this into my project and use its components. My problem is mainly about my buttons, so they have a padding, if that's important. Every time I change the original buttons, for example just a color adjustment, they move to left or right when I updating them in the project.This is very annoying for larger projects because I can't prevent it.

 

This happend in all my project and since i used Adobe XD (over one year).

 

Does anyone have this too, what can I do about it?

 

OS: Windows 10
XD Version: 57.1.12.2

 

Views

304

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Sep 11, 2023 Sep 11, 2023

I found a solution myself.

The padding setting can not be on the Button component itself. I created a new folder in it and gave it a padding. This folder contains the text and the background of the button.

Votes

Translate

Translate
Community Expert ,
Aug 23, 2023 Aug 23, 2023

Copy link to clipboard

Copied

Hello @Nori712, it would be great if you could share a screencast video from a sample file demonstrating the problem (would be even better sharing also a sample file) that doesn't have any confidential info. I can only think of text based issues (since with some fonts some similar issues can happen, I know you said that happens with a color adjustment etc also but still) That's all I can think of right now. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 24, 2023 Aug 24, 2023

Copy link to clipboard

Copied

Hello @AkinGn, thank you for your messeage. I made a gif to show you the problem. Maybe this is enough?
I used the component in this file and changed the button text. In my library I only changed the color of the original component. The font is the same. If I update it afterwards, the component jumps to the side.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 24, 2023 Aug 24, 2023

Copy link to clipboard

Copied

It happen with other buttons too. After updating the size from the green border changed. Maybe this is a reason, but why?

Screenshot 2023-08-24 102036.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 24, 2023 Aug 24, 2023

Copy link to clipboard

Copied

Hi @Nori712, I tested publishing a library with a single rounded button, and included that button in another document and changed the color of the button in the library, and updated the button in the document I included the button but nothing changed. Let's see maybe another designer/expert might have some suggestion.

If you like, you can send me a document with that button and I can do that test (publishing and including in another file) on my side, maybe there's an issue with that particular button, so we can test that.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 24, 2023 Aug 24, 2023

Copy link to clipboard

Copied

Ok, here is a file with only my Button Component. I can't uploade it here, its on my drive. Thank you!!

https://drive.google.com/file/d/18FHixYPm-K2pOIlSNginNCHWUw-ychmz/view?usp=sharing

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 24, 2023 Aug 24, 2023

Copy link to clipboard

Copied

Thank you for sharing, I changed its color multiple times, after publishing it as a library and updating the component in the test file I included the library but nothing changed (tried even using border, stroke etc) I'm not sure what is wrong, let's see maybe someone had a similar issue might be helpful. Of course I'll also update you if I find out anything.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 11, 2023 Sep 11, 2023

Copy link to clipboard

Copied

I found a solution myself.

The padding setting can not be on the Button component itself. I created a new folder in it and gave it a padding. This folder contains the text and the background of the button.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 11, 2023 Sep 11, 2023

Copy link to clipboard

Copied

LATEST

Wow sounds interesting, thank you for sharing the solution @Nori712, I'm sure it'll be helpful for some other people!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines