How to Resolve "Element is Missing" Error?

New Here ,
Oct 01, 2021 Oct 01, 2021

Copy link to clipboard

Copied

We have a master document that is the source file for our published library of components - recently we noticed that a large number of components are listed with the "Element is missing" error and the red chain icon. What's the best way to resolve these?

 

I'm not sure how XD got confused about the source library for these components (they all refer to another library that doesn't contain these components) - I tried using the "Make Local" option but when re-opening the document the error returns. What's odd is that when I use the "Reveal Components in Assets" option in the canvas, these components do get highlighted, and when I "Edit Main Component" it selects the same component in the asset list. So it appears to still be the master even though the error contradicts this.

Views

231

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Oct 04, 2021 Oct 04, 2021
Hi Rishabh, That solution didn't work for me as I wasn't pasting any components into the master file. That said, I eventually was able to resolve by systematically going through every component that was unlinked and selecting "make local". Once all masters components were resolved I was able to close/reopen the file without broken links.

Likes

Translate

Translate
Adobe Employee ,
Oct 04, 2021 Oct 04, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear about the trouble. Please try the suggestions shared here https://community.adobe.com/t5/adobe-xd-discussions/library-element-missing/m-p/11840944#M45603 and let us know if this helps or if you need any further assistance.

 

Regards

Rishabh

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 04, 2021 Oct 04, 2021

Copy link to clipboard

Copied

LATEST

Hi Rishabh,

 

That solution didn't work for me as I wasn't pasting any components into the master file.

 

That said, I eventually was able to resolve by systematically going through every component that was unlinked and selecting "make local". Once all masters components were resolved I was able to close/reopen the file without broken links.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines