• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

No padding function in Adobe XD 30

New Here ,
Jun 23, 2020 Jun 23, 2020

Copy link to clipboard

Copied

Dear all,

 

I've got a problem with Adobe XD right now. I found a tutorial for the padding function but there's no button for padding in my XD. (you can see it at the screenshot.) I searched in the manual and looked for tabs, but I cannot find the function. Can you help me with this?

 

Thanks for your help and have a nice day!

 

Regards,

 

Sascha

Views

2.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jun 23, 2020 Jun 23, 2020

Hi Sascha,

 

Thank you for reaching out and using Adobe XD. Would you mind making your object as an component or group and then check if you're able to see the padding option in the property inspector pane?

Please check out this article for more info: https://helpx.adobe.com/in/xd/help/set-fixed-padding-for-components-groups.html

 

Thanks,

Harshika

Likes

Translate

Translate
Adobe Employee ,
Jun 23, 2020 Jun 23, 2020

Copy link to clipboard

Copied

Hi Sascha,

 

Thank you for reaching out and using Adobe XD. Would you mind making your object as an component or group and then check if you're able to see the padding option in the property inspector pane?

Please check out this article for more info: https://helpx.adobe.com/in/xd/help/set-fixed-padding-for-components-groups.html

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 11, 2020 Aug 11, 2020

Copy link to clipboard

Copied

I have the exact same issue, NOT able to see the padding option on the inspector. I grouped and made a component as well, still nothing...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 11, 2020 Aug 11, 2020

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear about the trouble, we'll try our best to help you with it. Usually when we group the objects or if it is a component we do get the option for padding as suggested above. Could you please share a few screenshots of the design of how it looks so that we can have a better idea.

 

Regards

Rishabh

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

I also have this same problem. I tried with Croup and Component

screenshot_1630487012.pngscreenshot_1630487055.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 28, 2021 Sep 28, 2021

Copy link to clipboard

Copied

You have selected a component instance (diamond with a border icon). You can only add padding to the Main component (full diamond without a border icon). Instances inherit the function, and can have a different padding, but you must first set it on the main component.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 28, 2021 Sep 28, 2021

Copy link to clipboard

Copied

Also having the same problem with Adobe XD 44 - can't see the padding option in the inspector. Object is grouped and a component and not seeing any option for padding, only Responsive Resize.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 28, 2021 Sep 28, 2021

Copy link to clipboard

Copied

You can set padding to a Group, and to a Main Component (not to a component instance, unless the main component has a padding set). If you want help with a particular case, post screenshots and we'll see what's happening. Make sure to include the layers panel in your screenshot.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

I have the same issue. I have XD v44.1.12.5 xd4 CCSync 4.21.1.1

defaultf2zmc5s33jbr_0-1634298503931.png

 

I've selected the component - NO PADDING!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

The option is there, just enable it.

SpasK_0-1634323043648.png

 

Other users' issue was that there was no option at all.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2021 Oct 18, 2021

Copy link to clipboard

Copied

Sorry, yes, I see it now.

 

I believe you've moved it. It was previously (in the demo video) just below the Layout header, so I was looking for it there - perhaps you can update (and version label) your videos or at least add a What's changed note , so it's easier to see what's what. Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 14, 2020 Dec 14, 2020

Copy link to clipboard

Copied

I have the same issue too.

I tested it with group and component but I couldn't found padding option.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 30, 2021 Sep 30, 2021

Copy link to clipboard

Copied

I have the same problem as well. I the properties section it only appears the responsive resize option, but the padding one doesn't.

I hope it can be fixed because it's a really useful tool.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 01, 2021 Oct 01, 2021

Copy link to clipboard

Copied

Can you post a screenshot with the problematic elements selected, and both layers and property inspector panels visible?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 10, 2022 Oct 10, 2022

Copy link to clipboard

Copied

I have the same problem. I have read all the solutions and have watched a video. 
I have tried grouping. No padding
This is a main component. No padding
The background is the lowest level
XD ver: 54.1.12.1

 

Please can I get help. This is a very large enterprise app and I must get my base workflow to be efficient

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 11, 2022 Oct 11, 2022

Copy link to clipboard

Copied

LATEST

I found the solution to my problem. I added a new state in order to get a default state. Padding is only available when default state is selected. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines