Scroll to top button glitching

New Here ,
Sep 23, 2021 Sep 23, 2021

Copy link to clipboard

Copied

I'm really hoping someone can help me as this is driving me mad.

I'm currently doing a protoype in xd for learning modules. I have added a scroll to top on the first module and i can scroll down and click on the button, it jumps to the top and everything works perfectly.

 

I have another module which I assumed I did exactly the same way but, when I click on the 'back to top' button, it jumps to the top as it should.... However, once I then try to scroll down with my mouse after it has jumped to the top, my scroll triggers the page to jump to the bottom again rather than scrolling down as it should.

 

It's really frustrating, I can't seem to find anyone with a similar issue.

I would really appreciate the help.

 

Thanks

Views

273

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 23, 2021 Sep 23, 2021

Copy link to clipboard

Copied

Hey, could you upload a video showing the issue? If you can upload the file or the problematic page somewhere and share it here or via PM, that would be nice as well, so we can check it out and see what might be going wrong.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 23, 2021 Sep 23, 2021

Copy link to clipboard

Copied

Thanks for replying, I'll do a quick video

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 23, 2021 Sep 23, 2021

Copy link to clipboard

Copied

Hi

 

Here's a video. I went through it twice so you can see how it jumps. 

I have also attached a screen grab of the project for additional info. I hope this helps.

 

I'm only having this issue with the one module, the other one works fine.

 

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 23, 2021 Sep 23, 2021

Copy link to clipboard

Copied

What's the difference between the modules for this specific interraction? Does the scroll point to "Masthead" in both?

 

Can you try the following 2 things:

- Put the "Back to top" element in a group, and add the scroll to action to the group instead.

- Create some small element at the top of the page, below everything else, you can set its opacity to 0, and point the scroll to it instead. I tried your setup and couldn't break it, but maybe the fact that "Masthead" stretches over the whole artboard is breaking it for some reason.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 24, 2021 Sep 24, 2021

Copy link to clipboard

Copied

LATEST

Hey, thanks for the help.

 

I'll play around with the suggestions and see if anything works.

The other element is exactly the same, same masthead different content and colours.

 

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines