• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Spellcheck in XD not wanted

New Here ,
Oct 04, 2018 Oct 04, 2018

Copy link to clipboard

Copied

I would like to turn off the new spellcheck/autocorrect feature in XD but don't see an easy way to do so. We use an icon font set for adding icons to our designs and since I have updated to the latest version, XD is autocorrecting my entries - for example, one of the icons has a character mapping of "n" but XD corrects it to "N" because it thinks I am starting a sentence and wants to capitalize it. This also assumes that I always want to start typing with a capital letter no matter what the situation. There is one other issue that I find annoying, and that is that XD adds a period (.) if I add more than two spaces between words. This has been happening for a while, not just in the new version. Even Word or other word processing programs don't assume that I have just ended a sentence. This is totally unnecessary and adds no value, because I then have to manually go back and remove the period from the line of text, and then it keeps happening and I don't have a way to stop it the next time. If anyone knows how to configure XD to stop these annoying "features" please let me know.

thanks.

Views

3.8K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Oct 04, 2018 Oct 04, 2018

On Mac just uncheck Spelling and Grammar from the edit menu.

On Windows there should be a similar menu item in the top level menu of the app.

Votes

Translate

Translate
Adobe Employee ,
Oct 04, 2018 Oct 04, 2018

Copy link to clipboard

Copied

On Mac just uncheck Spelling and Grammar from the edit menu.

On Windows there should be a similar menu item in the top level menu of the app.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 04, 2018 Oct 04, 2018

Copy link to clipboard

Copied

Menus on the top level of an app in Windows doesn't apply to UWP apps like XD. There is a turn off spellcheck option in the 'hamburger' menu:

Screen Shot 2018-10-04 at 2.07.09 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 06, 2019 Aug 06, 2019

Copy link to clipboard

Copied

This solution didn't seem to help with the insertion of a period (.) when you add more than one space. Any ideas on how to turn that off?

Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 28, 2023 Apr 28, 2023

Copy link to clipboard

Copied

Just noting that you need to restart XD for it to take effect

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 04, 2018 Oct 04, 2018

Copy link to clipboard

Copied

If this does not answer your question, or you want spellchecking just without the auto-correct, you can go to system settings -> keyboard -> Text and uncheck auto-correct & first letter capitalization (Mac) or Settings -> Search spelling -> uncheck Auto-correct (Windows)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 25, 2023 May 25, 2023

Copy link to clipboard

Copied

LATEST

This actually helped me, thanks for pointing that out! I didn't know it was a dreadful Windows feature.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines