Web Share Prototype Slow and very laggy

New Here ,
Apr 20, 2020 Apr 20, 2020

Copy link to clipboard

Copied

Hi there,

Has anyone experienced issues when sharing a web preview of their prototypes?

Even on the most basic of sites, my scrolling is laggy and elements are often slow to respond.
I have decent internet speeds, and everything is up-to-date install-wise.

Please help as I need to deliver the links to clients and can't have them viewing the designs so poorly.

Thanks in advance.

TOPICS
Product performance , Share or publish

Views

1.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 20, 2020 Apr 20, 2020

Copy link to clipboard

Copied

Hi,

Sorry to hear that, Please help in knowing few question:-

1. Can you please share the size of file. 

2. Can you share on which browser you are facing this issue.

3. Can you please share screenshot or video.

 

Thanks, 

Vertika Gupta 

Adobe XD

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 28, 2020 Apr 28, 2020

Copy link to clipboard

Copied

Hi Vertika,
[UPDATE]
I just tried the file in Safari and it works perfectly. So I would suggest the issue is due to Chrome on Mac 😞

1. The file size was 130Mb, however, have seen the same issues with files much smaller.

2. Mac Chrome

3. Unfortunately, I can't share a screenshot/video because it's confidential for client purposes at the moment.

However, I can maintain that I'm having the same issue whether the link is a simple file with barely anything on it or a complex one with lots of layers.

 

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 28, 2020 Apr 28, 2020

Copy link to clipboard

Copied

Hi Sam,

 

Thanks for confirming that it's working on Safari. In order to troubleshoot issues with Google Chrome, I'd recommend resetting the browser once and then check again.

 

Let us know if need any further assistance.

 

Regards

Rishabh

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 06, 2020 Oct 06, 2020

Copy link to clipboard

Copied

Hi Rishabh,

I an confirm this is happening for me too; works perfect in firefox and edge, very slow and choppy animations in chrome.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 27, 2021 Aug 27, 2021

Copy link to clipboard

Copied

Happens to me as well. Only in Chrome. This should be fixed by the developers. Has been this way for years!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 27, 2021 Aug 27, 2021

Copy link to clipboard

Copied

Hi Dylan,

 

Sorry to hear about the trouble. Could you please share a few more details like:

 

  1. The version of XD and OS.
  2. Is this happening on a specific file or multiple files?
  3. Will it be possible for you to share a sample link with which this is happening for testing? If yes, you can either share the link here or through DM.

 

We're here to help, just need more details.

 

Regards

Rishabh

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 30, 2021 Aug 30, 2021

Copy link to clipboard

Copied

1) Latest version XD 43.0.12, Windows 10

2) Multiple, but only laggy when it's not set at a predefined scale percentage (which most of the times will be a random percentage based on someone's screen size)

3) Will share through DM

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

Hey,

 

I also have this kind of problem and tried it in different browsers and on different Terminals.

I used the Design-Review for the export.

So first I looked at it over a Macbook in Safari. It was laggy and the animation triggered pretty late.

Then I switched on a Mac and tried first Firefox. There were still some laggs but way better, so I tried it again in Safari and got the same issues as on the MacBook.

The last test was on my Mobile phone. A Samsung Galaxy S20 Ultra. Still in Firefox for the consistency of testing. The scrolling was absolutely fine, but the triggering of buttons and the connected animation got a big delay.

 

What are some solutions? Could it be the size of my document? Could I use other export methods to avoid such issues?

 

Thanks in advance

Sammy

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 03, 2022 Feb 03, 2022

Copy link to clipboard

Copied

We have the same problem at our agency, and it happens on most if not all of our published prototypes, in Chrome.

I can share multiple (50+) examples where laggy scrolling occurs, and it seems to be with complex designs rich with images.

 

I find it impossible that Adobe haven't experienced the scroll lag problems for themselves though?

 

I first posted this problem back in 2020 here.

 

Chris.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2022 Mar 29, 2022

Copy link to clipboard

Copied

LATEST

I had this same problem.  I seemed to find something that helped quite a bit.  I had a repeating background image on all my pages using the repeat grid function. I removed this background image on each page and it immediately felt snappier when I published the new version. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines