Highlighted

Components - Master Component does not have rounded corner options

New Here ,
Jul 10, 2020

Copy link to clipboard

Copied

I have a component (a button) used throughout my site designs. When I go to edit the master component to change the rounded corners, I double click into the component onto the rectangle and no option for rounded corners is available?

Adobe Community Professional
Correct answer by Spas K. | Adobe Community Professional

You might have accidentally converted the rectangle to a path. If the icon on the rectangle layer is the pen tool icon, instead of the rectangle, it's a path. You lose the option to set rounded corners, when the layer is a path.

 

Converting to a path happens if you double click a rectangle and change some property (color, size, or anything else).

Simply make a new rectangle in the component, and be careful with clicking. I advise you to use Ctrl/Cmd-Click to select things, because this way you can't convert to path by accident.

 

If you notice that you are in path mode (you will see 4 small circles in the rectangle corners, where the points are), press Escape or undo, to revert it to a rectangle. If you have closed the document or edited too far ahead after this, you can't really go back to a rectagle and you will have to make a new one.

 

dstoic_0-1594390320763.png

 

TOPICS
Design

Views

50

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Components - Master Component does not have rounded corner options

New Here ,
Jul 10, 2020

Copy link to clipboard

Copied

I have a component (a button) used throughout my site designs. When I go to edit the master component to change the rounded corners, I double click into the component onto the rectangle and no option for rounded corners is available?

Adobe Community Professional
Correct answer by Spas K. | Adobe Community Professional

You might have accidentally converted the rectangle to a path. If the icon on the rectangle layer is the pen tool icon, instead of the rectangle, it's a path. You lose the option to set rounded corners, when the layer is a path.

 

Converting to a path happens if you double click a rectangle and change some property (color, size, or anything else).

Simply make a new rectangle in the component, and be careful with clicking. I advise you to use Ctrl/Cmd-Click to select things, because this way you can't convert to path by accident.

 

If you notice that you are in path mode (you will see 4 small circles in the rectangle corners, where the points are), press Escape or undo, to revert it to a rectangle. If you have closed the document or edited too far ahead after this, you can't really go back to a rectagle and you will have to make a new one.

 

dstoic_0-1594390320763.png

 

TOPICS
Design

Views

51

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 10, 2020 0
Adobe Community Professional ,
Jul 10, 2020

Copy link to clipboard

Copied

it works for me. Double clicking master component on canvas shows round corner icons. Please check once again if you are cliking on master component? Aslo try to open new component with one instance and check with it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 10, 2020 1
Adobe Community Professional ,
Jul 10, 2020

Copy link to clipboard

Copied

You might have accidentally converted the rectangle to a path. If the icon on the rectangle layer is the pen tool icon, instead of the rectangle, it's a path. You lose the option to set rounded corners, when the layer is a path.

 

Converting to a path happens if you double click a rectangle and change some property (color, size, or anything else).

Simply make a new rectangle in the component, and be careful with clicking. I advise you to use Ctrl/Cmd-Click to select things, because this way you can't convert to path by accident.

 

If you notice that you are in path mode (you will see 4 small circles in the rectangle corners, where the points are), press Escape or undo, to revert it to a rectangle. If you have closed the document or edited too far ahead after this, you can't really go back to a rectagle and you will have to make a new one.

 

dstoic_0-1594390320763.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 10, 2020 1
New Here ,
Sep 25, 2020

Copy link to clipboard

Copied

Thank you, dear Spas K. you're right, it changed to a path  I re-made the rectangle in my master component group and it worked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 25, 2020 0