Highlighted

How do I add fonts to Adobe XD?

Community Beginner ,
Jun 30, 2019

Copy link to clipboard

Copied

Fonts installed on my PC aren't showing up in Adobe XD, how do I add them?

Edit: I should clarify when I say installed I mean activated via a font manager (FontBase, NexusFont, etc.) They show up in Photoshop, Illustrator, etc.

I was having a VERY hard time with Adobe XD finding the fonts I activated with FontBase, BUT I have found the unusual solution to fix that problem by simply —

 

  • Go to Settings (it should be a vertical ellipsis "…") in FontBase
  • Change the Root folder location to "C:/FontBase" (or C:\FontBase — not sure if it's front or backslash)

 

Very strange that Adobe XD didn't find my fonts to the default location FontBase put it (originally located in "C:\Users\%PROFILE%\FontBase"), so changing that location solved my issue.

 

Hopefully, this helps a lot of you out there!

Views

31.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How do I add fonts to Adobe XD?

Community Beginner ,
Jun 30, 2019

Copy link to clipboard

Copied

Fonts installed on my PC aren't showing up in Adobe XD, how do I add them?

Edit: I should clarify when I say installed I mean activated via a font manager (FontBase, NexusFont, etc.) They show up in Photoshop, Illustrator, etc.

I was having a VERY hard time with Adobe XD finding the fonts I activated with FontBase, BUT I have found the unusual solution to fix that problem by simply —

 

  • Go to Settings (it should be a vertical ellipsis "…") in FontBase
  • Change the Root folder location to "C:/FontBase" (or C:\FontBase — not sure if it's front or backslash)

 

Very strange that Adobe XD didn't find my fonts to the default location FontBase put it (originally located in "C:\Users\%PROFILE%\FontBase"), so changing that location solved my issue.

 

Hopefully, this helps a lot of you out there!

Views

31.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 30, 2019 9
Adobe Community Professional ,
Jul 01, 2019

Copy link to clipboard

Copied

Hi, on which computer are you working? Windows or Mac Os?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 01, 2019 1
Community Beginner ,
Jul 01, 2019

Copy link to clipboard

Copied

WIndows 10.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 01, 2019 0
Adobe Community Professional ,
Jul 01, 2019

Copy link to clipboard

Copied

I wonder if it is because XD compacts the fonts.
Can you confirm if the whole font family is missing or is it just that you don't see the additional options in the initial Font Choice Drop Down.

For example in my Font Manager I can see Book Antiqua, Book Antiqua Bold, Book Antiqua Bold Italic, Book Antiqua Italic.
When I'm in XD all I see is Book Antiqua, but then in one of the drop downs I can choose between Bold, Italic, Bold Italic.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 01, 2019 1
New Here ,
Sep 18, 2019

Copy link to clipboard

Copied

I was having a VERY hard time with Adobe XD finding the fonts I activated with FontBase, BUT I have found the unusual solution to fix that problem by simply —

 

  • Go to Settings (it should be a vertical ellipsis "…") in FontBase
  • Change the Root folder location to "C:/FontBase" (or C:\FontBase — not sure if it's front or backslash)

 

Very strange that Adobe XD didn't find my fonts to the default location FontBase put it (originally located in "C:\Users\%PROFILE%\FontBase"), so changing that location solved my issue.

 

Hopefully, this helps a lot of you out there!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2019 7
New Here ,
Nov 19, 2019

Copy link to clipboard

Copied

It worked very well for me. Not Ideal, but it's a fix for now.

Thanks a lot!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 19, 2019 1
Explorer ,
Nov 27, 2019

Copy link to clipboard

Copied

Oh well, I did have problems with this before, believe this had been fixed (and is stated in the changelogs of both apps as far as I remember), hadn't used XD for a while, only to find it doesn't work anymore again. Thanks for the 'fix', that does it now!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 27, 2019 0
New Here ,
Sep 23, 2020

Copy link to clipboard

Copied

Thank you very much, you have saved my sanity! 😄 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 23, 2020 0
New Here ,
Sep 23, 2020

Copy link to clipboard

Copied

You are welcome 😊

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 23, 2020 0
Community Beginner ,
Mar 22, 2020

Copy link to clipboard

Copied

Thanks so much for this answer. You just solved a major gripe I had with XD even though it's a workaround

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 22, 2020 1
Adobe Community Professional ,
Mar 23, 2020

Copy link to clipboard

Copied

We are happy that your problem with Adobe XD has been resolved. If you need help in the future, contact us 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 23, 2020 1
New Here ,
May 22, 2020

Copy link to clipboard

Copied

Unfortunally non of the solutions works for me. I'm on Macos Catalina with latest XD. 

The Fonts are displayed in XD but not in the demos on ios iphone or ipad.

I tried everything mentioned in this threat.  Complete random if a cusstom font (mainly google fonts) works or not. Sometimes it works, sometimes not, sometimes days later. Its impossible to work with clients on projects if they cant see the right fonts. Guess i have to switch to figma or sketch.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 22, 2020 0