Highlighted

Linked Component Not Updating

New Here ,
Oct 25, 2019

Copy link to clipboard

Copied

I have a component library in one XD file. I'm designing in another XD file. I have a component I have updated in the component library and when I go to my design XD file it adds and Update All (1) button in the Components pane. It won't update the component when I click the Update All (1) button. If I right click on the component and select Update, nothing happens. I can update other components. Anyone else experience this and have a fix?

I tried that several times. The only way I was able to fix it was to revert back to a version where it wasn't broken and redo my work. Not sure what I did that would of put me in that state.

Views

1.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Linked Component Not Updating

New Here ,
Oct 25, 2019

Copy link to clipboard

Copied

I have a component library in one XD file. I'm designing in another XD file. I have a component I have updated in the component library and when I go to my design XD file it adds and Update All (1) button in the Components pane. It won't update the component when I click the Update All (1) button. If I right click on the component and select Update, nothing happens. I can update other components. Anyone else experience this and have a fix?

I tried that several times. The only way I was able to fix it was to revert back to a version where it wasn't broken and redo my work. Not sure what I did that would of put me in that state.

Views

1.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 25, 2019 1
Adobe Community Professional ,
Oct 26, 2019

Copy link to clipboard

Copied

Try right-click on the component not getting updated and select the option of Edit Master in Source Document and then edit it and check if it gets updated. 

Vishu Aggarwal

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 26, 2019 1
New Here ,
Oct 28, 2019

Copy link to clipboard

Copied

I tried that several times. The only way I was able to fix it was to revert back to a version where it wasn't broken and redo my work. Not sure what I did that would of put me in that state.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 28, 2019 1
New Here ,
Nov 14, 2019

Copy link to clipboard

Copied

This does not work for me either and going back and redoing my work again is not a solution. Since the latest update I've had to uninstall and reinstall XD twice now after it crashes / fails to save in the cloud and then won't let me open the app again. Surely there must be another workaround for updating linked components. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 14, 2019 1
Explorer ,
Dec 14, 2019

Copy link to clipboard

Copied

I too experience frequent failures to update components. Has been reported widely across the forum by myself and others, yet Adobe mostly just asks us to describe the problem over again. Adobe kindly fix this problem, it's killing my productivity!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 14, 2019 1
Community Beginner ,
Jul 27, 2020

Copy link to clipboard

Copied

Don't think this problem has been fixed yet. Even when I make sure to edit the main component - the links will not udpate across all connected components. Very frusterating! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 27, 2020 0
Community Beginner ,
Nov 15, 2019

Copy link to clipboard

Copied

Hello!

 

I've been having this trouble lately myself and after some fiddling around I found a solution that almost worked for me. No idea if this will work for anyone else as I've only just had this one partial success which resulted in a slightly different problem. 🙂

 

I've been assembling a decently sized styleguide that has just grown a wee bit more complex due to my enthusiasm for the new component states feature. I create new components in this styleguide file and create hi-fidelity mocks in another couple of files. Recently, after making changes to the master components in the styleguide, I found that it was impossible to update the components in the mocks file. I'd click the Update All button, it would flash, but nothing would happen. I'd right click on the component in the asset library but again, nothing would happen. 

 

During one troubleshooting sequence, I noticed that upon reopening XD and reopening the styleguide file, it immediately started saving. I guessed that it was possible that the original change in the component hadn't entirely completed. So I let that save finish, then altered the default state in the component a small amount, just to get a change registered. I let XD save again. After that, I opened up the mocks file, pushed the Update All button and, after a moment, the update went through!

 

I thought my troubles were over, but a new problem arose... while inside the mocks file, I was now unable to drag the new component from the asset library onto the canvas. Dragging other components to the canvas also failed to work. After restarting and fiddling around, I found that I could drag other elements into the canvas, but as soon as I tried to drag the component which previously failed to update, nothing was able to be added to the canvas. 

 

I went into the styleguide file and found that everything worked just fine there, so I'm thinking there is an issue with an impartially complete update from one file to another through the linked assets feature. 

 

I'm still working on this, so if anyone has any ideas on what might be going on, I would love to hear them. I'll update here if I find out anything new.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 15, 2019 0
Community Beginner ,
Nov 15, 2019

Copy link to clipboard

Copied

Ok!  

An update. 

 

The component that had originally failed to update in an external file was composed of a text item and another component nested within it. Both the parent component and the internal component had multiple states. 

I ungrouped the internal component, simplified the states for the entire thing, and saved the styleguide file. Once I reopened the mocks file where it became impossible to drag any assets to the canvas, I found that the simplified component was both updatable and I could drag it (and other components) to the canvas. Everything fixed! (hoping they stay that way.)

 

So, I'm going to be a little more careful with nested components with multiple states in the future and hope to avoid this. 

 

Cheers!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 15, 2019 2
Community Beginner ,
Mar 04, 2020

Copy link to clipboard

Copied

I had the same problem, solved, but the solution wasn´t satisfatory for me.

Scenario

I have a component in the cloud with all states of a text field (inactive, focused, activated, error and disabled). In the same component, I have all states of a dropdown too, like inactive, opened with hover on all options (it is another component inside the main component), etc. After an improvement, the link stopped working in the another project.

Workarounds that doesn´t work
1. I tried to reset to master state;

2. I tried to click in the plus icon in assets and click in the document on cloud to try to relink;

3. I tried to copy and paste the component again;

4. I tried to click in the blue link icon than click update in the flyout menu;

5. I tried to sign out of Adobe XD and Creative Cloud and sign back in;

6. I made a local copy of the cloud project, deleted it from cloud, put it on cloud again and relink;

XD version
27.2.12.4 - Creative Cloud sync 4.3.28.24
I´m a Windows user (with the last update)

Solution
Ungroup the component with hover inside the main/hibrid component text field.

Maybe the problem in this case isn´t the update but the the difficulty of adobe XD dealing with nested components. I spent 4 hours to reach that conclusion. Soooo time consuming... and unsatisfactory at all.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2020 3
New Here ,
Apr 14, 2020

Copy link to clipboard

Copied

I have the same problem.

But some of my component has well being updated but not each state of my component. And not all component in my file. I don't understand.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 14, 2020 2
Community Beginner ,
Apr 14, 2020

Copy link to clipboard

Copied

Yes, it's so difficult because theoretically you have infinite
possibilities but, at really, a sad and restricted reality.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 14, 2020 3
Community Beginner ,
May 26, 2020

Copy link to clipboard

Copied

I uninstalled Xd, then re-installed it and the components updated okay. Sometimes I just have to smash the "update" button over and over like I'm playing Mario Party before it'll work as well.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 26, 2020 0
Explorer ,
May 27, 2020

Copy link to clipboard

Copied

Update bug is known. Would be nice if someone from Adobe team would give us some info about fixing status...

 

Solutions:

  • for some works smash update all or right-mouseclick on single component > update
  • for others, reinstall (if none, even single component doesn't update)
  • sometimes you need to do small change in source file (in component library) and re-save file
  • in my case, somehow I wasn't able to update one of a locally modified (width) components. Had to reset all modified instances - lucky me, had only 9 instances where it was used

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 27, 2020 0